aboutsummaryrefslogtreecommitdiffstats
path: root/www/nginx
diff options
context:
space:
mode:
authorosa <osa@FreeBSD.org>2010-09-28 14:32:17 +0800
committerosa <osa@FreeBSD.org>2010-09-28 14:32:17 +0800
commitaf7aaf58e8d2143b22ecac73514c4af9721bc1c2 (patch)
tree481d8b2736aa385280ef0431faca8cf6176c1140 /www/nginx
parent60ff6e79023566cb8c787af005e444ff1db01986 (diff)
downloadfreebsd-ports-gnome-af7aaf58e8d2143b22ecac73514c4af9721bc1c2.tar.gz
freebsd-ports-gnome-af7aaf58e8d2143b22ecac73514c4af9721bc1c2.tar.zst
freebsd-ports-gnome-af7aaf58e8d2143b22ecac73514c4af9721bc1c2.zip
Update from 0.7.67 to latest stable version 0.8.51 by merge changes from
www/nginx-devel. Update CONFLIGS and temporary mark IGNORE www/nginx-devel, because latest version available from www/nginx. <Announcement> Now the 0.8.x branch becomes a stable branch. The new features have been appeared during 0.8 development: o named regular expression captures; o file AIO in FreeBSD and Linux; o SSL CRL; o SCGI and uwsgi modules. </Announcement>
Diffstat (limited to 'www/nginx')
-rw-r--r--www/nginx/Makefile18
-rw-r--r--www/nginx/distinfo6
-rw-r--r--www/nginx/files/extra-patch-ngx_http_echo_time.c20
-rw-r--r--www/nginx/files/extra-patch-ngx_http_udplog_module.c23
-rw-r--r--www/nginx/pkg-plist6
5 files changed, 44 insertions, 29 deletions
diff --git a/www/nginx/Makefile b/www/nginx/Makefile
index e05b015e5744..e1ecf7321d1d 100644
--- a/www/nginx/Makefile
+++ b/www/nginx/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= nginx
-PORTVERSION= 0.7.67
-PORTREVISION= 1
+PORTVERSION= 0.8.51
CATEGORIES= www
MASTER_SITES= http://sysoev.ru/nginx/
MASTER_SITES+= ${MASTER_SITE_LOCAL}
@@ -21,6 +20,7 @@ LICENSE= BSD
OPTIONS= DEBUG "Enable nginx debugging" off \
DEBUGLOG "Enable debug log (--with-debug)" off \
+ FILE_AIO "Enable file aio" off \
IPV6 "Enable IPv6" off \
GOOGLE_PERFTOOLS "Enable google perftools module" off \
HTTP_MODULE "Enable HTTP module" on \
@@ -122,6 +122,10 @@ STRIP= #do not strip if nginx with debug information
CONFIGURE_ARGS+=--with-debug
.endif
+.if defined(WITH_FILE_AIO)
+CONFIGURE_ARGS+=--with-file-aio
+.endif
+
.if defined(WITH_IPV6)
CONFIGURE_ARGS+=--with-ipv6
CATEGORIES+= ipv6
@@ -134,8 +138,10 @@ CONFIGURE_ARGS+=--with-google_perftools_module
.if defined(WITH_HTTP_MODULE)
CONFIGURE_ARGS+=--http-client-body-temp-path=${NGINX_TMPDIR}/client_body_temp \
- --http-proxy-temp-path=${NGINX_TMPDIR}/proxy_temp \
--http-fastcgi-temp-path=${NGINX_TMPDIR}/fastcgi_temp \
+ --http-proxy-temp-path=${NGINX_TMPDIR}/proxy_temp \
+ --http-scgi-temp-path=${NGINX_TMPDIR}/scgi_temp \
+ --http-uwsgi-temp-path=${NGINX_TMPDIR}/uwsgi_temp \
--http-log-path=${NGINX_ACCESSLOG}
.if defined(WITH_HTTP_ACCEPT_LANGUAGE)
@@ -187,7 +193,6 @@ MASTER_SITES+= ${MASTER_SITE_LOCAL:S/$/:echo/}
MASTER_SITE_SUBDIR+= osa/:echo
DISTFILES+= ngx_echo_module-${NGINX_ECHO_MODULE_VERSION}.tar.gz:echo
CONFIGURE_ARGS+=--add-module=${WRKDIR}/ngx_echo_module-${NGINX_ECHO_MODULE_VERSION}
-EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-ngx_http_echo_time.c
.endif
.if defined(WITH_HEADERS_MORE_MODULE)
@@ -411,6 +416,7 @@ NGINX_UDPLOG_MODULE_VERSION= 1.0.0
MASTER_SITES+= http://www.grid.net.ru/nginx/download/:udplog
DISTFILES+= nginx_udplog_module-${NGINX_UDPLOG_MODULE_VERSION}.tar.gz:udplog
CONFIGURE_ARGS+=--add-module=${WRKDIR}/nginx_udplog_module-${NGINX_UDPLOG_MODULE_VERSION}
+EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-ngx_http_udplog_module.c
.endif
.if defined(WITH_WWW)
@@ -481,7 +487,7 @@ post-patch:
${WRKDIR}/ngx_supervisord-${NGINX_SUPERVISORD_MODULE_VERSION}/patches/ngx_http_upstream_fair_module.patch )
( cd ${WRKSRC} && \
${PATCH} -p0 < \
- ${WRKDIR}/ngx_supervisord-${NGINX_SUPERVISORD_MODULE_VERSION}/patches/ngx_http_upstream_init_busy-0.8.0.patch )
+ ${WRKDIR}/ngx_supervisord-${NGINX_SUPERVISORD_MODULE_VERSION}/patches/ngx_http_upstream_init_busy-0.8.17.patch )
.endif
do-build:
@@ -494,7 +500,7 @@ do-install:
.for i in koi-utf koi-win win-utf
${INSTALL_DATA} ${WRKSRC}/conf/${i} ${ETCDIR}
.endfor
-.for i in fastcgi_params mime.types nginx.conf
+.for i in fastcgi_params mime.types nginx.conf scgi_params uwsgi_params
[ -f ${ETCDIR}/${i} ] || \
${INSTALL_DATA} ${WRKSRC}/conf/${i} ${ETCDIR}
${INSTALL_DATA} ${WRKSRC}/conf/${i} ${ETCDIR}/${i}-dist
diff --git a/www/nginx/distinfo b/www/nginx/distinfo
index b6f75ab161bb..e11e4f94a805 100644
--- a/www/nginx/distinfo
+++ b/www/nginx/distinfo
@@ -1,6 +1,6 @@
-MD5 (nginx-0.7.67.tar.gz) = b6e175f969d03a4d3c5643aaabc6a5ff
-SHA256 (nginx-0.7.67.tar.gz) = 396c95055d041950831a9ee8ff54473436f212cd770c6bad0aa795637007f747
-SIZE (nginx-0.7.67.tar.gz) = 608462
+MD5 (nginx-0.8.51.tar.gz) = 61a58cd2c0cbc433ced4020b66cd6e3d
+SHA256 (nginx-0.8.51.tar.gz) = 35f92b15105990dc3b180dc8c8da61eafec1c2962720556d945a0b421efc612c
+SIZE (nginx-0.8.51.tar.gz) = 649122
MD5 (nginx_accept_language_module.tar.gz) = 330a8d3b2376fb476b5d3111a7905ec3
SHA256 (nginx_accept_language_module.tar.gz) = 7a4c2d42a83c5b6efd2b7b13ad232850b6ab0ca4261df6b46fb7d2d2738b1c0a
SIZE (nginx_accept_language_module.tar.gz) = 3299
diff --git a/www/nginx/files/extra-patch-ngx_http_echo_time.c b/www/nginx/files/extra-patch-ngx_http_echo_time.c
deleted file mode 100644
index 125a75bce5d6..000000000000
--- a/www/nginx/files/extra-patch-ngx_http_echo_time.c
+++ /dev/null
@@ -1,20 +0,0 @@
---- ../ngx_echo_module-0.30/src/ngx_http_echo_timer.c.orig 2010-06-07 16:32:51.000000000 +0400
-+++ ../ngx_echo_module-0.30/src/ngx_http_echo_timer.c 2010-06-07 16:34:32.000000000 +0400
-@@ -25,7 +25,7 @@
-
- /* force the ngx timer to update */
-
--#if defined nginx_version && nginx_version >= 8035
-+#if defined nginx_version && (nginx_version >= 8035 || nginx_version >= 7066)
- ngx_time_update();
- #else
- ngx_time_update(0, 0);
-@@ -62,7 +62,7 @@
-
- /* force the ngx timer to update */
-
--#if defined nginx_version && nginx_version >= 8035
-+#if defined nginx_version && (nginx_version >= 8035 || nginx_version >= 7066)
- ngx_time_update();
- #else
- ngx_time_update(0, 0);
diff --git a/www/nginx/files/extra-patch-ngx_http_udplog_module.c b/www/nginx/files/extra-patch-ngx_http_udplog_module.c
new file mode 100644
index 000000000000..3a369c21a272
--- /dev/null
+++ b/www/nginx/files/extra-patch-ngx_http_udplog_module.c
@@ -0,0 +1,23 @@
+--- ../nginx_udplog_module-1.0.0/ngx_http_udplog_module.c.orig 2010-01-11 19:16:46.000000000 +0300
++++ ../nginx_udplog_module-1.0.0/ngx_http_udplog_module.c 2010-01-11 19:20:17.000000000 +0300
+@@ -280,7 +280,7 @@
+ uc->sockaddr = endpoint->peer_addr.sockaddr;
+ uc->socklen = endpoint->peer_addr.socklen;
+ uc->server = endpoint->peer_addr.name;
+-#if defined nginx_version && nginx_version >= 7054
++#if defined nginx_version && ( nginx_version >= 7054 && nginx_version < 8032 )
+ uc->log = &cf->cycle->new_log;
+ #else
+ uc->log = cf->cycle->new_log;
+@@ -335,7 +335,11 @@
+ }
+
+ if ((size_t) n != (size_t) len) {
++#if defined nginx_version && nginx_version >= 8032
++ ngx_log_error(NGX_LOG_CRIT, &uc->log, 0, "send() incomplete");
++#else
+ ngx_log_error(NGX_LOG_CRIT, uc->log, 0, "send() incomplete");
++#endif
+ return NGX_ERROR;
+ }
+
diff --git a/www/nginx/pkg-plist b/www/nginx/pkg-plist
index aca447f49243..7a85efd5c1e4 100644
--- a/www/nginx/pkg-plist
+++ b/www/nginx/pkg-plist
@@ -4,6 +4,12 @@
@exec if [ ! -f %D/%%ETCDIR%%/fastcgi_params ] ; then cp -p %D/%F %B/fastcgi_params; fi
%%ETCDIR%%/koi-utf
%%ETCDIR%%/koi-win
+@unexec if cmp -s %D/%%ETCDIR%%/scgi_params-dist %D/%%ETCDIR%%/scgi_params; then rm -f %D/%%ETCDIR%%/scgi_params; fi
+%%ETCDIR%%/scgi_params-dist
+@exec if [ ! -f %D/%%ETCDIR%%/scgi_params ] ; then cp -p %D/%F %B/scgi_params; fi
+@unexec if cmp -s %D/%%ETCDIR%%/uwsgi_params-dist %D/%%ETCDIR%%/uwsgi_params; then rm -f %D/%%ETCDIR%%/uwsgi_params; fi
+%%ETCDIR%%/uwsgi_params-dist
+@exec if [ ! -f %D/%%ETCDIR%%/uwsgi_params ] ; then cp -p %D/%F %B/uwsgi_params; fi
%%ETCDIR%%/win-utf
@unexec if cmp -s %D/%%ETCDIR%%/mime.types-dist %D/%%ETCDIR%%/mime.types; then rm -f %D/%%ETCDIR%%/mime.types; fi
%%ETCDIR%%/mime.types-dist