aboutsummaryrefslogtreecommitdiffstats
path: root/www/nginx
diff options
context:
space:
mode:
authorosa <osa@FreeBSD.org>2015-03-13 08:41:05 +0800
committerosa <osa@FreeBSD.org>2015-03-13 08:41:05 +0800
commitca52d934d8550f75676338f2fc738137edc2d2bf (patch)
tree9d500e9aec2769c130b7864e1ee72383d91edd8a /www/nginx
parentc596176fc3bf07843f3c7f33f68bde2fb2662a4b (diff)
downloadfreebsd-ports-gnome-ca52d934d8550f75676338f2fc738137edc2d2bf.tar.gz
freebsd-ports-gnome-ca52d934d8550f75676338f2fc738137edc2d2bf.tar.zst
freebsd-ports-gnome-ca52d934d8550f75676338f2fc738137edc2d2bf.zip
Upgrade from 5.0.2 to 5.0.4:
o) www/rubygem-passenger; o) third-party modules for www/nginx and www/nginx-devel. <ChangeLog> Release 5.0.3 ------------- * [Standalone] When using the builtin engine, `passenger start` may crash during startup due to an initialization race condition. This has been fixed. * [Enterprise] Fixes a bug in passenger-irb. Running passenger-irb without a PID parameter worked, but running it with a PID parameter didn't. * Fixes an integer overflow that resulted in a file descriptor leak and stalled client connections. Closes GH-1412. * Truncates Passenger source code paths in logs (to 3 chars) to reduce redundant info. Closes GH-1383. * Fixes invalid JSON output for non-finite double values (e.g. from the HTTP JSON API). Closes GH-1408. * All hooks now set the `PASSENGER_HOOK_NAME` environment variable. This variable is set to the name of the hook that is being called. * The Ruby handler no longer tries to call #force_encoding on response body strings, which fixes an incompatibility with apps/libraries that return frozen body strings. Closes GH-1414. * If the Ruby handler crashes while processing a Rack response body, it will now no longer stall the connection. * Fixes env.SERVER_PORT containing 80 instead of 443 when using https on default port. Closes GH-1421. * We now handle errors in the `poll()` system call better. This might fix some crashes during shutdown which manifest on FreeBSD. </ChangeLog>
Diffstat (limited to 'www/nginx')
-rw-r--r--www/nginx/Makefile2
-rw-r--r--www/nginx/distinfo4
-rw-r--r--www/nginx/files/extra-patch-passenger-build-nginx.rb4
3 files changed, 5 insertions, 5 deletions
diff --git a/www/nginx/Makefile b/www/nginx/Makefile
index 722c19198387..ac117721ed29 100644
--- a/www/nginx/Makefile
+++ b/www/nginx/Makefile
@@ -655,7 +655,7 @@ CONFIGURE_ARGS+=--without-http_rewrite_module \
.endif
.if ${PORT_OPTIONS:MPASSENGER}
-PASSENGER_VERSION= 5.0.2
+PASSENGER_VERSION= 5.0.4
MASTER_SITES+= http://s3.amazonaws.com/phusion-passenger/releases/:passenger
DISTFILES+= passenger-${PASSENGER_VERSION}.tar.gz:passenger
CONFIGURE_ARGS+=--add-module=${WRKDIR}/passenger-${PASSENGER_VERSION}/ext/nginx
diff --git a/www/nginx/distinfo b/www/nginx/distinfo
index 052651a10be9..fc4b3d7c4c6d 100644
--- a/www/nginx/distinfo
+++ b/www/nginx/distinfo
@@ -74,8 +74,8 @@ SHA256 (modsecurity-2.9.0.tar.gz) = e2bbf789966c1f80094d88d9085a81bde082b2054f8e
SIZE (modsecurity-2.9.0.tar.gz) = 4246467
SHA256 (naxsi-core-0.50.tgz) = 7cece5f9d9c5df9e09af1e1023bc8e04bbbbe953e67461b893b8240e82ca52ef
SIZE (naxsi-core-0.50.tgz) = 49809
-SHA256 (passenger-5.0.2.tar.gz) = 93aa200fdc47597c0dcbe32ed6c55af0751114d2c268e4d30ff7f3d7afdbebe8
-SIZE (passenger-5.0.2.tar.gz) = 5287262
+SHA256 (passenger-5.0.4.tar.gz) = 5c29f2c1407db515ddccd540443cb34bff7ca180b3e269c2e28a34ad795f99f6
+SIZE (passenger-5.0.4.tar.gz) = 5289792
SHA256 (ngx_postgres-0.9.tar.gz) = aac0141e73b5c440927b7e040072f120b36e49deb2ff36ad00ff96a80622fbec
SIZE (ngx_postgres-0.9.tar.gz) = 41022
SHA256 (openresty-rds-csv-nginx-module-v0.05-0-g607e26b.tar.gz) = d5f14e45c6dc0d039ad52ae889775b5af1ff80a1c8edb69361c1581aca5d0b8f
diff --git a/www/nginx/files/extra-patch-passenger-build-nginx.rb b/www/nginx/files/extra-patch-passenger-build-nginx.rb
index b23af830a95f..d605262a52c6 100644
--- a/www/nginx/files/extra-patch-passenger-build-nginx.rb
+++ b/www/nginx/files/extra-patch-passenger-build-nginx.rb
@@ -1,5 +1,5 @@
---- ../passenger-5.0.2/build/nginx.rb.orig 2013-10-27 02:00:00.000000000 +0400
-+++ ../passenger-5.0.2/build/nginx.rb 2015-03-07 06:07:38.000000000 +0300
+--- ../passenger-5.0.4/build/nginx.rb.orig 2013-10-27 02:00:00.000000000 +0400
++++ ../passenger-5.0.4/build/nginx.rb 2015-03-07 06:07:38.000000000 +0300
@@ -32,6 +32,7 @@
desc "Build Nginx support files"
task :nginx => [