aboutsummaryrefslogtreecommitdiffstats
path: root/www/nginx
diff options
context:
space:
mode:
authorosa <osa@FreeBSD.org>2005-10-12 22:36:42 +0800
committerosa <osa@FreeBSD.org>2005-10-12 22:36:42 +0800
commit13e45544dab3e09b1e89cf8a212acd9580241a3f (patch)
tree0678527b2f36c43935d35f11cd9371d72d837820 /www/nginx
parent7e28e2cf762d8c19e404c8854cec1446550d480e (diff)
downloadfreebsd-ports-gnome-13e45544dab3e09b1e89cf8a212acd9580241a3f.tar.gz
freebsd-ports-gnome-13e45544dab3e09b1e89cf8a212acd9580241a3f.tar.zst
freebsd-ports-gnome-13e45544dab3e09b1e89cf8a212acd9580241a3f.zip
Update to 0.3.2.
Update port infrastructure: files/nginx.sh -> files/nginx.sh.in. Add configtest extra command for nginx.sh script (1). Submitted by: skv (1)
Diffstat (limited to 'www/nginx')
-rw-r--r--www/nginx/Makefile4
-rw-r--r--www/nginx/distinfo4
-rw-r--r--www/nginx/files/nginx.sh.in (renamed from www/nginx/files/nginx.sh)12
3 files changed, 16 insertions, 4 deletions
diff --git a/www/nginx/Makefile b/www/nginx/Makefile
index a9fd9c171947..a8b3720e5a6c 100644
--- a/www/nginx/Makefile
+++ b/www/nginx/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= nginx
-PORTVERSION= 0.2.6
+PORTVERSION= 0.3.2
CATEGORIES= www
MASTER_SITES= http://sysoev.ru/nginx/
MASTER_SITES+= ${MASTER_SITE_LOCAL}
@@ -89,7 +89,7 @@ RC_SCRIPTS_SUB=PREFIX=${PREFIX} RC_SUBR=${RC_SUBR}
post-extract:
@${SED} ${RC_SCRIPTS_SUB:S/$/!g/:S/^/ -e s!%%/:S/=/%%!/} \
- ${FILESDIR}/nginx.sh > ${WRKSRC}/nginx.sh
+ ${FILESDIR}/nginx.sh.in > ${WRKSRC}/nginx.sh
post-patch:
@${REINPLACE_CMD} 's!%%HTTP_PORT%%!${HTTP_PORT}!; \
diff --git a/www/nginx/distinfo b/www/nginx/distinfo
index 49cd59479275..4fc03a14c414 100644
--- a/www/nginx/distinfo
+++ b/www/nginx/distinfo
@@ -1,2 +1,2 @@
-MD5 (nginx-0.2.6.tar.gz) = 8e60eb03dd75226d21068f8d98362152
-SIZE (nginx-0.2.6.tar.gz) = 329236
+MD5 (nginx-0.3.2.tar.gz) = 848a0dd8f6362be8f361a62ea39d1539
+SIZE (nginx-0.3.2.tar.gz) = 331121
diff --git a/www/nginx/files/nginx.sh b/www/nginx/files/nginx.sh.in
index da3e9d13d694..b28a5bacb706 100644
--- a/www/nginx/files/nginx.sh
+++ b/www/nginx/files/nginx.sh.in
@@ -23,6 +23,18 @@ name="nginx"
rcvar=`set_rcvar`
command="%%PREFIX%%/sbin/nginx"
+extra_commands="configtest"
+
+configtest_cmd="configtest_cmd"
+configtest_cmd() {
+ echo "Configuration syntax test for ${name}."
+ if ${command} -t; then
+ :
+ else
+ err 8 "FATAL: bad config for ${name}"
+ fi
+}
+
load_rc_config $name
pidfile="${nginx_pidfile}"