aboutsummaryrefslogtreecommitdiffstats
path: root/www/nginx
diff options
context:
space:
mode:
authorosa <osa@FreeBSD.org>2012-06-21 14:35:24 +0800
committerosa <osa@FreeBSD.org>2012-06-21 14:35:24 +0800
commitec0d5a3cfecf5680d4c9492eeda0eadf53e7b128 (patch)
tree334f1b21fe29269db052e016f34827285af09a72 /www/nginx
parentfe1987c784ea4f6afcf0f342efe14597dc14716d (diff)
downloadfreebsd-ports-gnome-ec0d5a3cfecf5680d4c9492eeda0eadf53e7b128.tar.gz
freebsd-ports-gnome-ec0d5a3cfecf5680d4c9492eeda0eadf53e7b128.tar.zst
freebsd-ports-gnome-ec0d5a3cfecf5680d4c9492eeda0eadf53e7b128.zip
Add third-party tcp_proxy module, ver.0.26,
https://github.com/yaoweibin/nginx_tcp_proxy_module/ Requested by: Weibin Yao <yaoweibin@gmail.com>
Diffstat (limited to 'www/nginx')
-rw-r--r--www/nginx/Makefile16
-rw-r--r--www/nginx/distinfo2
2 files changed, 18 insertions, 0 deletions
diff --git a/www/nginx/Makefile b/www/nginx/Makefile
index d6e1b61f873f..e186fff94187 100644
--- a/www/nginx/Makefile
+++ b/www/nginx/Makefile
@@ -97,6 +97,7 @@ OPTIONS_DEFINE= \
SRCACHE \
SUPERVISORD \
SYSLOG_SUPPORT \
+ TCP_PROXY \
UDPLOG \
XRID_HEADER \
XSS \
@@ -181,6 +182,7 @@ SLOWFS_CACHE_DESC= 3rd party slowfs_cache module
SRCACHE_DESC= 3rd party srcache module
SUPERVISORD_DESC= 3rd party supervisord module
SYSLOG_SUPPORT_DESC= 3rd party syslog support
+TCP_PROXY_DESC= 3rd party tcp_proxy module
UDPLOG_DESC= 3rd party udplog (syslog) module
XRID_HEADER_DESC= 3rd party x-rid header module
XSS_DESC= 3rd party xss module
@@ -723,6 +725,15 @@ CONFIGURE_ARGS+=--with-syslog --with-syslog-facility=${NGINX_SYSLOG_SUPPORT_FACI
EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-syslog_support
.endif
+.if ${PORT_OPTIONS:MTCP_PROXY}
+NGINX_TCP_PROXY_VERSION= 0.26
+GIT_TCP_PROXY_VERSION= 0-gb83e5a6
+FETCH_ARGS= -pRr
+MASTER_SITES+= https://github.com/yaoweibin/nginx_tcp_proxy_module/tarball/v${NGINX_TCP_PROXY_VERSION}/:tcp_proxy
+DISTFILES+= yaoweibin-nginx_tcp_proxy_module-v${NGINX_TCP_PROXY_VERSION}-${GIT_TCP_PROXY_VERSION}.tar.gz:tcp_proxy
+CONFIGURE_ARGS+=--add-module=${WRKDIR}/yaoweibin-nginx_tcp_proxy_module-${GIT_TCP_PROXY_VERSION:S/^0-g//}
+.endif
+
.if ${PORT_OPTIONS:MUDPLOG}
NGINX_UDPLOG_VERSION= 1.0.0
MASTER_SITES+= http://www.grid.net.ru/nginx/download/:udplog
@@ -904,6 +915,11 @@ post-patch:
${PATCH} -p0 < \
${WRKDIR}/ngx_supervisord-${NGINX_SUPERVISORD_VERSION}/patches/ngx_http_upstream_init_busy-0.8.17.patch )
.endif
+.if ${PORT_OPTIONS:MTCP_PROXY}
+ ( cd ${WRKSRC} && \
+ ${PATCH} -p1 < \
+ ${WRKDIR}/yaoweibin-nginx_tcp_proxy_module-${GIT_TCP_PROXY_VERSION:S/^0-g//}/tcp.patch )
+.endif
.if ${PORT_OPTIONS:MICONV}
@${REINPLACE_CMD} \
's!%%PREFIX%%!${LOCALBASE}!g' \
diff --git a/www/nginx/distinfo b/www/nginx/distinfo
index 19ef3e988df5..ab78e37637c3 100644
--- a/www/nginx/distinfo
+++ b/www/nginx/distinfo
@@ -90,6 +90,8 @@ SHA256 (agentzh-srcache-nginx-module-v0.13rc8-0-g5237f26.tar.gz) = 2cb76adb4cf20
SIZE (agentzh-srcache-nginx-module-v0.13rc8-0-g5237f26.tar.gz) = 58234
SHA256 (ngx_supervisord-1.4.tar.gz) = 0954a4efb1b955692acf523e169221146d6aa93ad1643c9f2482f75a1fbf9e3b
SIZE (ngx_supervisord-1.4.tar.gz) = 19351
+SHA256 (yaoweibin-nginx_tcp_proxy_module-v0.26-0-gb83e5a6.tar.gz) = 4d843b8d0511b269382938ba5546f902ec24dbfa76c12f6bd6961d7aaaf3866a
+SIZE (yaoweibin-nginx_tcp_proxy_module-v0.26-0-g9677e00.tar.gz) = 127346
SHA256 (nginx_udplog_module-1.0.0.tar.gz) = e0c0bfa524c3a675ad6c08b916d08e57ef45f9818cb8a0d848c2c83785c6e659
SIZE (nginx_udplog_module-1.0.0.tar.gz) = 6284
SHA256 (gabor-nginx-x-rid-header-0daa3cc.tar.gz) = 136239b8f9ab2fbefb2aabc6897d3f12cc8063ce817901f9b8a624e12fbc6035