aboutsummaryrefslogtreecommitdiffstats
path: root/www/nginx
diff options
context:
space:
mode:
authorosa <osa@FreeBSD.org>2013-06-23 20:08:39 +0800
committerosa <osa@FreeBSD.org>2013-06-23 20:08:39 +0800
commitf3229da8af0466e08b3461ac91a8b638d1d1719b (patch)
tree9b55f4e2494d375a14ebdcc69227e4dda82edf95 /www/nginx
parent8a4e5193fc188863db8b6b83a184020bb885a7d2 (diff)
downloadfreebsd-ports-gnome-f3229da8af0466e08b3461ac91a8b638d1d1719b.tar.gz
freebsd-ports-gnome-f3229da8af0466e08b3461ac91a8b638d1d1719b.tar.zst
freebsd-ports-gnome-f3229da8af0466e08b3461ac91a8b638d1d1719b.zip
If nginx was compiled without --with-http_ssl_module, but with some
other module which uses OpenSSL (e.g. --with-mail_ssl_module), insufficient preprocessor check resulted in build failure. The problem was introduced by e0a3714a36f8 (1.3.14). Reported by: "M.S. Babaei" <info@babaei.net> Patch obtained from: http://hg.nginx.org/nginx/rev/9d83ec073c51
Diffstat (limited to 'www/nginx')
-rw-r--r--www/nginx/Makefile1
-rw-r--r--www/nginx/files/patch-fix-mail-ssl79
2 files changed, 80 insertions, 0 deletions
diff --git a/www/nginx/Makefile b/www/nginx/Makefile
index 112564168885..52b58eee45e2 100644
--- a/www/nginx/Makefile
+++ b/www/nginx/Makefile
@@ -3,6 +3,7 @@
PORTNAME= nginx
PORTVERSION= 1.4.1
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= www
MASTER_SITES= http://nginx.org/download/
diff --git a/www/nginx/files/patch-fix-mail-ssl b/www/nginx/files/patch-fix-mail-ssl
new file mode 100644
index 000000000000..7836236ad21f
--- /dev/null
+++ b/www/nginx/files/patch-fix-mail-ssl
@@ -0,0 +1,79 @@
+
+# HG changeset patch
+# User Maxim Dounin <mdounin@mdounin.ru>
+# Date 1368283770 -14400
+# Node ID 9d83ec073c514acec7adc84ee15d74692a5def7a
+# Parent 3494f14aa46a098bfcb4a1dc24acc7826cdd603b
+Fixed build with --with-mail_ssl_module.
+
+If nginx was compiled without --with-http_ssl_module, but with some
+other module which uses OpenSSL (e.g. --with-mail_ssl_module), insufficient
+preprocessor check resulted in build failure. The problem was introduced
+by e0a3714a36f8 (1.3.14).
+
+Reported by Roman Arutyunyan.
+
+diff -r 3494f14aa46a -r 9d83ec073c51 src/http/ngx_http.h
+--- src/http/ngx_http.h Sat May 11 18:49:19 2013 +0400
++++ src/http/ngx_http.h Sat May 11 18:49:30 2013 +0400
+@@ -89,7 +89,7 @@
+ void ngx_http_init_connection(ngx_connection_t *c);
+ void ngx_http_close_connection(ngx_connection_t *c);
+
+-#ifdef SSL_CTRL_SET_TLSEXT_HOSTNAME
++#if (NGX_HTTP_SSL && defined SSL_CTRL_SET_TLSEXT_HOSTNAME)
+ int ngx_http_ssl_servername(ngx_ssl_conn_t *ssl_conn, int *ad, void *arg);
+ #endif
+
+diff -r 3494f14aa46a -r 9d83ec073c51 src/http/ngx_http_request.c
+--- src/http/ngx_http_request.c Sat May 11 18:49:19 2013 +0400
++++ src/http/ngx_http_request.c Sat May 11 18:49:30 2013 +0400
+@@ -1955,7 +1955,7 @@
+
+ hc = r->http_connection;
+
+-#ifdef SSL_CTRL_SET_TLSEXT_HOSTNAME
++#if (NGX_HTTP_SSL && defined SSL_CTRL_SET_TLSEXT_HOSTNAME)
+
+ if (hc->ssl_servername) {
+ if (hc->ssl_servername->len == host->len
+@@ -1986,7 +1986,7 @@
+ return NGX_ERROR;
+ }
+
+-#ifdef SSL_CTRL_SET_TLSEXT_HOSTNAME
++#if (NGX_HTTP_SSL && defined SSL_CTRL_SET_TLSEXT_HOSTNAME)
+
+ if (hc->ssl_servername) {
+ ngx_http_ssl_srv_conf_t *sscf;
+@@ -2053,7 +2053,7 @@
+
+ sn = virtual_names->regex;
+
+-#ifdef SSL_CTRL_SET_TLSEXT_HOSTNAME
++#if (NGX_HTTP_SSL && defined SSL_CTRL_SET_TLSEXT_HOSTNAME)
+
+ if (r == NULL) {
+ ngx_http_connection_t *hc;
+@@ -2085,7 +2085,7 @@
+ return NGX_DECLINED;
+ }
+
+-#endif /* SSL_CTRL_SET_TLSEXT_HOSTNAME */
++#endif /* NGX_HTTP_SSL && defined SSL_CTRL_SET_TLSEXT_HOSTNAME */
+
+ for (i = 0; i < virtual_names->nregex; i++) {
+
+diff -r 3494f14aa46a -r 9d83ec073c51 src/http/ngx_http_request.h
+--- src/http/ngx_http_request.h Sat May 11 18:49:19 2013 +0400
++++ src/http/ngx_http_request.h Sat May 11 18:49:30 2013 +0400
+@@ -295,7 +295,7 @@
+ ngx_http_addr_conf_t *addr_conf;
+ ngx_http_conf_ctx_t *conf_ctx;
+
+-#ifdef SSL_CTRL_SET_TLSEXT_HOSTNAME
++#if (NGX_HTTP_SSL && defined SSL_CTRL_SET_TLSEXT_HOSTNAME)
+ ngx_str_t *ssl_servername;
+ #if (NGX_PCRE)
+ ngx_http_regex_t *ssl_servername_regex;
+