aboutsummaryrefslogtreecommitdiffstats
path: root/www/node04
diff options
context:
space:
mode:
authorvanilla <vanilla@FreeBSD.org>2011-09-08 16:44:17 +0800
committervanilla <vanilla@FreeBSD.org>2011-09-08 16:44:17 +0800
commit72286538d88d2e564f2919f0922a0ea3be646d66 (patch)
tree3b400d551eb65469711369310b0792cf020fe07a /www/node04
parent687de3faba96e0d3e440f2a80cfee0f887ecdbff (diff)
downloadfreebsd-ports-gnome-72286538d88d2e564f2919f0922a0ea3be646d66.tar.gz
freebsd-ports-gnome-72286538d88d2e564f2919f0922a0ea3be646d66.tar.zst
freebsd-ports-gnome-72286538d88d2e564f2919f0922a0ea3be646d66.zip
Fix broken with new lang/v8.
Approved by: maintainer
Diffstat (limited to 'www/node04')
-rw-r--r--www/node04/Makefile2
-rw-r--r--www/node04/files/extra-patch-src__node_buffer.cc11
2 files changed, 12 insertions, 1 deletions
diff --git a/www/node04/Makefile b/www/node04/Makefile
index f326ad717576..7388baa4fc0a 100644
--- a/www/node04/Makefile
+++ b/www/node04/Makefile
@@ -36,7 +36,7 @@ PREFIX_RELDEST= ${PREFIX:S,^${DESTDIR},,}
LIB_DEPENDS+= v8.1:${PORTSDIR}/lang/v8
CONFIGURE_ARGS+= --shared-v8-includes=${LOCALBASE}/include --shared-v8-libpath=${LOCALBASE}/lib
PLIST_SUB+= SHAREDV8="@comment "
-BROKEN= does not build with new v8
+EXTRA_PATCHES= ${FILESDIR}/extra-patch-src__node_buffer.cc
.else
PLIST_SUB+= SHAREDV8=""
.endif
diff --git a/www/node04/files/extra-patch-src__node_buffer.cc b/www/node04/files/extra-patch-src__node_buffer.cc
new file mode 100644
index 000000000000..265219e77cfd
--- /dev/null
+++ b/www/node04/files/extra-patch-src__node_buffer.cc
@@ -0,0 +1,11 @@
+--- src/node_buffer.cc.orig 2011-09-08 16:40:06.000000000 +0800
++++ src/node_buffer.cc 2011-09-08 16:40:18.000000000 +0800
+@@ -478,7 +478,7 @@ Handle<Value> Buffer::Utf8Write(const Ar
+
+ if (written > 0 && p[written-1] == '\0' && char_written == length) {
+ uint16_t last_char;
+- s->Write(&last_char, length - 1, 1, String::NO_HINTS);
++ s->Write(&last_char, length - 1, 1, String::NO_OPTIONS);
+ if (last_char != 0 || written > s->Utf8Length()) {
+ written--;
+ }