aboutsummaryrefslogtreecommitdiffstats
path: root/www/npm
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2016-12-09 20:56:18 +0800
committersunpoet <sunpoet@FreeBSD.org>2016-12-09 20:56:18 +0800
commitd9bc7a0d599abdc204f54f8adedb52454d8a32be (patch)
tree76f2e2fe4fd96a4eb6003c13e32ebb51408cc438 /www/npm
parenta89566dee2efed6a47173adcb7ef8890e7bd5e94 (diff)
downloadfreebsd-ports-gnome-d9bc7a0d599abdc204f54f8adedb52454d8a32be.tar.gz
freebsd-ports-gnome-d9bc7a0d599abdc204f54f8adedb52454d8a32be.tar.zst
freebsd-ports-gnome-d9bc7a0d599abdc204f54f8adedb52454d8a32be.zip
- Update to 4.0.3
Changes: https://github.com/npm/npm/releases https://github.com/npm/npm/blob/v4.0.3/CHANGELOG.md
Diffstat (limited to 'www/npm')
-rw-r--r--www/npm/Makefile2
-rw-r--r--www/npm/distinfo6
-rw-r--r--www/npm/pkg-plist11
3 files changed, 7 insertions, 12 deletions
diff --git a/www/npm/Makefile b/www/npm/Makefile
index a155dc938f9c..de2881d58f0c 100644
--- a/www/npm/Makefile
+++ b/www/npm/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= npm
-PORTVERSION= 4.0.2
+PORTVERSION= 4.0.3
CATEGORIES= www
MASTER_SITES= LOCAL/sunpoet
diff --git a/www/npm/distinfo b/www/npm/distinfo
index bcc7e535c7c8..9512a53cf465 100644
--- a/www/npm/distinfo
+++ b/www/npm/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1479768915
-SHA256 (npm-4.0.2.tar.xz) = 8e4ceeabb9501c7acda3067dd993a647d20980b4c8900c587cc41b92bd2543e9
-SIZE (npm-4.0.2.tar.xz) = 2664364
+TIMESTAMP = 1481217963
+SHA256 (npm-4.0.3.tar.xz) = 3ed5e0a71308ce40f064a66cd94ec2efc3c75a6618f405c0ae168840914f39c8
+SIZE (npm-4.0.3.tar.xz) = 2670980
diff --git a/www/npm/pkg-plist b/www/npm/pkg-plist
index a49e4c2b293a..06b2539ab402 100644
--- a/www/npm/pkg-plist
+++ b/www/npm/pkg-plist
@@ -221,7 +221,6 @@ lib/node_modules/npm/lib/install/actions.js
lib/node_modules/npm/lib/install/and-add-parent-to-errors.js
lib/node_modules/npm/lib/install/and-finish-tracker.js
lib/node_modules/npm/lib/install/and-ignore-errors.js
-lib/node_modules/npm/lib/install/build-path.js
lib/node_modules/npm/lib/install/check-permissions.js
lib/node_modules/npm/lib/install/copy-tree.js
lib/node_modules/npm/lib/install/decompose-actions.js
@@ -238,6 +237,7 @@ lib/node_modules/npm/lib/install/is-fs-access-available.js
lib/node_modules/npm/lib/install/is-opt-dep.js
lib/node_modules/npm/lib/install/is-prod-dep.js
lib/node_modules/npm/lib/install/is-registry-specifier.js
+lib/node_modules/npm/lib/install/module-staging-path.js
lib/node_modules/npm/lib/install/mutate-into-logical-tree.js
lib/node_modules/npm/lib/install/node.js
lib/node_modules/npm/lib/install/read-shrinkwrap.js
@@ -2572,10 +2572,6 @@ lib/node_modules/npm/node_modules/npmlog/node_modules/gauge/node_modules/string-
lib/node_modules/npm/node_modules/npmlog/node_modules/gauge/node_modules/string-width/license
lib/node_modules/npm/node_modules/npmlog/node_modules/gauge/node_modules/string-width/node_modules/code-point-at/index.js
lib/node_modules/npm/node_modules/npmlog/node_modules/gauge/node_modules/string-width/node_modules/code-point-at/license
-lib/node_modules/npm/node_modules/npmlog/node_modules/gauge/node_modules/string-width/node_modules/code-point-at/node_modules/number-is-nan/index.js
-lib/node_modules/npm/node_modules/npmlog/node_modules/gauge/node_modules/string-width/node_modules/code-point-at/node_modules/number-is-nan/license
-lib/node_modules/npm/node_modules/npmlog/node_modules/gauge/node_modules/string-width/node_modules/code-point-at/node_modules/number-is-nan/package.json
-lib/node_modules/npm/node_modules/npmlog/node_modules/gauge/node_modules/string-width/node_modules/code-point-at/node_modules/number-is-nan/readme.md
lib/node_modules/npm/node_modules/npmlog/node_modules/gauge/node_modules/string-width/node_modules/code-point-at/package.json
lib/node_modules/npm/node_modules/npmlog/node_modules/gauge/node_modules/string-width/node_modules/code-point-at/readme.md
lib/node_modules/npm/node_modules/npmlog/node_modules/gauge/node_modules/string-width/node_modules/is-fullwidth-code-point/index.js
@@ -2763,7 +2759,6 @@ lib/node_modules/npm/node_modules/readable-stream/.npmignore
lib/node_modules/npm/node_modules/readable-stream/.travis.yml
lib/node_modules/npm/node_modules/readable-stream/LICENSE
lib/node_modules/npm/node_modules/readable-stream/README.md
-lib/node_modules/npm/node_modules/readable-stream/doc/stream.md
lib/node_modules/npm/node_modules/readable-stream/doc/wg-meetings/2015-01-30.md
lib/node_modules/npm/node_modules/readable-stream/duplex.js
lib/node_modules/npm/node_modules/readable-stream/lib/_stream_duplex.js
@@ -3685,7 +3680,6 @@ lib/node_modules/npm/test/fixtures/config/builtin
lib/node_modules/npm/test/fixtures/config/globalconfig
lib/node_modules/npm/test/fixtures/config/malformed
lib/node_modules/npm/test/fixtures/config/multi-ca
-lib/node_modules/npm/test/fixtures/config/package.json
lib/node_modules/npm/test/fixtures/config/userconfig
lib/node_modules/npm/test/fixtures/forked-underscore-1.5.1.tgz
lib/node_modules/npm/test/fixtures/github-com-BryanDonovan-dummy-npm-bar.git.tar.gz
@@ -3709,7 +3703,6 @@ lib/node_modules/npm/test/network/legacy-shrinkwrap.js
lib/node_modules/npm/test/network/legacy-url-dep.js
lib/node_modules/npm/test/network/outdated-symlink.js
lib/node_modules/npm/test/network/registry.js
-lib/node_modules/npm/test/slow/legacy-npm-self-install.js
lib/node_modules/npm/test/tap/00-check-mock-dep.js
lib/node_modules/npm/test/tap/00-config-setup.js
lib/node_modules/npm/test/tap/00-verify-bundle-deps.js
@@ -3831,6 +3824,7 @@ lib/node_modules/npm/test/tap/install-save-local.js
lib/node_modules/npm/test/tap/install-save-prefix.js
lib/node_modules/npm/test/tap/install-scoped-already-installed.js
lib/node_modules/npm/test/tap/install-scoped-link.js
+lib/node_modules/npm/test/tap/install-scoped-with-bundled-dependency.js
lib/node_modules/npm/test/tap/install-scoped-with-peer-dependency.js
lib/node_modules/npm/test/tap/install-shrinkwrapped-git.js
lib/node_modules/npm/test/tap/install-with-dev-dep-duplicate.js
@@ -3842,6 +3836,7 @@ lib/node_modules/npm/test/tap/legacy-dir-bin.js
lib/node_modules/npm/test/tap/legacy-ignore-nested-nm.js
lib/node_modules/npm/test/tap/legacy-missing-bindir.js
lib/node_modules/npm/test/tap/legacy-no-auth-leak.js
+lib/node_modules/npm/test/tap/legacy-npm-self-install.js
lib/node_modules/npm/test/tap/legacy-platform-all.js
lib/node_modules/npm/test/tap/legacy-platform.js
lib/node_modules/npm/test/tap/legacy-private.js