aboutsummaryrefslogtreecommitdiffstats
path: root/www/npm
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2012-05-15 02:52:39 +0800
committersunpoet <sunpoet@FreeBSD.org>2012-05-15 02:52:39 +0800
commit35524f3f7a5c4de8097bfb8ba2021697ac0a7c51 (patch)
treed64cf98ce5f80108b2e2a61bcc218ca38ec65eb9 /www/npm
parentb5b1ce44df9fef8e89d23a9f736d3edc3fbf78b6 (diff)
downloadfreebsd-ports-gnome-35524f3f7a5c4de8097bfb8ba2021697ac0a7c51.tar.gz
freebsd-ports-gnome-35524f3f7a5c4de8097bfb8ba2021697ac0a7c51.tar.zst
freebsd-ports-gnome-35524f3f7a5c4de8097bfb8ba2021697ac0a7c51.zip
- Allow node-devel users to install npm
Diffstat (limited to 'www/npm')
-rw-r--r--www/npm/Makefile10
1 files changed, 9 insertions, 1 deletions
diff --git a/www/npm/Makefile b/www/npm/Makefile
index efe8617e4443..3d6b58264a6b 100644
--- a/www/npm/Makefile
+++ b/www/npm/Makefile
@@ -13,7 +13,7 @@ MASTER_SITES= LOCAL/sunpoet
MAINTAINER= sunpoet@FreeBSD.org
COMMENT= Node package manager
-RUN_DEPENDS= node>=0.6:${PORTSDIR}/www/node
+OPTIONS= NODE_DEVEL "Use www/node-devel instead of www/node" off
NO_BUILD= yes
USE_XZ= yes
@@ -42,4 +42,12 @@ MAN3= npm.3 npm-bin.3 npm-bugs.3 npm-commands.3 npm-config.3 \
npm-tag.3 npm-test.3 npm-uninstall.3 npm-unpublish.3 \
npm-update.3 npm-version.3 npm-view.3 npm-whoami.3
+.include <bsd.port.options.mk>
+
+.if !defined(WITH_NODE_DEVEL)
+RUN_DEPENDS= ${LOCALBASE}/bin/node:${PORTSDIR}/www/node
+.else
+RUN_DEPENDS= ${LOCALBASE}/bin/node:${PORTSDIR}/www/node-devel
+.endif
+
.include <bsd.port.mk>