aboutsummaryrefslogtreecommitdiffstats
path: root/www/ocaml-net
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2012-10-28 04:06:23 +0800
committerbapt <bapt@FreeBSD.org>2012-10-28 04:06:23 +0800
commit2c3a30e90cd315b58db227c4dd062843cd7c0ae2 (patch)
treea7693d6831951b4869e691e16f3175d301028784 /www/ocaml-net
parentb4793edd161acb0e75dda43c4e1902074c772fc8 (diff)
downloadfreebsd-ports-gnome-2c3a30e90cd315b58db227c4dd062843cd7c0ae2.tar.gz
freebsd-ports-gnome-2c3a30e90cd315b58db227c4dd062843cd7c0ae2.tar.zst
freebsd-ports-gnome-2c3a30e90cd315b58db227c4dd062843cd7c0ae2.zip
Disable gtk1 support which depends on ocaml-lablgtk which is expired
Feature safe: yes
Diffstat (limited to 'www/ocaml-net')
-rw-r--r--www/ocaml-net/Makefile12
1 files changed, 2 insertions, 10 deletions
diff --git a/www/ocaml-net/Makefile b/www/ocaml-net/Makefile
index 043138daece2..7047b3298508 100644
--- a/www/ocaml-net/Makefile
+++ b/www/ocaml-net/Makefile
@@ -48,12 +48,13 @@ OCAML_LDLIBS= ${OCAML_PKGDIRS:S/^/${OCAML_SITELIBDIR}\//}
OPTIONS= SSL "Enable SSL support" ON \
NETHTTPD "Enable the integrated HTTP daemon" OFF \
AUTH_DH "Enable Diffie-Hellman authorization support" OFF \
- GTK "Enable GTK support" OFF \
GTK2 "Enable GTK2 support" OFF \
APACHE "Enable Apache mod connector (experimental)" OFF \
ZIP "Enable compression support" OFF \
SCRAM "Enable SCRAM support" OFF
+CONFIGURE_ARGS+= -disable-gtk
+
.include <bsd.port.options.mk>
.if defined(WITHOUT_SSL)
@@ -81,15 +82,6 @@ OCAML_PKGDIRS+= rpc-auth-dh
CONFIGURE_ARGS+= -without-rpc-auth-dh
.endif
-.if defined(WITH_GTK)
-CONFIGURE_ARGS+= -enable-gtk
-BUILD_DEPENDS+= lablgtk:${PORTSDIR}/x11-toolkits/ocaml-lablgtk
-RUN_DEPENDS+= lablgtk:${PORTSDIR}/x11-toolkits/ocaml-lablgtk
-OCAML_PKGDIRS+= equeue-gtk1
-.else
-CONFIGURE_ARGS+= -disable-gtk
-.endif
-
.if defined(WITH_GTK2)
CONFIGURE_ARGS+= -enable-gtk2
BUILD_DEPENDS+= lablgtk2:${PORTSDIR}/x11-toolkits/ocaml-lablgtk2