aboutsummaryrefslogtreecommitdiffstats
path: root/www/ocsigen
diff options
context:
space:
mode:
authorbeech <beech@FreeBSD.org>2009-01-30 12:56:00 +0800
committerbeech <beech@FreeBSD.org>2009-01-30 12:56:00 +0800
commitdc6b1256eb5b6e8b682ac6dde8f2a56d31c0917a (patch)
tree5fd6fd948227ec33fd3947158da98ec474ad9a66 /www/ocsigen
parent21e6d8a1afd41ebe07982f647f4aa19ee5eaafa0 (diff)
downloadfreebsd-ports-gnome-dc6b1256eb5b6e8b682ac6dde8f2a56d31c0917a.tar.gz
freebsd-ports-gnome-dc6b1256eb5b6e8b682ac6dde8f2a56d31c0917a.tar.zst
freebsd-ports-gnome-dc6b1256eb5b6e8b682ac6dde8f2a56d31c0917a.zip
- Update to 1.1.0
- Changelog at http://www.ocsigen.org/install/ocsigen PR: ports/130508 Submitted by: Jaap Boender <jaapb@kerguelen.org> (maintainer)
Diffstat (limited to 'www/ocsigen')
-rw-r--r--www/ocsigen/Makefile66
-rw-r--r--www/ocsigen/distinfo6
-rw-r--r--www/ocsigen/files/patch-Makefile114
-rw-r--r--www/ocsigen/files/patch-configure121
-rw-r--r--www/ocsigen/files/patch-modules_Makefile11
-rw-r--r--www/ocsigen/files/patch-server_Makefile11
-rw-r--r--www/ocsigen/files/patch-xmlp4_oldocaml_Makefile11
-rw-r--r--www/ocsigen/pkg-plist200
8 files changed, 147 insertions, 393 deletions
diff --git a/www/ocsigen/Makefile b/www/ocsigen/Makefile
index 42cc05d62e39..99a737a2b327 100644
--- a/www/ocsigen/Makefile
+++ b/www/ocsigen/Makefile
@@ -5,50 +5,53 @@
# $FreeBSD$
PORTNAME= ocsigen
-PORTVERSION= 0.6.0
-PORTREVISION= 1
+PORTVERSION= 1.1.0
CATEGORIES= www
MASTER_SITES= http://www.ocsigen.org/download/
MAINTAINER= jaapb@kerguelen.org
COMMENT= Web programming framework for OCaml
-BUILD_DEPENDS= ocaml-net<2:${PORTSDIR}/www/ocaml-net \
- ${SA_DIR}/ssl/ssl.a:${PORTSDIR}/security/ocaml-ssl
-RUN_DEPENDS= ocaml-net<2:${PORTSDIR}/www/ocaml-net \
- ${SA_DIR}/ssl/ssl.a:${PORTSDIR}/security/ocaml-ssl
+BUILD_DEPENDS= ocaml-net>=2:${PORTSDIR}/www/ocaml-net \
+ ${SA_DIR}/ssl/ssl.a:${PORTSDIR}/security/ocaml-ssl \
+ ${SA_DIR}/lwt/lwt.a:${PORTSDIR}/devel/ocaml-lwt \
+ ${SA_DIR}/cryptokit/cryptokit.a:${PORTSDIR}/security/ocaml-cryptokit
+RUN_DEPENDS= ocaml-net>=2:${PORTSDIR}/www/ocaml-net \
+ ${SA_DIR}/ssl/ssl.a:${PORTSDIR}/security/ocaml-ssl \
+ ${SA_DIR}/lwt/lwt.a:${PORTSDIR}/devel/ocaml-lwt \
+ ${SA_DIR}/cryptokit/cryptokit.a:${PORTSDIR}/security/ocaml-cryptokit
-BROKEN= unsatisfiable dependency line
-DEPRECATED= has been broken for more than 6 months
-EXPIRATION_DATE=2009-01-19
-
-USE_OCAML= yes
+USE_OCAML= yes
USE_OCAML_FINDLIB= yes
+USE_OCAMLFIND_PLIST= yes
USE_OCAML_LDCONFIG= yes
-SA_DIR= ${LOCALBASE}/${OCAML_SITELIBDIR}
+SA_DIR= ${PREFIX}/${OCAML_SITELIBDIR}
-OPTIONS= OCAMLDUCE "Use OCamlDuce support" ON
+OPTIONS= OCAMLDUCE "Use OCamlDuce support" ON \
+ SQLITE "Use sqlite as a database backend" OFF \
+ CAMLZIP "Use camlzip for compression" ON
USE_GMAKE= yes
HAS_CONFIGURE= yes
CONFIGURE_ARGS= --name ${PORTNAME} \
- --disable-newocamlnet \
--disable-nativecode \
--disable-debug \
--ocsigen-user ${WWWOWN} \
--ocsigen-group ${WWWGRP} \
--bindir ${PREFIX}/bin \
--mandir ${PREFIX}/man/man1 \
- --libdir ${PREFIX}/share/examples \
- --docdir ${PREFIX}/share/doc \
+ --libdir ${SA_DIR} \
+ --docdir ${DOCSDIR} \
--sysconfdir ${PREFIX}/etc \
--staticpagesdir ${PREFIX}/share/ocsigen/www \
--uploaddir /tmp
-INSTALL_TARGET= fullinstall
+ALL_TARGET= depend all
+INSTALL_TARGET= installnodoc
.if !defined(NOPORTDOCS)
INSTALL_TARGET+= docinstall
+PORTDOCS= *
.endif
MAN1= ocsigen.1
@@ -61,9 +64,32 @@ CONFIGURE_ARGS+= --disable-ocamlduce
BUILD_DEPENDS+= ${SA_DIR}/ocamlduce/ocamlduce.a:${PORTSDIR}/lang/ocamlduce
RUN_DEPENDS+= ${SA_DIR}/ocamlduce/ocamlduce.a:${PORTSDIR}/lang/ocamlduce
CONFIGURE_ARGS+= --enable-ocamlduce
-PLIST_FILES+= ${OCAML_SITELIBDIR}/ocsigen/ocsigenduce.cma \
- ${OCAML_SITELIBDIR}/ocsigen/ocsigenduce.cmi \
- share/examples/ocsigen/exampleduce.cmo
+PLIST_FILES+= lib/ocsigen/examples/exampleduce.cmo \
+ lib/ocsigen/extensions/eliom_duce.cma
+.endif
+
+.if defined(WITH_SQLITE)
+BUILD_DEPENDS+= ${SA_DIR}/sqlite3/sqlite3.a:${PORTSDIR}/databases/ocaml-sqlite3
+RUN_DEPENDS+= ${SA_DIR}/sqlite3/sqlite3.a:${PORTSDIR}/databases/ocaml-sqlite3
+CONFIGURE_ARGS+= --enable-sqlite
+PLIST_FILES+= lib/ocsigen/extensions/ocsipersist-sqlite.cma
+.else
+CONFIGURE_ARGS+= --disable-sqlite
.endif
+.if defined(WITHOUT_CAMLZIP)
+CONFIGURE_ARGS+= --disable-camlzip
+.else
+CONFIGURE_ARGS+= --enable-camlzip
+BUILD_DEPENDS+= ocaml-zip>=1.03_2:${PORTSDIR}/archivers/ocaml-zip
+RUN_DEPENDS+= ocaml-zip>=1.03_2:${PORTSDIR}/archivers/ocaml-zip
+PLIST_FILES+= lib/ocsigen/extensions/deflatemod.cmo
+.endif
+
+post-install:
+ @if [ ! -f ${PREFIX}/etc/${PORTNAME}/ocsigen.conf ]; then \
+ ${CP} -p ${PREFIX}/etc/${PORTNAME}/ocsigen.conf.sample \
+ ${PREFIX}/etc/${PORTNAME}/ocsigen.conf; \
+ fi
+
.include <bsd.port.post.mk>
diff --git a/www/ocsigen/distinfo b/www/ocsigen/distinfo
index 49527b33458e..714b49f900d5 100644
--- a/www/ocsigen/distinfo
+++ b/www/ocsigen/distinfo
@@ -1,3 +1,3 @@
-MD5 (ocsigen-0.6.0.tar.gz) = 942e8395c0959c18512722320514bd7d
-SHA256 (ocsigen-0.6.0.tar.gz) = 29d877e25a6fe444b7b6dce33f4f3d2513cc34365e2e9eb01f915f0f9dfa55de
-SIZE (ocsigen-0.6.0.tar.gz) = 984754
+MD5 (ocsigen-1.1.0.tar.gz) = 4633086fdede3ff135eb0ee9e692be94
+SHA256 (ocsigen-1.1.0.tar.gz) = 9cad514c1162eaee8a48de0acb58c061eca8777fdc0eed0538ebd09f844ebcd2
+SIZE (ocsigen-1.1.0.tar.gz) = 683710
diff --git a/www/ocsigen/files/patch-Makefile b/www/ocsigen/files/patch-Makefile
index b39fa3cdd23b..2858690086f9 100644
--- a/www/ocsigen/files/patch-Makefile
+++ b/www/ocsigen/files/patch-Makefile
@@ -1,80 +1,40 @@
---- Makefile.orig Thu Mar 15 12:27:51 2007
-+++ Makefile Mon Apr 23 10:18:24 2007
-@@ -16,7 +16,7 @@
- CAMLDOC = $(OCAMLFIND) ocamldoc $(LIB)
- TOINSTALL = modules/tutorial.cmo modules/tutorial.cmi modules/monitoring.cmo server/parseconfig.cmi server/ocsigen.cmi server/ocsigenmod.cma server/staticmod.cmi server/staticmod.cmo server/ocsigenboxes.cmi xmlp4/ohl-xhtml/xHTML.cmi xmlp4/ohl-xhtml/xML.cmi xmlp4/ohl-xhtml/xhtml.cma xmlp4/xhtmltypes.cmi xmlp4/simplexmlparser.cmi xmlp4/xhtmlsyntax.cma META lwt/lwt.cmi lwt/lwt_unix.cmi server/preemptive.cmi http/predefined_senders.cmi baselib/messages.cmi $(DUCEFILES)
- EXAMPLES = modules/tutorial.cmo modules/tutorial.cmi modules/monitoring.cmo $(DUCEEXAMPLES)
--PP = -pp "camlp4o ./lib/xhtmlsyntax.cma -loc loc"
-+PP = -pp "$(CAMLP4O) ./lib/xhtmlsyntax.cma -loc loc"
+--- Makefile.orig 2008-07-01 13:50:21.000000000 +0200
++++ Makefile 2008-07-08 11:25:25.000000000 +0200
+@@ -284,7 +284,6 @@
- all: $(REPS)
-
-@@ -62,7 +62,7 @@
- @for i in $(REPS) ; do touch "$$i"/.depend; $(MAKE) -C $$i depend ; done
-
-
--.PHONY: install fullinstall doc
-+.PHONY: install fullinstall doc docinstall
- install:
- mkdir -p $(PREFIX)/$(MODULEINSTALLDIR)
- mkdir -p $(PREFIX)/$(EXAMPLESINSTALLDIR)
-@@ -73,10 +73,10 @@
- -rm META
-
-
--fullinstall: doc install
-+fullinstall: install
- mkdir -p $(PREFIX)/$(CONFIGDIR)
- mkdir -p $(PREFIX)/$(STATICPAGESDIR)
-- -mv $(PREFIX)/$(CONFIGDIR)/ocsigen.conf $(PREFIX)/$(CONFIGDIR)/ocsigen.conf.old
-+# -mv $(PREFIX)/$(CONFIGDIR)/ocsigen.conf $(PREFIX)/$(CONFIGDIR)/ocsigen.conf.old
- cat files/ocsigen.conf \
+ installnodoc: partialinstall
+ mkdir -p $(TEMPROOT)$(CONFIGDIR)
+- mkdir -p $(TEMPROOT)$(CONFIGDIR)/conf.d
+ mkdir -p $(TEMPROOT)$(STATICPAGESDIR)
+ mkdir -p $(TEMPROOT)$(STATICPAGESDIR)/miniwiki
+ mkdir -p $(TEMPROOT)$(STATICPAGESDIR)/tutorial
+@@ -295,7 +294,6 @@
+ [ -p $(TEMPROOT)$(COMMANDPIPE) ] || { mkfifo $(TEMPROOT)$(COMMANDPIPE); \
+ chmod 660 $(TEMPROOT)$(COMMANDPIPE); \
+ $(CHOWN) -R $(OCSIGENUSER):$(OCSIGENGROUP) $(TEMPROOT)$(COMMANDPIPE);}
+-# -mv $(TEMPROOT)$(CONFIGDIR)/$(OCSIGENNAME).conf $(TEMPROOT)$(CONFIGDIR)/$(OCSIGENNAME).conf.old
+ cat files/ocsigen.conf.in \
| sed s%_LOGDIR_%$(LOGDIR)%g \
| sed s%_STATICPAGESDIR_%$(STATICPAGESDIR)%g \
-@@ -84,7 +84,7 @@
- | sed s%_OCSIGENUSER_%$(OCSIGENUSER)%g \
- | sed s%_OCSIGENGROUP_%$(OCSIGENGROUP)%g \
- | sed s%_MODULEINSTALLDIR_%$(MODULEINSTALLDIR)/$(OCSIGENNAME)%g \
-- > $(PREFIX)/$(CONFIGDIR)/ocsigen.conf
-+ > $(PREFIX)/$(CONFIGDIR)/ocsigen.conf.sample
- -mv $(PREFIX)/$(CONFIGDIR)/mime.types $(PREFIX)/$(CONFIGDIR)/mime.types.old
- cp -f files/mime.types $(PREFIX)/$(CONFIGDIR)
- mkdir -p $(PREFIX)/$(LOGDIR)
-@@ -92,8 +92,19 @@
- $(CHOWN) -R $(OCSIGENUSER):$(OCSIGENGROUP) $(PREFIX)/$(STATICPAGESDIR)
- chmod u+rwx $(PREFIX)/$(LOGDIR)
- chmod a+rx $(PREFIX)/$(CONFIGDIR)
-- chmod a+r $(PREFIX)/$(CONFIGDIR)/ocsigen.conf
-+ chmod a+r $(PREFIX)/$(CONFIGDIR)/ocsigen.conf.sample
- chmod a+r $(PREFIX)/$(CONFIGDIR)/mime.types
-+# [ -d /etc/logrotate.d ] && \
-+# { mkdir -p ${PREFIX}/etc/logrotate.d ; \
-+# cat files/logrotate.IN \
-+# | sed s%LOGDIR%$(LOGDIR)%g \
-+# | sed s%USER%$(OCSIGENUSER)%g \
-+# | sed s%GROUP%$(OCSIGENGROUP)%g \
-+# > $(PREFIX)/etc/logrotate.d/$(OCSIGENNAME); }
-+ install -d -m 755 $(PREFIX)/$(MANDIR)
-+ install -m 644 files/ocsigen.1 $(PREFIX)/$(MANDIR)
-+
-+docinstall: doc
- mkdir -p $(PREFIX)/$(DOCDIR)
- install -d -m 755 $(PREFIX)/$(DOCDIR)/lwt
- install -d -m 755 $(PREFIX)/$(DOCDIR)/oc
-@@ -102,16 +113,6 @@
- install -m 644 doc/oc/* $(PREFIX)/$(DOCDIR)/oc
- chmod a+rx $(PREFIX)/$(DOCDIR)
- chmod a+r $(PREFIX)/$(DOCDIR)/*
-- [ -d /etc/logrotate.d ] && \
-- { mkdir -p ${PREFIX}/etc/logrotate.d ; \
-- cat files/logrotate.IN \
-- | sed s%LOGDIR%$(LOGDIR)%g \
-- | sed s%USER%$(OCSIGENUSER)%g \
-- | sed s%GROUP%$(OCSIGENGROUP)%g \
-- > $(PREFIX)/etc/logrotate.d/$(OCSIGENNAME); }
-- install -d -m 755 $(PREFIX)/$(MANDIR)
-- install -m 644 files/ocsigen.1 $(PREFIX)/$(MANDIR)
--
-
- .PHONY: uninstall fulluninstall
- uninstall:
+@@ -318,21 +316,10 @@
+ | sed s%[.]cmo%.cmxs%g \
+ | sed s%[.]cma%.cmxs%g \
+ > $(TEMPROOT)$(CONFIGDIR)/$(OCSIGENNAME).conf.opt.sample
+- -mv $(TEMPROOT)$(CONFIGDIR)/mime.types $(TEMPROOT)$(CONFIGDIR)/mime.types.old
+ cp -f files/mime.types $(TEMPROOT)$(CONFIGDIR)
+ mkdir -p $(TEMPROOT)$(LOGDIR)
+ chmod u+rwx $(TEMPROOT)$(LOGDIR)
+- chmod a+rx $(TEMPROOT)$(CONFIGDIR)
+- chmod a+rx $(TEMPROOT)$(CONFIGDIR)/conf.d
+- [ -f $(TEMPROOT)$(CONFIGDIR)/$(OCSIGENNAME).conf ] || \
+- { cp $(TEMPROOT)$(CONFIGDIR)/$(OCSIGENNAME).conf.sample \
+- $(TEMPROOT)$(CONFIGDIR)/$(OCSIGENNAME).conf; \
+- chmod a+r $(TEMPROOT)$(CONFIGDIR)/$(OCSIGENNAME).conf; }
+ chmod a+r $(TEMPROOT)$(CONFIGDIR)/$(OCSIGENNAME).conf.sample
+- [ -f $(TEMPROOT)$(CONFIGDIR)/$(OCSIGENNAME).conf ] || \
+- { cp $(TEMPROOT)$(CONFIGDIR)/$(OCSIGENNAME).conf.opt.sample \
+- $(TEMPROOT)$(CONFIGDIR)/$(OCSIGENNAME).conf.opt; \
+- chmod a+r $(TEMPROOT)$(CONFIGDIR)/$(OCSIGENNAME).conf.opt; }
+ chmod a+r $(TEMPROOT)$(CONFIGDIR)/$(OCSIGENNAME).conf.opt.sample
+ chmod a+r $(TEMPROOT)$(CONFIGDIR)/mime.types
+ $(INSTALL) -m 644 files/tutorial/style.css $(TEMPROOT)$(STATICPAGESDIR)/tutorial
diff --git a/www/ocsigen/files/patch-configure b/www/ocsigen/files/patch-configure
deleted file mode 100644
index 2fbf03161d4c..000000000000
--- a/www/ocsigen/files/patch-configure
+++ /dev/null
@@ -1,121 +0,0 @@
---- configure.orig Thu Mar 15 12:27:54 2007
-+++ configure Mon Apr 23 10:17:10 2007
-@@ -51,10 +51,13 @@
- libdir="/usr/local/lib"
- mandir="/usr/local/share/man/man1/"
- docdir="/usr/share/doc"
-+ sysconfdir="/etc"
- name="ocsigen"
- prefix="/"
- ocsigen_user="www-data"
- ocsigen_group="www-data"
-+ staticpagesdir="/var/www/$name"
-+ uploaddir="/tmp"
- }
-
- set_defaults
-@@ -132,6 +135,9 @@
- echo " --libdir $libdir"
- echo " --mandir $mandir"
- echo " --docdir $docdir"
-+ echo " --sysconfdir $sysconfdir"
-+ echo " --staticpagesdir $staticpagesdir"
-+ echo " --uploaddir $uploaddir"
- echo " --name $name"
- }
-
-@@ -174,6 +180,15 @@
- --docdir dir
- Install documentation in this directory
-
-+--sysconfdir dir
-+ Install system configuration files in this directory
-+
-+--staticpagesdir dir
-+ Serve static pages from this directory
-+
-+--uploaddir dir
-+ Put uploaded files in this directory
-+
- --name name
- The name of the server (and directory for the modules)
-
-@@ -266,6 +281,21 @@
- shift
- shift
- ;;
-+ --sysconfdir)
-+ sysconfdir="$2"
-+ shift
-+ shift
-+ ;;
-+ --staticpagesdir)
-+ staticpagesdir="$2"
-+ shift
-+ shift
-+ ;;
-+ --uploaddir)
-+ uploaddir="$2"
-+ shift
-+ shift
-+ ;;
- --name)
- name="$2"
- shift
-@@ -293,6 +323,17 @@
-
-
- ######################################################################
-+# Check camlp4o
-+printf "%s" "Finding out which camlp4o to use... "
-+if which camlp4o.byte >/dev/null 2>/dev/null; then
-+ echo "camlp4o.byte"
-+ camlp4o="camlp4o.byte"
-+else
-+ echo "camlp4o"
-+ camlp4o="camlp4o"
-+fi
-+
-+######################################################################
- # Check ocamlfind
-
- printf "%s" "Checking for findlib... "
-@@ -322,9 +363,10 @@
- ######################################################################
- # Check whether OCaml version is > 3.9
- version=`ocamlc -version`
--ocamlversion=`n1=${version:0:1}; \
-- n2=${version:2:2}; \
-- n3=${version:5}; \
-+ocamlversion=`n1=${version%%.[0-9][0-9].[0-9]}; \
-+ tail=${version##[0-9].}; \
-+ n2=${tail%%.[0-9]}; \
-+ n3=${tail##[0-9][0-9].}; \
- if [ $n1 = "3" ] && [ $n2 -le 9 ]; then \
- echo "OLD"; \
- else \
-@@ -380,6 +422,7 @@
- # ocamlfind will choose automatically the compiler.
- OCAMLFIND=ocamlfind
- CAMLP4=camlp4
-+CAMLP4O="$camlp4o"
- CAMLLEX=ocamllex
- CAMLYACC=ocamlyacc
- CAMLCNAME=ocamlc
-@@ -429,13 +472,13 @@
- LOGDIR = /var/log/\$(OCSIGENNAME)
-
- # Config files:
--CONFIGDIR = /etc/\$(OCSIGENNAME)
-+CONFIGDIR = $sysconfdir
-
- # Where to put static pages:
--STATICPAGESDIR = /var/www/\$(OCSIGENNAME)
-+STATICPAGESDIR = $staticpagesdir
-
- # Default directory for file upload:
--UPLOADDIR = /tmp
-+UPLOADDIR = $uploaddir
-
- # Where to put Ocsigen documentation:
- DOCDIR = $docdir/\$(OCSIGENNAME)
diff --git a/www/ocsigen/files/patch-modules_Makefile b/www/ocsigen/files/patch-modules_Makefile
deleted file mode 100644
index f8250ce25857..000000000000
--- a/www/ocsigen/files/patch-modules_Makefile
+++ /dev/null
@@ -1,11 +0,0 @@
---- modules/Makefile.orig Thu Mar 15 12:27:54 2007
-+++ modules/Makefile Mon Apr 23 10:18:59 2007
-@@ -21,7 +21,7 @@
- CAMLOPT = $(OCAMLFIND) ocamlopt $(DBG) $(LIB)
- CAMLDEP = $(OCAMLFIND) ocamldep
- LIB = -I ../lib
--PP = -pp "camlp4o ../lib/xhtmlsyntax.cma -loc loc"
-+PP = -pp "$(CAMLP4O) ../lib/xhtmlsyntax.cma -loc loc"
-
- OBJS = $(FILES:.ml=.cmo)
-
diff --git a/www/ocsigen/files/patch-server_Makefile b/www/ocsigen/files/patch-server_Makefile
deleted file mode 100644
index 4be21ce600e0..000000000000
--- a/www/ocsigen/files/patch-server_Makefile
+++ /dev/null
@@ -1,11 +0,0 @@
---- server/Makefile.orig Thu Mar 15 12:27:55 2007
-+++ server/Makefile Mon Apr 23 10:19:29 2007
-@@ -41,7 +41,7 @@
- CAMLDEP = $(OCAMLFIND) ocamldep
- LIB = -thread -package netstring,$(NETSYS)ssl -I ../lib -I +camlp4
- PP =
--PP2 = -pp "camlp4o ../lib/xhtmlsyntax.cma -- -loc loc"
-+PP2 = -pp "$(CAMLP4O) ../lib/xhtmlsyntax.cma -- -loc loc"
-
- CMAO = nums.cma dynlink.cma unix.cma \
- ssl.cma pcre.cma $(NETSYSCMA) netstring.cma \
diff --git a/www/ocsigen/files/patch-xmlp4_oldocaml_Makefile b/www/ocsigen/files/patch-xmlp4_oldocaml_Makefile
deleted file mode 100644
index 7373473f31f7..000000000000
--- a/www/ocsigen/files/patch-xmlp4_oldocaml_Makefile
+++ /dev/null
@@ -1,11 +0,0 @@
---- xmlp4/oldocaml/Makefile.orig Thu Mar 15 12:27:52 2007
-+++ xmlp4/oldocaml/Makefile Mon Apr 23 10:19:55 2007
-@@ -13,7 +13,7 @@
- CAMLOPT = $(OCAMLFIND) ocamlopt $(DBG) $(LIB)
- CAMLDEP = $(OCAMLFIND) ocamldep
- LIB = -I `$(CAMLP4) -where` -I ../../lib
--PP = -pp "camlp4o pa_extend.cmo q_MLast.cmo -- -loc loc"
-+PP = -pp "$(CAMLP4O) pa_extend.cmo q_MLast.cmo -- -loc loc"
- PPLEXER = -pp "camlp4r -- -loc loc"
-
- SRCLIBREP = ../../lib
diff --git a/www/ocsigen/pkg-plist b/www/ocsigen/pkg-plist
index 4a91944cce39..8616155f9293 100644
--- a/www/ocsigen/pkg-plist
+++ b/www/ocsigen/pkg-plist
@@ -1,142 +1,64 @@
-%%OCAML_SITELIBDIR%%/ocsigen/xhtml1_strict.cmi
-%%OCAML_SITELIBDIR%%/ocsigen/messages.cmi
-%%OCAML_SITELIBDIR%%/ocsigen/predefined_senders.cmi
-%%OCAML_SITELIBDIR%%/ocsigen/preemptive.cmi
-%%OCAML_SITELIBDIR%%/ocsigen/lwt_unix.cmi
-%%OCAML_SITELIBDIR%%/ocsigen/lwt.cmi
-%%OCAML_SITELIBDIR%%/ocsigen/xhtmlsyntax.cma
-%%OCAML_SITELIBDIR%%/ocsigen/simplexmlparser.cmi
-%%OCAML_SITELIBDIR%%/ocsigen/xhtmltypes.cmi
-%%OCAML_SITELIBDIR%%/ocsigen/xhtml.cma
-%%OCAML_SITELIBDIR%%/ocsigen/xML.cmi
-%%OCAML_SITELIBDIR%%/ocsigen/xHTML.cmi
-%%OCAML_SITELIBDIR%%/ocsigen/ocsigenboxes.cmi
-%%OCAML_SITELIBDIR%%/ocsigen/staticmod.cmo
-%%OCAML_SITELIBDIR%%/ocsigen/staticmod.cmi
-%%OCAML_SITELIBDIR%%/ocsigen/ocsigenmod.cma
-%%OCAML_SITELIBDIR%%/ocsigen/ocsigen.cmi
-%%OCAML_SITELIBDIR%%/ocsigen/parseconfig.cmi
-%%OCAML_SITELIBDIR%%/ocsigen/monitoring.cmo
-%%OCAML_SITELIBDIR%%/ocsigen/tutorial.cmi
-%%OCAML_SITELIBDIR%%/ocsigen/tutorial.cmo
-%%OCAML_SITELIBDIR%%/ocsigen/META
bin/ocsigen
-%%EXAMPLESDIR%%/tutorial.cmo
-%%EXAMPLESDIR%%/tutorial.cmi
-%%EXAMPLESDIR%%/monitoring.cmo
-etc/ocsigen.conf.sample
-etc/mime.types
-%%PORTDOCS%%%%DOCSDIR%%/lwt/Lwt.html
-%%PORTDOCS%%%%DOCSDIR%%/lwt/Lwt_unix.html
-%%PORTDOCS%%%%DOCSDIR%%/lwt/index.html
-%%PORTDOCS%%%%DOCSDIR%%/lwt/index_attributes.html
-%%PORTDOCS%%%%DOCSDIR%%/lwt/index_class_types.html
-%%PORTDOCS%%%%DOCSDIR%%/lwt/index_classes.html
-%%PORTDOCS%%%%DOCSDIR%%/lwt/index_exceptions.html
-%%PORTDOCS%%%%DOCSDIR%%/lwt/index_methods.html
-%%PORTDOCS%%%%DOCSDIR%%/lwt/index_module_types.html
-%%PORTDOCS%%%%DOCSDIR%%/lwt/index_modules.html
-%%PORTDOCS%%%%DOCSDIR%%/lwt/index_types.html
-%%PORTDOCS%%%%DOCSDIR%%/lwt/index_values.html
-%%PORTDOCS%%%%DOCSDIR%%/lwt/style.css
-%%PORTDOCS%%%%DOCSDIR%%/lwt/type_Lwt.html
-%%PORTDOCS%%%%DOCSDIR%%/lwt/type_Lwt_unix.html
-%%PORTDOCS%%%%DOCSDIR%%/oc/Extensions.html
-%%PORTDOCS%%%%DOCSDIR%%/oc/Messages.html
-%%PORTDOCS%%%%DOCSDIR%%/oc/Ocsigen.Make.html
-%%PORTDOCS%%%%DOCSDIR%%/oc/Ocsigen.OCSIGENSIG.html
-%%PORTDOCS%%%%DOCSDIR%%/oc/Ocsigen.PAGES.html
-%%PORTDOCS%%%%DOCSDIR%%/oc/Ocsigen.Text.html
-%%PORTDOCS%%%%DOCSDIR%%/oc/Ocsigen.Xhtml.html
-%%PORTDOCS%%%%DOCSDIR%%/oc/Ocsigen.html
-%%PORTDOCS%%%%DOCSDIR%%/oc/Ocsigenboxes.html
-%%PORTDOCS%%%%DOCSDIR%%/oc/Parseconfig.html
-%%PORTDOCS%%%%DOCSDIR%%/oc/Predefined_senders.html
-%%PORTDOCS%%%%DOCSDIR%%/oc/Simplexmlparser.ExprOrPatt.html
-%%PORTDOCS%%%%DOCSDIR%%/oc/Simplexmlparser.html
-%%PORTDOCS%%%%DOCSDIR%%/oc/XHTML.M.html
-%%PORTDOCS%%%%DOCSDIR%%/oc/XHTML.M_01_00.html
-%%PORTDOCS%%%%DOCSDIR%%/oc/XHTML.M_01_01.html
-%%PORTDOCS%%%%DOCSDIR%%/oc/XHTML.T.BASE.html
-%%PORTDOCS%%%%DOCSDIR%%/oc/XHTML.T.Basic_Forms.html
-%%PORTDOCS%%%%DOCSDIR%%/oc/XHTML.T.Basic_Tables.html
-%%PORTDOCS%%%%DOCSDIR%%/oc/XHTML.T.FORMS.html
-%%PORTDOCS%%%%DOCSDIR%%/oc/XHTML.T.HYPERTEXT.html
-%%PORTDOCS%%%%DOCSDIR%%/oc/XHTML.T.IMAGE.html
-%%PORTDOCS%%%%DOCSDIR%%/oc/XHTML.T.LINK.html
-%%PORTDOCS%%%%DOCSDIR%%/oc/XHTML.T.LIST.html
-%%PORTDOCS%%%%DOCSDIR%%/oc/XHTML.T.METAINFORMATION.html
-%%PORTDOCS%%%%DOCSDIR%%/oc/XHTML.T.PRESENTATION.html
-%%PORTDOCS%%%%DOCSDIR%%/oc/XHTML.T.SPECIAL.html
-%%PORTDOCS%%%%DOCSDIR%%/oc/XHTML.T.STRUCTURE.html
-%%PORTDOCS%%%%DOCSDIR%%/oc/XHTML.T.STYLE_SHEET.html
-%%PORTDOCS%%%%DOCSDIR%%/oc/XHTML.T.TABLES.html
-%%PORTDOCS%%%%DOCSDIR%%/oc/XHTML.T.TEXT.html
-%%PORTDOCS%%%%DOCSDIR%%/oc/XHTML.T.html
-%%PORTDOCS%%%%DOCSDIR%%/oc/XHTML.T_01_00.html
-%%PORTDOCS%%%%DOCSDIR%%/oc/XHTML.T_01_01.html
-%%PORTDOCS%%%%DOCSDIR%%/oc/XHTML.html
-%%PORTDOCS%%%%DOCSDIR%%/oc/code_VALMessages.access.html
-%%PORTDOCS%%%%DOCSDIR%%/oc/code_VALMessages.accesslog.html
-%%PORTDOCS%%%%DOCSDIR%%/oc/code_VALMessages.bip.html
-%%PORTDOCS%%%%DOCSDIR%%/oc/code_VALMessages.console.html
-%%PORTDOCS%%%%DOCSDIR%%/oc/code_VALMessages.debug.html
-%%PORTDOCS%%%%DOCSDIR%%/oc/code_VALMessages.debug_noel.html
-%%PORTDOCS%%%%DOCSDIR%%/oc/code_VALMessages.errlog.html
-%%PORTDOCS%%%%DOCSDIR%%/oc/code_VALMessages.error.html
-%%PORTDOCS%%%%DOCSDIR%%/oc/code_VALMessages.log_aux.html
-%%PORTDOCS%%%%DOCSDIR%%/oc/code_VALMessages.lwtbip.html
-%%PORTDOCS%%%%DOCSDIR%%/oc/code_VALMessages.open_files.html
-%%PORTDOCS%%%%DOCSDIR%%/oc/code_VALMessages.warning.html
-%%PORTDOCS%%%%DOCSDIR%%/oc/index.html
-%%PORTDOCS%%%%DOCSDIR%%/oc/index_attributes.html
-%%PORTDOCS%%%%DOCSDIR%%/oc/index_class_types.html
-%%PORTDOCS%%%%DOCSDIR%%/oc/index_classes.html
-%%PORTDOCS%%%%DOCSDIR%%/oc/index_exceptions.html
-%%PORTDOCS%%%%DOCSDIR%%/oc/index_methods.html
-%%PORTDOCS%%%%DOCSDIR%%/oc/index_module_types.html
-%%PORTDOCS%%%%DOCSDIR%%/oc/index_modules.html
-%%PORTDOCS%%%%DOCSDIR%%/oc/index_types.html
-%%PORTDOCS%%%%DOCSDIR%%/oc/index_values.html
-%%PORTDOCS%%%%DOCSDIR%%/oc/style.css
-%%PORTDOCS%%%%DOCSDIR%%/oc/type_Extensions.html
-%%PORTDOCS%%%%DOCSDIR%%/oc/type_Messages.html
-%%PORTDOCS%%%%DOCSDIR%%/oc/type_Ocsigen.Make.html
-%%PORTDOCS%%%%DOCSDIR%%/oc/type_Ocsigen.OCSIGENSIG.html
-%%PORTDOCS%%%%DOCSDIR%%/oc/type_Ocsigen.PAGES.html
-%%PORTDOCS%%%%DOCSDIR%%/oc/type_Ocsigen.Text.html
-%%PORTDOCS%%%%DOCSDIR%%/oc/type_Ocsigen.Xhtml.html
-%%PORTDOCS%%%%DOCSDIR%%/oc/type_Ocsigen.html
-%%PORTDOCS%%%%DOCSDIR%%/oc/type_Ocsigenboxes.html
-%%PORTDOCS%%%%DOCSDIR%%/oc/type_Parseconfig.html
-%%PORTDOCS%%%%DOCSDIR%%/oc/type_Predefined_senders.html
-%%PORTDOCS%%%%DOCSDIR%%/oc/type_Simplexmlparser.ExprOrPatt.html
-%%PORTDOCS%%%%DOCSDIR%%/oc/type_Simplexmlparser.html
-%%PORTDOCS%%%%DOCSDIR%%/oc/type_XHTML.M.html
-%%PORTDOCS%%%%DOCSDIR%%/oc/type_XHTML.M_01_00.html
-%%PORTDOCS%%%%DOCSDIR%%/oc/type_XHTML.M_01_01.html
-%%PORTDOCS%%%%DOCSDIR%%/oc/type_XHTML.T.BASE.html
-%%PORTDOCS%%%%DOCSDIR%%/oc/type_XHTML.T.Basic_Forms.html
-%%PORTDOCS%%%%DOCSDIR%%/oc/type_XHTML.T.Basic_Tables.html
-%%PORTDOCS%%%%DOCSDIR%%/oc/type_XHTML.T.FORMS.html
-%%PORTDOCS%%%%DOCSDIR%%/oc/type_XHTML.T.HYPERTEXT.html
-%%PORTDOCS%%%%DOCSDIR%%/oc/type_XHTML.T.IMAGE.html
-%%PORTDOCS%%%%DOCSDIR%%/oc/type_XHTML.T.LINK.html
-%%PORTDOCS%%%%DOCSDIR%%/oc/type_XHTML.T.LIST.html
-%%PORTDOCS%%%%DOCSDIR%%/oc/type_XHTML.T.METAINFORMATION.html
-%%PORTDOCS%%%%DOCSDIR%%/oc/type_XHTML.T.PRESENTATION.html
-%%PORTDOCS%%%%DOCSDIR%%/oc/type_XHTML.T.SPECIAL.html
-%%PORTDOCS%%%%DOCSDIR%%/oc/type_XHTML.T.STRUCTURE.html
-%%PORTDOCS%%%%DOCSDIR%%/oc/type_XHTML.T.STYLE_SHEET.html
-%%PORTDOCS%%%%DOCSDIR%%/oc/type_XHTML.T.TABLES.html
-%%PORTDOCS%%%%DOCSDIR%%/oc/type_XHTML.T.TEXT.html
-%%PORTDOCS%%%%DOCSDIR%%/oc/type_XHTML.T.html
-%%PORTDOCS%%%%DOCSDIR%%/oc/type_XHTML.T_01_00.html
-%%PORTDOCS%%%%DOCSDIR%%/oc/type_XHTML.T_01_01.html
-%%PORTDOCS%%%%DOCSDIR%%/oc/type_XHTML.html
-@dirrm %%EXAMPLESDIR%%
+etc/ocsigen/mime.types
+etc/ocsigen/ocsigen.conf
+etc/ocsigen/ocsigen.conf.sample
+etc/ocsigen/ocsigen.conf.opt.sample
+lib/ocsigen/METAS/META.eliom_examples
+lib/ocsigen/METAS/META.ocsigen_ext
+lib/ocsigen/examples/miniwiki.cmo
+lib/ocsigen/examples/monitoring.cmo
+lib/ocsigen/examples/tutoeliom.cmi
+lib/ocsigen/examples/tutoeliom.cmo
+lib/ocsigen/extensions/accesscontrol.cmo
+lib/ocsigen/extensions/authbasic.cmo
+lib/ocsigen/extensions/cgimod.cmo
+lib/ocsigen/extensions/eliom.cma
+lib/ocsigen/extensions/ocsidbm
+lib/ocsigen/extensions/ocsipersist-dbm.cma
+lib/ocsigen/extensions/outputfilter.cmo
+lib/ocsigen/extensions/redirectmod.cmo
+lib/ocsigen/extensions/revproxy.cmo
+lib/ocsigen/extensions/staticmod.cmo
+lib/ocsigen/extensions/userconf.cmo
+share/ocsigen/www/ocsigen/miniwiki/style.css
+share/ocsigen/www/ocsigen/ocsigenstuff/LICENSE
+share/ocsigen/www/ocsigen/ocsigenstuff/back.png
+share/ocsigen/www/ocsigen/ocsigenstuff/cdimage.png
+share/ocsigen/www/ocsigen/ocsigenstuff/deb.png
+share/ocsigen/www/ocsigen/ocsigenstuff/dvi.png
+share/ocsigen/www/ocsigen/ocsigenstuff/folder_open.png
+share/ocsigen/www/ocsigen/ocsigenstuff/html.png
+share/ocsigen/www/ocsigen/ocsigenstuff/image.png
+share/ocsigen/www/ocsigen/ocsigenstuff/ocsigen5.png
+share/ocsigen/www/ocsigen/ocsigenstuff/pdf.png
+share/ocsigen/www/ocsigen/ocsigenstuff/postscript.png
+share/ocsigen/www/ocsigen/ocsigenstuff/readme.png
+share/ocsigen/www/ocsigen/ocsigenstuff/rpm.png
+share/ocsigen/www/ocsigen/ocsigenstuff/sound.png
+share/ocsigen/www/ocsigen/ocsigenstuff/source_c.png
+share/ocsigen/www/ocsigen/ocsigenstuff/source_java.png
+share/ocsigen/www/ocsigen/ocsigenstuff/source_pl.png
+share/ocsigen/www/ocsigen/ocsigenstuff/source_py.png
+share/ocsigen/www/ocsigen/ocsigenstuff/style.css
+share/ocsigen/www/ocsigen/ocsigenstuff/tar.png
+share/ocsigen/www/ocsigen/ocsigenstuff/tex.png
+share/ocsigen/www/ocsigen/ocsigenstuff/tgz.png
+share/ocsigen/www/ocsigen/ocsigenstuff/txt.png
+share/ocsigen/www/ocsigen/ocsigenstuff/unknown.png
+share/ocsigen/www/ocsigen/ocsigenstuff/video.png
+share/ocsigen/www/ocsigen/tutorial/bulles-bleues.png
+share/ocsigen/www/ocsigen/tutorial/ocsigen5.png
+share/ocsigen/www/ocsigen/tutorial/style.css
+@dirrm share/ocsigen/www/ocsigen/miniwiki
+@dirrm share/ocsigen/www/ocsigen/ocsigenstuff
+@dirrm share/ocsigen/www/ocsigen/tutorial
+@dirrm share/ocsigen/www/ocsigen
@dirrm share/ocsigen/www
@dirrm share/ocsigen
-%%PORTDOCS%%@dirrm %%DOCSDIR%%/lwt
-%%PORTDOCS%%@dirrm %%DOCSDIR%%/oc
-%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@dirrm lib/ocsigen/METAS
+@dirrm lib/ocsigen/examples
+@dirrm lib/ocsigen/extensions
+@dirrm lib/ocsigen
+@dirrm etc/ocsigen
+@unexec if cmp -s %D/etc/${PORTNAME}/ocsigen.conf.sample %D/etc/${PORTNAME}/ocsigen.conf; then rm -f %D/etc/${PORTNAME}/ocsigen.conf; fi
+@exec if [ ! -f %D/etc/${PORTNAME}/ocsigen.conf ] ; then cp -p %D/%F %B/${PORTNAME}/ocsigen.conf; fi