aboutsummaryrefslogtreecommitdiffstats
path: root/www/opera-devel
diff options
context:
space:
mode:
authoritetcu <itetcu@FreeBSD.org>2008-04-28 23:11:59 +0800
committeritetcu <itetcu@FreeBSD.org>2008-04-28 23:11:59 +0800
commit53c686b86c78f275c797a2280a1333e2352142de (patch)
tree90a74d7c1842ae605ba0eae116e8cd450bec3664 /www/opera-devel
parentab5043cb5de380d63504ef014cf8c83ff329404e (diff)
downloadfreebsd-ports-gnome-53c686b86c78f275c797a2280a1333e2352142de.tar.gz
freebsd-ports-gnome-53c686b86c78f275c797a2280a1333e2352142de.tar.zst
freebsd-ports-gnome-53c686b86c78f275c797a2280a1333e2352142de.zip
Easter Bunny brings you the new opera-devel, with more native builds for
various OSVERSIONS and native amd64 builds. The most full-featured Internet power tool on the market, Opera includes pop-up blocking, tabbed browsing, integrated searches, and advanced functions like Opera's groundbreaking E-mail program, RSS Newsfeeds and IRC chat. And because we know that our users have different needs, you can customize the look and content of your Opera browser with a few clicks of the mouse. This port contains the devel/beta version, for the stable one please use www/opera. WWW: http://www.opera.com/
Diffstat (limited to 'www/opera-devel')
-rw-r--r--www/opera-devel/Makefile80
-rw-r--r--www/opera-devel/distinfo15
-rw-r--r--www/opera-devel/files/patch-install.sh48
-rw-r--r--www/opera-devel/pkg-descr10
-rw-r--r--www/opera-devel/pkg-message15
-rw-r--r--www/opera-devel/pkg-plist103
6 files changed, 271 insertions, 0 deletions
diff --git a/www/opera-devel/Makefile b/www/opera-devel/Makefile
new file mode 100644
index 000000000000..538d169a69f5
--- /dev/null
+++ b/www/opera-devel/Makefile
@@ -0,0 +1,80 @@
+# New ports collection makefile for: opera-devel
+# Date created: April 24th 2008
+# Whom: Arjan van Leeuwen
+#
+# $FreeBSD$
+#
+
+PORTNAME= opera
+PORTVERSION= ${OPERA_VER}.${OPERA_DATE}
+CATEGORIES= www ipv6
+MASTER_SITES= ftp://opera.inode.at/unix/freebsd/${OPERA_VER:S/.//}${OPERA_MINVER}/${OPERA_REL}/en/${OPERA_LIB}/ \
+ http://gd.tuwien.ac.at/infosys/browsers/opera/unix/freebsd/${OPERA_VER:S/.//}${OPERA_MINVER}/${OPERA_REL}/en/${OPERA_LIB}/ \
+ http://ftp.ucr.ac.cr/WWW/opera/unix/freebsd/${OPERA_VER:S/.//}${OPERA_MINVER}/${OPERA_REL}/en/${OPERA_LIB}/ \
+ http://www.microrpm.ca/pub/opera/unix/freebsd/${OPERA_VER:S/.//}${OPERA_MINVER}/${OPERA_REL}/en/${OPERA_LIB}/ \
+ http://www.opera.mirroarrr.de/unix/freebsd/${OPERA_VER:S/.//}${OPERA_MINVER}/${OPERA_REL}/en/${OPERA_LIB}/ \
+ http://opera.eurenet.net/unix/freebsd/${OPERA_VER:S/.//}${OPERA_MINVER}/${OPERA_REL}/en/${OPERA_LIB}/ \
+ ftp://opera.ftp.fu-berlin.de/unix/freebsd/${OPERA_VER:S/.//}${OPERA_MINVER}/${OPERA_REL}/en/${OPERA_LIB}/ \
+ http://ftp.ntua.gr/pub/www/Opera/unix/freebsd/${OPERA_VER:S/.//}${OPERA_MINVER}/${OPERA_REL}/en/${OPERA_LIB}/ \
+ ftp://ftp.wayne.edu/opera/unix/freebsd/${OPERA_VER:S/.//}${OPERA_MINVER}/${OPERA_REL}/en/${OPERA_LIB}/ \
+ http://mirrors.dedipower.com/opera/unix/freebsd/${OPERA_VER:S/.//}${OPERA_MINVER}/${OPERA_REL}/en/${OPERA_LIB}/ \
+ ftp://ftp.mirror.ac.uk/sites/ftp.opera.com/unix/freebsd/${OPERA_VER:S/.//}${OPERA_MINVER}/${OPERA_REL}/en/${OPERA_LIB}/ \
+ http://opera.nedmirror.nl/unix/freebsd/${OPERA_VER:S/.//}${OPERA_MINVER}/${OPERA_REL}/en/${OPERA_LIB}/ \
+ ftp://ftp.tiscali.nl/pub/mirrors/opera/unix/freebsd/${OPERA_VER:S/.//}${OPERA_MINVER}/${OPERA_REL}/en/${OPERA_LIB}/ \
+ ${MASTER_SITE_RINGSERVER:S,%SUBDIR%,net/www/opera/unix/freebsd/${OPERA_VER:S/.//}${OPERA_MINVER}/${OPERA_REL}/en/${OPERA_LIB}/&,} \
+ ftp://ftp.opera.com/pub/opera/unix/freebsd/${OPERA_VER:S/.//}${OPERA_MINVER}/${OPERA_REL}/en/${OPERA_LIB}/
+PKGNAMESUFFIX= -devel
+DISTNAME= ${PORTNAME}-${OPERA_VER}${OPERA_MINVER}-${OPERA_DATE}.${OPERA_TYPE}-shared-qt.${ARCH}.freebsd
+
+MAINTAINER= freebsd-maintainer@opera.com
+COMMENT= Blazingly fast, full-featured, standards-compliant browser, devel version
+
+OPERA_VER= 9.50
+OPERA_MINVER= b2
+OPERA_REL= final
+OPERA_DATE= 20080422
+OPERA_BUILD= 1933
+
+DATADIR= ${PREFIX}/share/${PORTNAME}${PKGNAMESUFFIX}
+DOCSDIR= ${PREFIX}/share/doc/${PORTNAME}${PKGNAMESUFFIX}
+
+USE_BZIP2= yes
+ONLY_FOR_ARCHS= i386 amd64
+WRKSRC= ${WRKDIR}/${PORTNAME}-${OPERA_VER}-${OPERA_DATE}.${OPERA_TYPE}-shared-qt.${ARCH}.freebsd-${OPERA_BUILD}
+USE_QT_VER= 3
+
+NO_BUILD= yes
+
+OPTIONS= ASPELL "Use the aspell library for spell checking" on
+
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == amd64
+OPERA_LIB= amd64
+.else
+OPERA_LIB= shared
+.endif
+
+.if ${OSVERSION} >= 700000
+OPERA_TYPE= 7
+.elif ${OSVERSION} >= 600000
+.if ${ARCH} == amd64
+OPERA_TYPE= 1
+.else
+OPERA_TYPE= 4
+.endif
+.else
+OPERA_TYPE= 3
+.endif
+
+.if !defined(WITHOUT_ASPELL)
+LIB_DEPENDS+= aspell.16:${PORTSDIR}/textproc/aspell
+.endif
+
+do-install:
+ @(cd ${WRKSRC} && ./install.sh --prefix=${PREFIX} --docdir=${DOCSDIR} --sharedir=${DATADIR} --exec_prefix=${DATADIR}/bin --plugindir=${DATADIR}/plugins)
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.post.mk>
diff --git a/www/opera-devel/distinfo b/www/opera-devel/distinfo
new file mode 100644
index 000000000000..ba38a7fe34d7
--- /dev/null
+++ b/www/opera-devel/distinfo
@@ -0,0 +1,15 @@
+MD5 (opera-9.50b2-20080422.3-shared-qt.i386.freebsd.tar.bz2) = bb0c80d0a0a7ebfa75edc0c3a6bc8088
+SHA256 (opera-9.50b2-20080422.3-shared-qt.i386.freebsd.tar.bz2) = a13ad2bddb5bde702d7d964791c345c08b6c46bc8a9d5406830e1f665ec5420d
+SIZE (opera-9.50b2-20080422.3-shared-qt.i386.freebsd.tar.bz2) = 5796100
+MD5 (opera-9.50b2-20080422.4-shared-qt.i386.freebsd.tar.bz2) = 4416c3e77a4f8f052f987c8f221c52f0
+SHA256 (opera-9.50b2-20080422.4-shared-qt.i386.freebsd.tar.bz2) = d309d0c0bb0289232e41c6e82c26bfe7ce7ae4036869812826a35f57f5ea3391
+SIZE (opera-9.50b2-20080422.4-shared-qt.i386.freebsd.tar.bz2) = 5797946
+MD5 (opera-9.50b2-20080422.7-shared-qt.i386.freebsd.tar.bz2) = e901027bd053d6ce935ee90b08c961a6
+SHA256 (opera-9.50b2-20080422.7-shared-qt.i386.freebsd.tar.bz2) = 88d3a368d585e986e04931a5843e861214fdb91538177d657e16130b98271bb0
+SIZE (opera-9.50b2-20080422.7-shared-qt.i386.freebsd.tar.bz2) = 5673371
+MD5 (opera-9.50b2-20080422.1-shared-qt.amd64.freebsd.tar.bz2) = b20a87dbf6ca63226c28b9206f288765
+SHA256 (opera-9.50b2-20080422.1-shared-qt.amd64.freebsd.tar.bz2) = 763612270901a410db5085e1dd225aa23aea7bec8177813e3f468c820dc2cdb7
+SIZE (opera-9.50b2-20080422.1-shared-qt.amd64.freebsd.tar.bz2) = 6274070
+MD5 (opera-9.50b2-20080422.7-shared-qt.amd64.freebsd.tar.bz2) = adb4e8675bd5ea8a11b3679665f6c103
+SHA256 (opera-9.50b2-20080422.7-shared-qt.amd64.freebsd.tar.bz2) = 5d97f5445152c978cb134da1a801ebdcc2fa56037034718e87aca01aa04f8080
+SIZE (opera-9.50b2-20080422.7-shared-qt.amd64.freebsd.tar.bz2) = 6198726
diff --git a/www/opera-devel/files/patch-install.sh b/www/opera-devel/files/patch-install.sh
new file mode 100644
index 000000000000..db8de6119f8a
--- /dev/null
+++ b/www/opera-devel/files/patch-install.sh
@@ -0,0 +1,48 @@
+--- install.sh.orig 2008-04-22 16:06:18.000000000 +0200
++++ install.sh 2008-04-24 13:49:24.470507835 +0200
+@@ -865,7 +865,7 @@
+ error 'os'
+ ;;
+ esac
+- wrapper_file="${wrapper_dir}/opera"
++ wrapper_file="${wrapper_dir}/opera-devel"
+
+ wrapper_contain="#!/bin/sh
+
+@@ -877,6 +877,10 @@
+ OPERA_BINARYDIR=${str_localdirexec}
+ export OPERA_BINARYDIR
+
++# Location of Opera personal dir
++OPERA_PERSONALDIR=\${HOME}/.opera-devel
++export OPERA_PERSONALDIR
++
+ # Parse commandline parameters
+ toset=
+ _QTSTYLE_FROM_CMDLINE_='NO'
+@@ -1259,7 +1263,6 @@
+ manifest_contains operapluginwrapper-native && part_install "`manifest_path operapluginwrapper-native`" "$exec_dir" Binaries
+ manifest_contains operapluginwrapper-ia32-linux && part_install "`manifest_path operapluginwrapper-ia32-linux`" "$exec_dir" Binaries
+ part_install "`manifest_path LICENSE`" "$doc_dir" Documentation
+- part_install "`manifest_path man1/opera.1`" "$man_dir" "Manual page"
+
+ share_src="`manifest_path 'html40_entities\.dtd'`"
+ part_install "$share_src" "$share_dir" "Shared resources"
+@@ -1268,15 +1271,14 @@
+ mkdir $mkdirv $mkdirp $plugin_dir/
+
+ # Wrapper
+- backup ${wrapper_dir}/opera opera
+ debug_msg 1 "Wrapper"
+ mkdir $mkdirv $mkdirp $wrapper_dir/
+
+ #cp $cpv $cpf wrapper.sh $wrapper_dir/opera
+ generate_wrapper
+- chmod $chmodv 755 $wrapper_dir/opera
++ chmod $chmodv 755 $wrapper_dir/opera-devel
+
+- if test -z "$OPERADESTDIR"
++ if false
+ then
+ # System wide configuration files
+ case $os in AnyBSD|OpenBSD) config_dir="/usr/local/etc";; *) config_dir="/etc";; esac
diff --git a/www/opera-devel/pkg-descr b/www/opera-devel/pkg-descr
new file mode 100644
index 000000000000..639f77ae9ea0
--- /dev/null
+++ b/www/opera-devel/pkg-descr
@@ -0,0 +1,10 @@
+The most full-featured Internet power tool on the market, Opera includes
+pop-up blocking, tabbed browsing, integrated searches, and advanced functions
+like Opera's groundbreaking E-mail program, RSS Newsfeeds and IRC chat. And
+because we know that our users have different needs, you can customize
+the look and content of your Opera browser with a few clicks of the mouse.
+
+This port contains the devel/beta version, for the stable one please use
+www/opera.
+
+WWW: http://www.opera.com/
diff --git a/www/opera-devel/pkg-message b/www/opera-devel/pkg-message
new file mode 100644
index 000000000000..f9bf08be138a
--- /dev/null
+++ b/www/opera-devel/pkg-message
@@ -0,0 +1,15 @@
+###########################################################################
+
+This is a beta version of Opera. It is likely to contain bugs, and should
+not be relied on for daily use.
+
+Instead of your normal profile, it will by default use the profile in
+~/.opera-devel, so that you can use both a stable version and a development
+version of Opera in parallel.
+
+Please report any bugs you find at https://bugs.opera.com/wizard/.
+
+Have fun!
+- The Opera Desktop Team
+
+###########################################################################
diff --git a/www/opera-devel/pkg-plist b/www/opera-devel/pkg-plist
new file mode 100644
index 000000000000..66de67148064
--- /dev/null
+++ b/www/opera-devel/pkg-plist
@@ -0,0 +1,103 @@
+bin/opera-devel
+%%DATADIR%%/svg-mo.dat
+%%DATADIR%%/skin/windows_skin.zip
+%%DATADIR%%/skin/standard_skin.zip
+%%DATADIR%%/opera6.adr
+%%DATADIR%%/svg-se.dat
+%%DATADIR%%/html40_entities.dtd
+%%DATADIR%%/svg-sebd.dat
+%%DATADIR%%/java/opera.policy
+%%DATADIR%%/java/opera.jar
+%%DATADIR%%/bin/works
+%%DATADIR%%/bin/operapluginwrapper
+%%DATADIR%%/bin/missingsyms.so
+%%DATADIR%%/bin/spellcheck.so
+%%DATADIR%%/bin/operaplugincleaner
+%%DATADIR%%/bin/opera
+%%DATADIR%%/styles/im.css
+%%DATADIR%%/styles/mime.css
+%%DATADIR%%/styles/warning.css
+%%DATADIR%%/styles/certinfo.css
+%%DATADIR%%/styles/error.css
+%%DATADIR%%/styles/cache.css
+%%DATADIR%%/styles/plugins.css
+%%DATADIR%%/styles/user/toc.css
+%%DATADIR%%/styles/user/disableforms.css
+%%DATADIR%%/styles/user/disablebreaks.css
+%%DATADIR%%/styles/user/disablepositioning.css
+%%DATADIR%%/styles/user/disablefloats.css
+%%DATADIR%%/styles/user/altdebugger.css
+%%DATADIR%%/styles/user/structuretables.css
+%%DATADIR%%/styles/user/classid.css
+%%DATADIR%%/styles/user/structureblock.css
+%%DATADIR%%/styles/user/outline.css
+%%DATADIR%%/styles/user/disabletables.css
+%%DATADIR%%/styles/user/contrastwb.css
+%%DATADIR%%/styles/user/tablelayout.css
+%%DATADIR%%/styles/user/structureinline.css
+%%DATADIR%%/styles/user/contrastbw.css
+%%DATADIR%%/styles/user/accessibility.css
+%%DATADIR%%/styles/wml.css
+%%DATADIR%%/styles/history.css
+%%DATADIR%%/styles/images/red_right.png
+%%DATADIR%%/styles/images/flag.png
+%%DATADIR%%/styles/images/defaultFavicon.png
+%%DATADIR%%/styles/images/root.png
+%%DATADIR%%/styles/images/folder.png
+%%DATADIR%%/styles/images/red_left.png
+%%DATADIR%%/styles/images/darkBox.png
+%%DATADIR%%/styles/images/bar.png
+%%DATADIR%%/styles/images/smartGroup.png
+%%DATADIR%%/styles/images/center.png
+%%DATADIR%%/styles/images/top.png
+%%DATADIR%%/styles/images/section.png
+%%DATADIR%%/styles/images/customize.gif
+%%DATADIR%%/styles/images/opera.png
+%%DATADIR%%/styles/images/red_center.png
+%%DATADIR%%/styles/config.css
+%%DATADIR%%/styles/search.css
+%%DATADIR%%/styles/message.css
+%%DATADIR%%/styles/dir.css
+%%DATADIR%%/styles/info.css
+%%DATADIR%%/styles/mathml.css
+%%DATADIR%%/styles/contentblock.css
+%%DATADIR%%/styles/about.css
+%%DATADIR%%/styles/image.css
+%%DATADIR%%/encoding.bin
+%%DATADIR%%/lngcode.txt
+%%DATADIR%%/ini/xmlentities.ini
+%%DATADIR%%/ini/unix_keyboard.ini
+%%DATADIR%%/ini/font.ini
+%%DATADIR%%/ini/filehandler.ini
+%%DATADIR%%/ini/standard_keyboard_compat.ini
+%%DATADIR%%/ini/mailproviders.xml
+%%DATADIR%%/ini/pluginpath.ini
+%%DATADIR%%/ini/dialog.ini
+%%DATADIR%%/ini/standard_mouse.ini
+%%DATADIR%%/ini/fastforward.ini
+%%DATADIR%%/ini/standard_menu.ini
+%%DATADIR%%/ini/standard_toolbar.ini
+%%DATADIR%%/ini/standard_keyboard.ini
+%%DATADIR%%/svg-sa.dat
+%%DATADIR%%/search.ini
+%%DATADIR%%/locale/en/license.txt
+%%DATADIR%%/locale/en/opera6.adr
+%%DATADIR%%/locale/en/search.ini
+%%DATADIR%%/locale/english.lng
+%%DATADIR%%/svg-mobd.dat
+%%DATADIR%%/svg-sabd.dat
+%%DOCSDIR%%/LGPL
+%%DOCSDIR%%/LICENSE
+
+@dirrm %%DATADIR%%/styles/user
+@dirrm %%DATADIR%%/styles/images
+@dirrm %%DATADIR%%/styles
+@dirrm %%DATADIR%%/skin
+@dirrm %%DATADIR%%/plugins
+@dirrm %%DATADIR%%/locale/en
+@dirrm %%DATADIR%%/locale
+@dirrm %%DATADIR%%/java
+@dirrm %%DATADIR%%/ini
+@dirrm %%DATADIR%%/bin
+@dirrm %%DATADIR%%
+@dirrm %%DOCSDIR%%