aboutsummaryrefslogtreecommitdiffstats
path: root/www/orion
diff options
context:
space:
mode:
authorznerd <znerd@FreeBSD.org>2002-03-29 20:54:15 +0800
committerznerd <znerd@FreeBSD.org>2002-03-29 20:54:15 +0800
commit236c8ea5bf0e0c13d516020f1e5a28a6dd22c6ec (patch)
treeff98ed2696b99f9f916dbcdf0ab860a2e14d02b2 /www/orion
parentef595ab474ba331d5105e53c45fa9a4f58b9049e (diff)
downloadfreebsd-ports-gnome-236c8ea5bf0e0c13d516020f1e5a28a6dd22c6ec.tar.gz
freebsd-ports-gnome-236c8ea5bf0e0c13d516020f1e5a28a6dd22c6ec.tar.zst
freebsd-ports-gnome-236c8ea5bf0e0c13d516020f1e5a28a6dd22c6ec.zip
Improved startup script. It now creates the PID file and fixes
the ownership and permissions before actually calling the orionctl program. Bumped PORTREVISION.
Diffstat (limited to 'www/orion')
-rw-r--r--www/orion/Makefile2
-rw-r--r--www/orion/files/orion.sh13
2 files changed, 14 insertions, 1 deletions
diff --git a/www/orion/Makefile b/www/orion/Makefile
index bcfb92e8526d..ba06e3b04b6b 100644
--- a/www/orion/Makefile
+++ b/www/orion/Makefile
@@ -7,7 +7,7 @@
PORTNAME= orion
PORTVERSION= 1.5.2
-PORTREVISION= 12
+PORTREVISION= 13
CATEGORIES= www java
MASTER_SITES= http://www.orionserver.com/distributions/ \
http://www.atlassian.com/software/orion/downloads/ \
diff --git a/www/orion/files/orion.sh b/www/orion/files/orion.sh
index 2bff6366dd1a..6627cfbda27f 100644
--- a/www/orion/files/orion.sh
+++ b/www/orion/files/orion.sh
@@ -1,13 +1,26 @@
#!/bin/sh
+# -*- mode: Fundamental; tab-width: 4; -*-
+# ex:ts=4
+#
+# Orion startup script.
+#
+# $FreeBSD$
+#
+
# Set some variables
MYSELF=`basename $0`
case "$1" in
start)
+ truncate -s 0 %%PID_FILE%%
+ chown %%USER%%:%%GROUP%% %%PID_FILE%%
+ chmod 600 %%PID_FILE%%
su -f -m %%USER%% -c "exec %%CONTROL_SCRIPT%% start > /dev/null" && echo -n ' %%APP_SHORTNAME%%'
;;
stop)
+ chown %%USER%%:%%GROUP%% %%PID_FILE%%
+ chmod 600 %%PID_FILE%%
su -f -m %%USER%% -c "exec %%CONTROL_SCRIPT%% stop > /dev/null" && echo -n ' %%APP_SHORTNAME%%'
;;
*)