aboutsummaryrefslogtreecommitdiffstats
path: root/www/owncloud
diff options
context:
space:
mode:
authorkevlo <kevlo@FreeBSD.org>2011-10-14 18:32:33 +0800
committerkevlo <kevlo@FreeBSD.org>2011-10-14 18:32:33 +0800
commit60f3774a7b3d4040219489a892d4825b5c6c595d (patch)
tree2cec77adb6f8601450900c2b0efdddf0af6bb6e7 /www/owncloud
parent9c3307a3dc5fff5828f197743d50ae6340b877d8 (diff)
downloadfreebsd-ports-gnome-60f3774a7b3d4040219489a892d4825b5c6c595d.tar.gz
freebsd-ports-gnome-60f3774a7b3d4040219489a892d4825b5c6c595d.tar.zst
freebsd-ports-gnome-60f3774a7b3d4040219489a892d4825b5c6c595d.zip
Initial import of owncloud.
Owncloud is a personal cloud which runs on your own server.
Diffstat (limited to 'www/owncloud')
-rw-r--r--www/owncloud/Makefile40
-rw-r--r--www/owncloud/distinfo2
-rw-r--r--www/owncloud/files/pkg-message.in21
-rw-r--r--www/owncloud/pkg-descr4
4 files changed, 67 insertions, 0 deletions
diff --git a/www/owncloud/Makefile b/www/owncloud/Makefile
new file mode 100644
index 000000000000..079fdc6f42aa
--- /dev/null
+++ b/www/owncloud/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: owncloud
+# Date created: 14 October 2011
+# Whom: Kevin Lo <kevlo@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= owncloud
+PORTVERSION= 2
+CATEGORIES= www
+MASTER_SITES= http://owncloud.org/releases/
+
+MAINTAINER= kevlo@FreeBSD.org
+COMMENT= A personal cloud which runs on your own server
+
+BUILD_DEPENDS= mp3info:${PORTSDIR}/audio/mp3info
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+USE_BZIP2= yes
+USE_PHP= ctype curl hash json mbstring mysql session simplexml sqlite zip
+
+WWWDOCROOT?= www
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+NO_BUILD= yes
+SUB_FILES= pkg-message
+
+do-install:
+ ${MKDIR} ${WWWDIR}
+ @cd ${WRKSRC} && ${COPYTREE_SHARE} . ${WWWDIR}
+ ${CHOWN} -R ${WWWOWN}:${WWWGRP} ${WWWDIR}
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+ @${FIND} -s -d ${WWWDIR} -type f -print | \
+ ${SED} -e "s#${PREFIX}/##g" >> ${TMPPLIST}
+ @${FIND} -s -d ${WWWDIR} -type d -print | \
+ ${SED} -E -e "s#${PREFIX}/#@dirrm #g" >> ${TMPPLIST}
+
+.include <bsd.port.mk>
diff --git a/www/owncloud/distinfo b/www/owncloud/distinfo
new file mode 100644
index 000000000000..cce62d1fefe1
--- /dev/null
+++ b/www/owncloud/distinfo
@@ -0,0 +1,2 @@
+SHA256 (owncloud-2.tar.bz2) = 728410817b10ad78bcbcfc22e1a28a1949b60af04834719babbfef4204d2a8c1
+SIZE (owncloud-2.tar.bz2) = 1169660
diff --git a/www/owncloud/files/pkg-message.in b/www/owncloud/files/pkg-message.in
new file mode 100644
index 000000000000..e10bc7d9a7aa
--- /dev/null
+++ b/www/owncloud/files/pkg-message.in
@@ -0,0 +1,21 @@
+
+***********************************************************************
+* POST INSTALL CONFIGURATION *
+***********************************************************************
+
+Please note that everything has been installed in %%WWWDIR%%.
+
+Read %%WWWDIR%%/README.
+
+You will probably want to add an alias to your httpd.conf file, something
+like this:
+
+ Alias /owncloud %%WWWDIR%%
+ AcceptPathInfo On
+ <Directory %%WWWDIR%%>
+ AllowOverride All
+ Order Allow,Deny
+ Allow from all
+ </Directory>
+
+And restart Apache.
diff --git a/www/owncloud/pkg-descr b/www/owncloud/pkg-descr
new file mode 100644
index 000000000000..472c6da40a7d
--- /dev/null
+++ b/www/owncloud/pkg-descr
@@ -0,0 +1,4 @@
+Owncloud is a system for the creation and management of personal
+cloud resources.
+
+WWW: http://owncloud.org