aboutsummaryrefslogtreecommitdiffstats
path: root/www/p5-AMF-Perl
diff options
context:
space:
mode:
authorskv <skv@FreeBSD.org>2003-05-20 18:17:32 +0800
committerskv <skv@FreeBSD.org>2003-05-20 18:17:32 +0800
commitd2360daf5392ed6b9cde3f820912f4113a87094b (patch)
treeed857730fd6932e790f596bfbb2f8ad57e1c7af5 /www/p5-AMF-Perl
parent8b9f57b45337c097768e5413e9c397cb5e688055 (diff)
downloadfreebsd-ports-gnome-d2360daf5392ed6b9cde3f820912f4113a87094b.tar.gz
freebsd-ports-gnome-d2360daf5392ed6b9cde3f820912f4113a87094b.tar.zst
freebsd-ports-gnome-d2360daf5392ed6b9cde3f820912f4113a87094b.zip
Add p5-Flash-FLAP 0.05, flash Remoting in Perl.
Diffstat (limited to 'www/p5-AMF-Perl')
-rw-r--r--www/p5-AMF-Perl/Makefile30
-rw-r--r--www/p5-AMF-Perl/distinfo1
-rw-r--r--www/p5-AMF-Perl/pkg-descr17
-rw-r--r--www/p5-AMF-Perl/pkg-plist18
4 files changed, 66 insertions, 0 deletions
diff --git a/www/p5-AMF-Perl/Makefile b/www/p5-AMF-Perl/Makefile
new file mode 100644
index 000000000000..0f5ef2eae874
--- /dev/null
+++ b/www/p5-AMF-Perl/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: Flash-FLAP
+# Date created: 20 May 2003
+# Whom: Sergey Skvortsov <skv@protey.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Flash-FLAP
+PORTVERSION= 0.05
+CATEGORIES= www devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Flash
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= skv@FreeBSD.org
+COMMENT= Flash Remoting in Perl
+
+PERL_CONFIGURE= yes
+
+MAN3= Flash::FLAP.3 Flash::FLAP::App::Executive.3 \
+ Flash::FLAP::IO::Deserializer.3 Flash::FLAP::IO::InputStream.3 \
+ Flash::FLAP::IO::OutputStream.3 Flash::FLAP::IO::Serializer.3 \
+ Flash::FLAP::Sql::MysqlRecordSet.3 Flash::FLAP::Util::Object.3 \
+ Flash::FLAP::Util::RemotingService.3
+
+post-configure:
+# dirty hack to deceive irritable pod2man
+ @${PERL} -pi -e 's/^(POD2MAN_EXE.*)$$/\1 --lax/;' ${WRKSRC}/Makefile
+
+.include <bsd.port.mk>
diff --git a/www/p5-AMF-Perl/distinfo b/www/p5-AMF-Perl/distinfo
new file mode 100644
index 000000000000..eefa1bae01a5
--- /dev/null
+++ b/www/p5-AMF-Perl/distinfo
@@ -0,0 +1 @@
+MD5 (Flash-FLAP-0.05.tar.gz) = 2da54cb815891863f5d0a1515710f47b
diff --git a/www/p5-AMF-Perl/pkg-descr b/www/p5-AMF-Perl/pkg-descr
new file mode 100644
index 000000000000..0ed4dba72e64
--- /dev/null
+++ b/www/p5-AMF-Perl/pkg-descr
@@ -0,0 +1,17 @@
+Flash Remoting is a way for Flash movies running in a web browser to
+request structured data from the web server. The following data types
+are supported - strings, numbers, dates, arrays, dictionaries/hashes,
+objects, recordsets. Flash clients talk with the server using the AMF
+protocol, which is proprietary to Macromedia. However, it's not that
+hard to decode.
+
+Using Flash::FLAP it is possible to send arbitrary data between client
+and server using very few lines of code. There is no need to pack
+complicated data structures into CGI form parameteres or XML strings.
+The coding time can be spent on better things - data preparation and
+graphical presentation, not data delivery.
+
+WWW: http://search.cpan.org/dist/Flash-FLAP/
+
+-- Sergey Skvortsov
+skv@FreeBSD.org
diff --git a/www/p5-AMF-Perl/pkg-plist b/www/p5-AMF-Perl/pkg-plist
new file mode 100644
index 000000000000..d0b2feb730fe
--- /dev/null
+++ b/www/p5-AMF-Perl/pkg-plist
@@ -0,0 +1,18 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Flash/FLAP/.packlist
+%%SITE_PERL%%/Flash/FLAP.pm
+%%SITE_PERL%%/Flash/FLAP/App/Executive.pm
+%%SITE_PERL%%/Flash/FLAP/IO/Deserializer.pm
+%%SITE_PERL%%/Flash/FLAP/IO/InputStream.pm
+%%SITE_PERL%%/Flash/FLAP/IO/OutputStream.pm
+%%SITE_PERL%%/Flash/FLAP/IO/Serializer.pm
+%%SITE_PERL%%/Flash/FLAP/Sql/MysqlRecordSet.pm
+%%SITE_PERL%%/Flash/FLAP/Util/Object.pm
+%%SITE_PERL%%/Flash/FLAP/Util/RemotingService.pm
+@dirrm %%SITE_PERL%%/Flash/FLAP/App
+@dirrm %%SITE_PERL%%/Flash/FLAP/IO
+@dirrm %%SITE_PERL%%/Flash/FLAP/Sql
+@dirrm %%SITE_PERL%%/Flash/FLAP/Util
+@dirrm %%SITE_PERL%%/Flash/FLAP
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Flash/FLAP
+@unexec rmdir %D/%%SITE_PERL%%/Flash 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Flash 2>/dev/null || true