aboutsummaryrefslogtreecommitdiffstats
path: root/www/p5-AnyEvent-HTTP
diff options
context:
space:
mode:
authorbeech <beech@FreeBSD.org>2008-07-08 15:22:32 +0800
committerbeech <beech@FreeBSD.org>2008-07-08 15:22:32 +0800
commit1cd0f05c45258bf1be286e2dedbd7127a49ed64f (patch)
tree28af80d1654191ed222f29f07d15845787b0231b /www/p5-AnyEvent-HTTP
parent31c7598c77af185ca10730bebfa749be6dfc1770 (diff)
downloadfreebsd-ports-gnome-1cd0f05c45258bf1be286e2dedbd7127a49ed64f.tar.gz
freebsd-ports-gnome-1cd0f05c45258bf1be286e2dedbd7127a49ed64f.tar.zst
freebsd-ports-gnome-1cd0f05c45258bf1be286e2dedbd7127a49ed64f.zip
- New port p5-AnyEvent-HTTP-1.0.3
Implements a simple, stateless and non-blocking HTTP client. It supports GET, POST and other request methods, cookies and more, all on a very low level. It can follow redirects supports proxies and automatically limits the number of connections to the values specified in the RFC. WWW: http://search.cpan.org/perldoc?AnyEvent::HTTP PR: ports/125342 Submitted by: Vladimir Timofeev <vovkasm at gmail.com>
Diffstat (limited to 'www/p5-AnyEvent-HTTP')
-rw-r--r--www/p5-AnyEvent-HTTP/Makefile25
-rw-r--r--www/p5-AnyEvent-HTTP/distinfo3
-rw-r--r--www/p5-AnyEvent-HTTP/pkg-descr6
-rw-r--r--www/p5-AnyEvent-HTTP/pkg-plist5
4 files changed, 39 insertions, 0 deletions
diff --git a/www/p5-AnyEvent-HTTP/Makefile b/www/p5-AnyEvent-HTTP/Makefile
new file mode 100644
index 000000000000..6caced1827a0
--- /dev/null
+++ b/www/p5-AnyEvent-HTTP/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: p5-AnyEvent-HTTP
+# Date created: 06 Jul 2008
+# Whom: Vladimir Timofeev <vovkasm@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= AnyEvent-HTTP
+PORTVERSION= 1.03
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= ../../authors/id/M/ML/MLEHMANN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= vovkasm@gmail.com
+COMMENT= Simple but non-blocking HTTP/HTTPS client
+
+BUILD_DEPENDS= p5-AnyEvent>=4.14:${PORTSDIR}/devel/p5-AnyEvent
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= AnyEvent::HTTP.3
+
+.include <bsd.port.mk>
diff --git a/www/p5-AnyEvent-HTTP/distinfo b/www/p5-AnyEvent-HTTP/distinfo
new file mode 100644
index 000000000000..c467a35907dc
--- /dev/null
+++ b/www/p5-AnyEvent-HTTP/distinfo
@@ -0,0 +1,3 @@
+MD5 (AnyEvent-HTTP-1.03.tar.gz) = 3fe4a645a95dd56812830d0a6656c0d9
+SHA256 (AnyEvent-HTTP-1.03.tar.gz) = 1e66f12348569bbc74f9bfd339e20cfcb4ea23180d25cb854d528b7b763ffa7a
+SIZE (AnyEvent-HTTP-1.03.tar.gz) = 8161
diff --git a/www/p5-AnyEvent-HTTP/pkg-descr b/www/p5-AnyEvent-HTTP/pkg-descr
new file mode 100644
index 000000000000..6128e1dd25b8
--- /dev/null
+++ b/www/p5-AnyEvent-HTTP/pkg-descr
@@ -0,0 +1,6 @@
+Implements a simple, stateless and non-blocking HTTP client. It supports GET,
+POST and other request methods, cookies and more, all on a very low level.
+It can follow redirects supports proxies and automatically limits the number
+of connections to the values specified in the RFC.
+
+WWW: http://search.cpan.org/perldoc?AnyEvent::HTTP
diff --git a/www/p5-AnyEvent-HTTP/pkg-plist b/www/p5-AnyEvent-HTTP/pkg-plist
new file mode 100644
index 000000000000..1bb27871a819
--- /dev/null
+++ b/www/p5-AnyEvent-HTTP/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/AnyEvent/HTTP.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/AnyEvent/HTTP/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/AnyEvent/HTTP
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/AnyEvent
+@dirrmtry %%SITE_PERL%%/AnyEvent