aboutsummaryrefslogtreecommitdiffstats
path: root/www/p5-Apache-ASP/Makefile
diff options
context:
space:
mode:
authorsteve <steve@FreeBSD.org>2000-01-29 13:48:18 +0800
committersteve <steve@FreeBSD.org>2000-01-29 13:48:18 +0800
commitd6393274299b1985aa32a137ab5c90e0931fb69a (patch)
tree9f98f01dd07c6c274cc0f34c98378e64942900d2 /www/p5-Apache-ASP/Makefile
parent818ccaa880cec63fd43d0b786673cecbcea6dfcd (diff)
downloadfreebsd-ports-gnome-d6393274299b1985aa32a137ab5c90e0931fb69a.tar.gz
freebsd-ports-gnome-d6393274299b1985aa32a137ab5c90e0931fb69a.tar.zst
freebsd-ports-gnome-d6393274299b1985aa32a137ab5c90e0931fb69a.zip
Adding p5-Apache-ASP version 0.17.
Active Server Pages for Apache with mod_perl. PR: 15815 Submitted by: Igor Vinokurov <igor@zynaps.ru>
Diffstat (limited to 'www/p5-Apache-ASP/Makefile')
-rw-r--r--www/p5-Apache-ASP/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/www/p5-Apache-ASP/Makefile b/www/p5-Apache-ASP/Makefile
new file mode 100644
index 000000000000..676d668914ad
--- /dev/null
+++ b/www/p5-Apache-ASP/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: p5-Apache-ASP
+# Version required: 0.17
+# Date created: 31 December 1999
+# Whom: Igor Vinokurov <igor@zynaps.ru>
+#
+# $FreeBSD$
+#
+
+DISTNAME= Apache-ASP-0.17
+PKGNAME= p5-Apache-ASP-0.17
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Apache
+
+MAINTAINER= igor@zynaps.ru
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/mod_perl.pm:${PORTSDIR}/www/p5-Apache \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5 \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/MLDBM.pm:${PORTSDIR}/databases/p5-MLDBM \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/HTTP/Date.pm:${PORTSDIR}/www/p5-libwww \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Devel/Symdump.pm:${PORTSDIR}/devel/p5-Devel-Symdump
+
+USE_PERL5= YES
+
+MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= Apache::ASP.3
+
+do-configure:
+ @cd ${WRKSRC}; ${SETENV} ${CONFIGURE_ENV} ${PERL5} Makefile.PL
+
+.include <bsd.port.mk>