aboutsummaryrefslogtreecommitdiffstats
path: root/www/p5-Apache-Archive/Makefile
diff options
context:
space:
mode:
authorwill <will@FreeBSD.org>2001-01-04 07:18:19 +0800
committerwill <will@FreeBSD.org>2001-01-04 07:18:19 +0800
commit5bd4b6792245f99493ee86dbb36a82ade07f7b3f (patch)
tree95bf8e64f3a8bc86368d01b7e0a4b7ced297cef6 /www/p5-Apache-Archive/Makefile
parent0e85fe1389c51b001a452a0fc18fba0088237f21 (diff)
downloadfreebsd-ports-gnome-5bd4b6792245f99493ee86dbb36a82ade07f7b3f.tar.gz
freebsd-ports-gnome-5bd4b6792245f99493ee86dbb36a82ade07f7b3f.tar.zst
freebsd-ports-gnome-5bd4b6792245f99493ee86dbb36a82ade07f7b3f.zip
Add p5-Apache-Archive 0.1, perl module that creates a menu to allow perusal
of tarball contents.
Diffstat (limited to 'www/p5-Apache-Archive/Makefile')
-rw-r--r--www/p5-Apache-Archive/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/www/p5-Apache-Archive/Makefile b/www/p5-Apache-Archive/Makefile
new file mode 100644
index 000000000000..678ee4e562aa
--- /dev/null
+++ b/www/p5-Apache-Archive/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: Apache::Archive
+# Date created: 04 Nov 2000
+# Whom: will
+#
+# $FreeBSD$
+#
+
+PORTNAME= Apache-Archive
+PORTVERSION= 0.1
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Apache
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= ports@FreeBSD.org
+
+BUILD_DEPENDS= ${SITE_PERL}/Archive/Tar.pm:${PORTSDIR}/archivers/p5-Archive-Tar
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+SITE_PERL= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}
+USE_PERL5= yes
+PERL_CONFIGURE= yes
+
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= Apache::Archive.3
+
+.include <bsd.port.mk>