aboutsummaryrefslogtreecommitdiffstats
path: root/www/p5-Apache-AuthTicket
diff options
context:
space:
mode:
authorpgollucci <pgollucci@FreeBSD.org>2010-05-05 11:24:01 +0800
committerpgollucci <pgollucci@FreeBSD.org>2010-05-05 11:24:01 +0800
commit641bf6a2e0fb99e1a5726efe42d099664eab2532 (patch)
tree1c62a5e14533a9c5bb4b72631f3a70a7535339dc /www/p5-Apache-AuthTicket
parent22d8165bcbf4829c24527012a3fe36ec4fa5e407 (diff)
downloadfreebsd-ports-gnome-641bf6a2e0fb99e1a5726efe42d099664eab2532.tar.gz
freebsd-ports-gnome-641bf6a2e0fb99e1a5726efe42d099664eab2532.tar.zst
freebsd-ports-gnome-641bf6a2e0fb99e1a5726efe42d099664eab2532.zip
- Unbreak, port depends on both mod_perl and Apache-Test
With Hat: perl@ Reported by: pointyhat duds file
Diffstat (limited to 'www/p5-Apache-AuthTicket')
-rw-r--r--www/p5-Apache-AuthTicket/Makefile18
1 files changed, 14 insertions, 4 deletions
diff --git a/www/p5-Apache-AuthTicket/Makefile b/www/p5-Apache-AuthTicket/Makefile
index dff2e93e9a4b..52b6fec319a2 100644
--- a/www/p5-Apache-AuthTicket/Makefile
+++ b/www/p5-Apache-AuthTicket/Makefile
@@ -16,13 +16,23 @@ COMMENT= Perl modules that implement a cookie-based authentication system
RUN_DEPENDS= ${SITE_PERL}/Apache/AuthCookie.pm:${PORTSDIR}/www/p5-Apache-AuthCookie \
${SITE_PERL}/SQL/Abstract.pm:${PORTSDIR}/databases/p5-SQL-Abstract \
- ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
+ ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI \
+ ${SITE_PERL}/${PERL_ARCH}/Apache/Test.pm:${PORTSDIR}/www/p5-Apache-Test
BUILD_DEPENDS= ${RUN_DEPENDS}
-BROKEN= does not build
-
PERL_CONFIGURE= yes
MAN3= Apache::AuthTicket.3 Apache2::AuthTicket.3
-.include <bsd.port.mk>
+USE_APACHE= 1.3+
+.include <bsd.port.pre.mk>
+
+.if ${APACHE_VERSION} > 20
+RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/mod_perl2.pm:${PORTSDIR}/www/mod_perl2
+BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/mod_perl2.pm:${PORTSDIR}/www/mod_perl2
+.else
+RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/mod_perl.pm:${PORTSDIR}/www/mod_perl
+BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/mod_perl.pm:${PORTSDIR}/www/mod_perl
+.endif
+
+.include <bsd.port.post.mk>