aboutsummaryrefslogtreecommitdiffstats
path: root/www/p5-Apache-DBI
diff options
context:
space:
mode:
authorpgollucci <pgollucci@FreeBSD.org>2008-08-29 02:30:27 +0800
committerpgollucci <pgollucci@FreeBSD.org>2008-08-29 02:30:27 +0800
commit223c6b0542db41e3ad30f04d43becea74cf5739e (patch)
treeb1e1ec8a41b8e3619cd9f29bdda6cec5d2743441 /www/p5-Apache-DBI
parent1aa0e9cbd4b0eb00cf87964a56b4a00e2e0888d3 (diff)
downloadfreebsd-ports-gnome-223c6b0542db41e3ad30f04d43becea74cf5739e.tar.gz
freebsd-ports-gnome-223c6b0542db41e3ad30f04d43becea74cf5739e.tar.zst
freebsd-ports-gnome-223c6b0542db41e3ad30f04d43becea74cf5739e.zip
DEPENDS_ARGS doesn't work with packages and even if it did
WITH_MODPERL2 / WITH_MODPERL is not handled correctly so the depency list for upcomming www/rt38 is way off. As such, we've split this port into MASTER (www/p5-Apache-DBI) and SLAVES (www/p5-Apache-DBI-mp1) and (www/p5-Apache-DBI-mp2). While here, cleanup the MASTER port a little - spell out the RUN_DEPENDS - remove USE_APACHE and let www/mod_perl* deal with it - pull the plist into Makefile Bump PORTREVISION Discussed with: pav on #bsdports Approved by: gabor (mentor)
Diffstat (limited to 'www/p5-Apache-DBI')
-rw-r--r--www/p5-Apache-DBI/Makefile20
-rw-r--r--www/p5-Apache-DBI/pkg-plist5
2 files changed, 15 insertions, 10 deletions
diff --git a/www/p5-Apache-DBI/Makefile b/www/p5-Apache-DBI/Makefile
index 7cde18bc6e95..99160492ef70 100644
--- a/www/p5-Apache-DBI/Makefile
+++ b/www/p5-Apache-DBI/Makefile
@@ -5,14 +5,17 @@
# $FreeBSD$
#
-PORTNAME= Apache-DBI
+PORTNAME?= Apache-DBI
PORTVERSION= 1.06
+PORTREVISION?= 1
CATEGORIES= www databases perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
MAINTAINER= pgollucci@FreeBSD.org
-COMMENT= DBI persistent connection, authentication and authorization
+COMMENT?= DBI persistent connection, authentication and authorization
+
+SLAVEDIRS= www/p5-Apache-DBI-mp1 www/p5-Apache-DBI-mp2
BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
@@ -22,14 +25,21 @@ MAN3= Apache::DBI.3 Apache::AuthDBI.3
PERL_CONFIGURE= yes
.if defined(WITH_MODPERL2)
-USE_APACHE= 2.0+
RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/mod_perl2.pm:${PORTSDIR}/www/mod_perl2
-BUILD_DEPENDS+= ${RUN_DEPENDS}
+BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/mod_perl2.pm:${PORTSDIR}/www/mod_perl2
.else
RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/mod_perl.pm:${PORTSDIR}/www/mod_perl
-BUILD_DEPENDS+= ${RUN_DEPENDS}
+BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/mod_perl.pm:${PORTSDIR}/www/mod_perl
.endif
+PLIST_FILES= %%SITE_PERL%%/Apache/DBI.pm \
+ %%SITE_PERL%%/Apache/AuthDBI.pm \
+ %%SITE_PERL%%/%%PERL_ARCH%%/auto/Apache/DBI/.packlist
+
+PLIST_DIRS= %%SITE_PERL%%/%%PERL_ARCH%%/auto/Apache/DBI \
+ %%SITE_PERL%%/%%PERL_ARCH%%/auto/Apache \
+ %%SITE_PERL%%/Apache
+
.include <bsd.port.pre.mk>
.if ${PERL_LEVEL} < 500800
diff --git a/www/p5-Apache-DBI/pkg-plist b/www/p5-Apache-DBI/pkg-plist
deleted file mode 100644
index 814e8dc2141f..000000000000
--- a/www/p5-Apache-DBI/pkg-plist
+++ /dev/null
@@ -1,5 +0,0 @@
-%%SITE_PERL%%/Apache/DBI.pm
-%%SITE_PERL%%/Apache/AuthDBI.pm
-%%SITE_PERL%%/%%PERL_ARCH%%/auto/Apache/DBI/.packlist
-@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Apache/DBI
-@dirrmtry %%SITE_PERL%%/Apache