aboutsummaryrefslogtreecommitdiffstats
path: root/www/p5-Apache-GopherHandler
diff options
context:
space:
mode:
authorflz <flz@FreeBSD.org>2005-03-09 20:28:36 +0800
committerflz <flz@FreeBSD.org>2005-03-09 20:28:36 +0800
commit857a2136b927ba6c545ca9dd4fa0fea2b08607e9 (patch)
tree1d901989fa88270f8be53c07b78d7545b6516abc /www/p5-Apache-GopherHandler
parenta12fe93f02fabd1857d8ea99df38c1f3652b20b4 (diff)
downloadfreebsd-ports-gnome-857a2136b927ba6c545ca9dd4fa0fea2b08607e9.tar.gz
freebsd-ports-gnome-857a2136b927ba6c545ca9dd4fa0fea2b08607e9.tar.zst
freebsd-ports-gnome-857a2136b927ba6c545ca9dd4fa0fea2b08607e9.zip
- Add p5-Apache-GopherHandler 0.1, a gopher protocol implementation for Apache2.
PR: ports/66506 Submitted by: Toni Viemero <toni.viemero@iki.fi> Approved by: pav (mentor)
Diffstat (limited to 'www/p5-Apache-GopherHandler')
-rw-r--r--www/p5-Apache-GopherHandler/Makefile33
-rw-r--r--www/p5-Apache-GopherHandler/distinfo2
-rw-r--r--www/p5-Apache-GopherHandler/pkg-descr3
-rw-r--r--www/p5-Apache-GopherHandler/pkg-plist4
4 files changed, 42 insertions, 0 deletions
diff --git a/www/p5-Apache-GopherHandler/Makefile b/www/p5-Apache-GopherHandler/Makefile
new file mode 100644
index 000000000000..ec8a9f270642
--- /dev/null
+++ b/www/p5-Apache-GopherHandler/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: p5-Apache-GopherHandler
+# Date created: 2004-03-31
+# Whom: Toni Viemerö <toni.viemero@iki.fi>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Apache-GopherHandler
+PORTVERSION= 0.1
+CATEGORIES= www net perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Apache
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= toni.viemero@iki.fi
+COMMENT= Gopher protocol implementation for Apache2
+
+RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Apache2/mod_perl.pm:${PORTSDIR}/www/mod_perl2 \
+ ${SITE_PERL}/Gopher/Server/ParseRequest.pm:${PORTSDIR}/net/p5-Gopher-Server
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_MODBUILD= yes
+
+MAN3= Apache::GopherHandler.3 \
+ Apache::GopherHandler::TiedSocket.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= "Needs perl 5.6.0 or higher, install lang/perl5 or lang/perl5.8 and try again"
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/www/p5-Apache-GopherHandler/distinfo b/www/p5-Apache-GopherHandler/distinfo
new file mode 100644
index 000000000000..424039e19cf1
--- /dev/null
+++ b/www/p5-Apache-GopherHandler/distinfo
@@ -0,0 +1,2 @@
+MD5 (Apache-GopherHandler-0.1.tar.gz) = dd8cfae564a501669027d366cfc0897e
+SIZE (Apache-GopherHandler-0.1.tar.gz) = 9845
diff --git a/www/p5-Apache-GopherHandler/pkg-descr b/www/p5-Apache-GopherHandler/pkg-descr
new file mode 100644
index 000000000000..3c0dd0b881c8
--- /dev/null
+++ b/www/p5-Apache-GopherHandler/pkg-descr
@@ -0,0 +1,3 @@
+Apache::GopherHandler - Gopher protocol implementation for Apache2
+
+WWW: http://search.cpan.org/dist/Apache-GopherHandler/
diff --git a/www/p5-Apache-GopherHandler/pkg-plist b/www/p5-Apache-GopherHandler/pkg-plist
new file mode 100644
index 000000000000..ee1491ab97eb
--- /dev/null
+++ b/www/p5-Apache-GopherHandler/pkg-plist
@@ -0,0 +1,4 @@
+%%SITE_PERL%%/Apache/GopherHandler.pm
+%%SITE_PERL%%/Apache/GopherHandler/TiedSocket.pm
+@dirrm %%SITE_PERL%%/Apache/GopherHandler
+@unexec rmdir %D/%%SITE_PERL%%/Apache 2> /dev/null || true