aboutsummaryrefslogtreecommitdiffstats
path: root/www/p5-Apache2-SiteControl
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2011-06-25 18:11:01 +0800
committermiwi <miwi@FreeBSD.org>2011-06-25 18:11:01 +0800
commit1f5ac5aa6d2071ca1cf379f98e16bf3923d349af (patch)
tree68612ee648e0327a06231d403f6b39eaeea5d0f4 /www/p5-Apache2-SiteControl
parent0ef66afe8c65325b56d8324df57e14addb12ad87 (diff)
downloadfreebsd-ports-gnome-1f5ac5aa6d2071ca1cf379f98e16bf3923d349af.tar.gz
freebsd-ports-gnome-1f5ac5aa6d2071ca1cf379f98e16bf3923d349af.tar.zst
freebsd-ports-gnome-1f5ac5aa6d2071ca1cf379f98e16bf3923d349af.zip
Apache2::SiteControl is a set of perl object-oriented classes that implement
a fine-grained security control system for a web-based application. The intent is to provide a clear, easy-to-integrate system that does not require the policies to be written into your application components. It attempts to separate the concerns of how to show and manipulate data from the concerns of who is allowed to view and manipulate data and why. WWW: http://search.cpan.org/dist/Apache2-SiteControl/ PR: ports/158001 Submitted by: Nick Hilliard <nick at foobar.org
Diffstat (limited to 'www/p5-Apache2-SiteControl')
-rw-r--r--www/p5-Apache2-SiteControl/Makefile26
-rw-r--r--www/p5-Apache2-SiteControl/distinfo2
-rw-r--r--www/p5-Apache2-SiteControl/pkg-descr8
-rw-r--r--www/p5-Apache2-SiteControl/pkg-plist13
4 files changed, 49 insertions, 0 deletions
diff --git a/www/p5-Apache2-SiteControl/Makefile b/www/p5-Apache2-SiteControl/Makefile
new file mode 100644
index 000000000000..c5faff47c82d
--- /dev/null
+++ b/www/p5-Apache2-SiteControl/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: p5-Apache2-SiteControl
+# Date created: 18 June 2011
+# Whom: Nick Hilliard <nick@foobar.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= Apache2-SiteControl
+PORTVERSION= 1.05
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= nick@foobar.org
+COMMENT= Perl web site authentication/authorization system
+
+PERL_CONFIGURE= yes
+
+MAN3= Apache2::SiteControl::User.3 Apache2::SiteControl::Rule.3 \
+ Apache2::SiteControl::ManagerFactory.3 \
+ Apache2::SiteControl::GrantAllRule.3 Apache2::SiteControl.3 \
+ Apache2::SiteControl::UserFactory.3 \
+ Apache2::SiteControl::Radius.3 \
+ Apache2::SiteControl::PermissionManager.3
+
+.include <bsd.port.mk>
diff --git a/www/p5-Apache2-SiteControl/distinfo b/www/p5-Apache2-SiteControl/distinfo
new file mode 100644
index 000000000000..b517db938c80
--- /dev/null
+++ b/www/p5-Apache2-SiteControl/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Apache2-SiteControl-1.05.tar.gz) = 4e9ee37e1a8e3d5df4587e9085621c2f6d253035c2cd2749cb16f6d8e7dbcc4c
+SIZE (Apache2-SiteControl-1.05.tar.gz) = 19669
diff --git a/www/p5-Apache2-SiteControl/pkg-descr b/www/p5-Apache2-SiteControl/pkg-descr
new file mode 100644
index 000000000000..331f1b4b790e
--- /dev/null
+++ b/www/p5-Apache2-SiteControl/pkg-descr
@@ -0,0 +1,8 @@
+Apache2::SiteControl is a set of perl object-oriented classes that implement
+a fine-grained security control system for a web-based application. The
+intent is to provide a clear, easy-to-integrate system that does not require
+the policies to be written into your application components. It attempts to
+separate the concerns of how to show and manipulate data from the concerns
+of who is allowed to view and manipulate data and why.
+
+WWW: http://search.cpan.org/dist/Apache2-SiteControl/
diff --git a/www/p5-Apache2-SiteControl/pkg-plist b/www/p5-Apache2-SiteControl/pkg-plist
new file mode 100644
index 000000000000..22c5b90bb4a3
--- /dev/null
+++ b/www/p5-Apache2-SiteControl/pkg-plist
@@ -0,0 +1,13 @@
+%%SITE_PERL%%/Apache2/SiteControl.pm
+%%SITE_PERL%%/Apache2/SiteControl/GrantAllRule.pm
+%%SITE_PERL%%/Apache2/SiteControl/ManagerFactory.pm
+%%SITE_PERL%%/Apache2/SiteControl/PermissionManager.pm
+%%SITE_PERL%%/Apache2/SiteControl/Radius.pm
+%%SITE_PERL%%/Apache2/SiteControl/Rule.pm
+%%SITE_PERL%%/Apache2/SiteControl/User.pm
+%%SITE_PERL%%/Apache2/SiteControl/UserFactory.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Apache2/SiteControl/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Apache2/SiteControl
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Apache2
+@dirrmtry %%SITE_PERL%%/Apache2/SiteControl
+@dirrmtry %%SITE_PERL%%/Apache2