aboutsummaryrefslogtreecommitdiffstats
path: root/www/p5-Ark
diff options
context:
space:
mode:
authorkuriyama <kuriyama@FreeBSD.org>2009-06-09 12:54:39 +0800
committerkuriyama <kuriyama@FreeBSD.org>2009-06-09 12:54:39 +0800
commit81a9cf867a1f958fde308d8da7bc8ac2a121751d (patch)
treefe2d66574cd4699411fec39b313d6a535ba348f3 /www/p5-Ark
parent37015e384482032809564702a25b302393625ebe (diff)
downloadfreebsd-ports-gnome-81a9cf867a1f958fde308d8da7bc8ac2a121751d.tar.gz
freebsd-ports-gnome-81a9cf867a1f958fde308d8da7bc8ac2a121751d.tar.zst
freebsd-ports-gnome-81a9cf867a1f958fde308d8da7bc8ac2a121751d.zip
Ark is a web application framework. It's heavily inspired by Catalyst
Framework. Most different point between Ark and Catalyst is that Ark has CGI specific mode which can run applications less latency under CGI environment. WWW: http://opensource.kayac.com/en/projects/ark/
Diffstat (limited to 'www/p5-Ark')
-rw-r--r--www/p5-Ark/Makefile50
-rw-r--r--www/p5-Ark/distinfo3
-rw-r--r--www/p5-Ark/files/patch-AutoInstall.pm15
-rw-r--r--www/p5-Ark/pkg-descr8
-rw-r--r--www/p5-Ark/pkg-plist69
5 files changed, 145 insertions, 0 deletions
diff --git a/www/p5-Ark/Makefile b/www/p5-Ark/Makefile
new file mode 100644
index 000000000000..cee22d2ee115
--- /dev/null
+++ b/www/p5-Ark/Makefile
@@ -0,0 +1,50 @@
+# New ports collection makefile for: p5-Ark
+# Date created: 06 Jun 2009
+# Whom: Jun Kuriyama <kuriyama@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Ark
+PORTVERSION= 0.1.r1
+CATEGORIES= www perl5
+MASTER_SITES= http://cloud.github.com/downloads/typester/ark-perl/ \
+ ${MASTER_SITE_LOCAL}
+MASTER_SITE_SUBDIR= kuriyama
+PKGNAMEPREFIX= p5-
+DISTNAME= Ark-0.001000_001
+
+MAINTAINER= kuriyama@FreeBSD.org
+COMMENT= Perl web application framework
+
+BUILD_DEPENDS= ${RUN_DEPENDS}
+RUN_DEPENDS= \
+ p5-Class-Data-Inheritable>0:${PORTSDIR}/devel/p5-Class-Data-Inheritable \
+ p5-Class-Method-Modifiers-Fast>0:${PORTSDIR}/devel/p5-Class-Method-Modifiers-Fast \
+ p5-Data-UUID>0:${PORTSDIR}/devel/p5-Data-UUID \
+ p5-Data-Util>0:${PORTSDIR}/devel/p5-Data-Util \
+ p5-Devel-StackTrace>0:${PORTSDIR}/devel/p5-Devel-StackTrace \
+ p5-Digest-SHA1>0:${PORTSDIR}/security/p5-Digest-SHA1 \
+ p5-FindBin-libs>0:${PORTSDIR}/devel/p5-FindBin-libs \
+ p5-HTML-Parser>0:${PORTSDIR}/www/p5-HTML-Parser \
+ p5-HTTP-Engine>=0.1.8:${PORTSDIR}/www/p5-HTTP-Engine \
+ p5-HTTP-Engine-Middleware>=0.13:${PORTSDIR}/www/p5-HTTP-Engine-Middleware \
+ p5-MIME-Types>0:${PORTSDIR}/mail/p5-MIME-Types \
+ p5-Module-Pluggable>0:${PORTSDIR}/devel/p5-Module-Pluggable \
+ p5-Module-Setup>0:${PORTSDIR}/devel/p5-Module-Setup \
+ p5-Mouse>=0.21:${PORTSDIR}/devel/p5-Mouse \
+ p5-MouseX-Types-Path-Class>0:${PORTSDIR}/devel/p5-MouseX-Types-Path-Class \
+ p5-Path-Class>=0.16:${PORTSDIR}/devel/p5-Path-Class \
+ p5-Text-SimpleTable>=0.05:${PORTSDIR}/textproc/p5-Text-SimpleTable \
+ p5-URI>0:${PORTSDIR}/net/p5-URI
+
+PERL_CONFIGURE= 5.8.1+
+
+MAN3= Ark::Command.3 \
+ Ark::Command::Controller.3 \
+ Ark::Command::Model.3 \
+ Ark::Command::Newapp.3 \
+ Ark::Command::Server.3 \
+ Ark::Command::View.3
+
+.include <bsd.port.mk>
diff --git a/www/p5-Ark/distinfo b/www/p5-Ark/distinfo
new file mode 100644
index 000000000000..3bf4bbb8f30f
--- /dev/null
+++ b/www/p5-Ark/distinfo
@@ -0,0 +1,3 @@
+MD5 (Ark-0.001000_001.tar.gz) = fbe42ffc0807fe0a83b6e88e8eb7766b
+SHA256 (Ark-0.001000_001.tar.gz) = 6720dd0a375039c337805e434ca865e12fac123d0f030307bb159aae2c3d5206
+SIZE (Ark-0.001000_001.tar.gz) = 70981
diff --git a/www/p5-Ark/files/patch-AutoInstall.pm b/www/p5-Ark/files/patch-AutoInstall.pm
new file mode 100644
index 000000000000..c033b1970abb
--- /dev/null
+++ b/www/p5-Ark/files/patch-AutoInstall.pm
@@ -0,0 +1,15 @@
+--- inc/Module/AutoInstall.pm.orig 2009-06-01 09:53:37.000000000 +0900
++++ inc/Module/AutoInstall.pm 2009-06-07 13:45:32.000000000 +0900
+@@ -637,10 +637,10 @@
+ require CPAN;
+ if ( $CPAN::HandleConfig::VERSION ) {
+ # Newer versions of CPAN have a HandleConfig module
+- CPAN::HandleConfig->load;
++# CPAN::HandleConfig->load;
+ } else {
+ # Older versions had the load method in Config directly
+- CPAN::Config->load;
++# CPAN::Config->load;
+ }
+ }
+
diff --git a/www/p5-Ark/pkg-descr b/www/p5-Ark/pkg-descr
new file mode 100644
index 000000000000..69243d354161
--- /dev/null
+++ b/www/p5-Ark/pkg-descr
@@ -0,0 +1,8 @@
+Ark is a web application framework. It's heavily inspired by Catalyst
+Framework.
+
+Most different point between Ark and Catalyst is that Ark has CGI
+specific mode which can run applications less latency under CGI
+environment.
+
+WWW: http://opensource.kayac.com/en/projects/ark/
diff --git a/www/p5-Ark/pkg-plist b/www/p5-Ark/pkg-plist
new file mode 100644
index 000000000000..451817be9c74
--- /dev/null
+++ b/www/p5-Ark/pkg-plist
@@ -0,0 +1,69 @@
+bin/ark.pl
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Ark/.packlist
+%%SITE_PERL%%/Ark.pm
+%%SITE_PERL%%/Ark/Action.pm
+%%SITE_PERL%%/Ark/ActionChain.pm
+%%SITE_PERL%%/Ark/ActionContainer.pm
+%%SITE_PERL%%/Ark/Command.pm
+%%SITE_PERL%%/Ark/Command/Controller.pm
+%%SITE_PERL%%/Ark/Command/Flavor/Controller.pm
+%%SITE_PERL%%/Ark/Command/Flavor/Model.pm
+%%SITE_PERL%%/Ark/Command/Flavor/Newapp.pm
+%%SITE_PERL%%/Ark/Command/Flavor/View.pm
+%%SITE_PERL%%/Ark/Command/Interface.pm
+%%SITE_PERL%%/Ark/Command/Interface/ModuleSetup.pm
+%%SITE_PERL%%/Ark/Command/Model.pm
+%%SITE_PERL%%/Ark/Command/Newapp.pm
+%%SITE_PERL%%/Ark/Command/Plugin.pm
+%%SITE_PERL%%/Ark/Command/Server.pm
+%%SITE_PERL%%/Ark/Command/View.pm
+%%SITE_PERL%%/Ark/Component.pm
+%%SITE_PERL%%/Ark/Context.pm
+%%SITE_PERL%%/Ark/Context/Debug.pm
+%%SITE_PERL%%/Ark/Controller.pm
+%%SITE_PERL%%/Ark/Core.pm
+%%SITE_PERL%%/Ark/DispatchType/Chained.pm
+%%SITE_PERL%%/Ark/DispatchType/Path.pm
+%%SITE_PERL%%/Ark/DispatchType/Regex.pm
+%%SITE_PERL%%/Ark/Logger.pm
+%%SITE_PERL%%/Ark/Model.pm
+%%SITE_PERL%%/Ark/Model/Adaptor.pm
+%%SITE_PERL%%/Ark/Plugin.pm
+%%SITE_PERL%%/Ark/Plugin/Authentication.pm
+%%SITE_PERL%%/Ark/Plugin/Authentication/Backend.pm
+%%SITE_PERL%%/Ark/Plugin/Authentication/Credential/OpenID.pm
+%%SITE_PERL%%/Ark/Plugin/Authentication/Credential/Password.pm
+%%SITE_PERL%%/Ark/Plugin/Authentication/Store/DBIx/Class.pm
+%%SITE_PERL%%/Ark/Plugin/Authentication/Store/Minimal.pm
+%%SITE_PERL%%/Ark/Plugin/Authentication/Store/Model.pm
+%%SITE_PERL%%/Ark/Plugin/Authentication/Store/Null.pm
+%%SITE_PERL%%/Ark/Plugin/Authentication/User.pm
+%%SITE_PERL%%/Ark/Plugin/Encoding/Null.pm
+%%SITE_PERL%%/Ark/Plugin/Encoding/Unicode.pm
+%%SITE_PERL%%/Ark/Plugin/Session.pm
+%%SITE_PERL%%/Ark/Plugin/Session/Backend.pm
+%%SITE_PERL%%/Ark/Plugin/Session/State/Cookie.pm
+%%SITE_PERL%%/Ark/Plugin/Session/Store/Memory.pm
+%%SITE_PERL%%/Ark/Plugin/Session/Store/Model.pm
+%%SITE_PERL%%/Ark/Request.pm
+%%SITE_PERL%%/Ark/Test.pm
+%%SITE_PERL%%/Ark/View.pm
+%%SITE_PERL%%/Ark/View/MT.pm
+@dirrm %%SITE_PERL%%/Ark/View
+@dirrm %%SITE_PERL%%/Ark/Plugin/Session/Store
+@dirrm %%SITE_PERL%%/Ark/Plugin/Session/State
+@dirrm %%SITE_PERL%%/Ark/Plugin/Session
+@dirrm %%SITE_PERL%%/Ark/Plugin/Encoding
+@dirrm %%SITE_PERL%%/Ark/Plugin/Authentication/Store/DBIx
+@dirrm %%SITE_PERL%%/Ark/Plugin/Authentication/Store
+@dirrm %%SITE_PERL%%/Ark/Plugin/Authentication/Credential
+@dirrm %%SITE_PERL%%/Ark/Plugin/Authentication
+@dirrm %%SITE_PERL%%/Ark/Plugin
+@dirrm %%SITE_PERL%%/Ark/Model
+@dirrm %%SITE_PERL%%/Ark/DispatchType
+@dirrm %%SITE_PERL%%/Ark/Context
+@dirrm %%SITE_PERL%%/Ark/Command/Interface
+@dirrm %%SITE_PERL%%/Ark/Command/Flavor
+@dirrm %%SITE_PERL%%/Ark/Command
+@dirrm %%SITE_PERL%%/Ark
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Ark