aboutsummaryrefslogtreecommitdiffstats
path: root/www/p5-AxKit-XSP-ESQL
diff options
context:
space:
mode:
authorerwin <erwin@FreeBSD.org>2003-09-16 13:43:52 +0800
committererwin <erwin@FreeBSD.org>2003-09-16 13:43:52 +0800
commit11412f5f13d0ac12046d38512b9aa92faf493592 (patch)
tree83f083cfab38622b0550914a068355cf1bea6ca8 /www/p5-AxKit-XSP-ESQL
parente3f2471f57b5539a0e72bb944aa8c1c159fb8431 (diff)
downloadfreebsd-ports-gnome-11412f5f13d0ac12046d38512b9aa92faf493592.tar.gz
freebsd-ports-gnome-11412f5f13d0ac12046d38512b9aa92faf493592.tar.zst
freebsd-ports-gnome-11412f5f13d0ac12046d38512b9aa92faf493592.zip
Conditionalise dependencies on databases/p5-DBI: for perl
5.005_03 use databases/p5-DBI-137 as newer versions do not support the old perl. Note that for some port, I merely removed the explicit dependency as they already have implicit dependencies via other ports. Approved by: portmgr (marcus)
Diffstat (limited to 'www/p5-AxKit-XSP-ESQL')
-rw-r--r--www/p5-AxKit-XSP-ESQL/Makefile13
1 files changed, 11 insertions, 2 deletions
diff --git a/www/p5-AxKit-XSP-ESQL/Makefile b/www/p5-AxKit-XSP-ESQL/Makefile
index c0835047847b..c58a3a043bb4 100644
--- a/www/p5-AxKit-XSP-ESQL/Makefile
+++ b/www/p5-AxKit-XSP-ESQL/Makefile
@@ -15,7 +15,6 @@ MAINTAINER= dom@happygiraffe.net
COMMENT= An Extended SQL taglib for AxKit eXtensible Server Pages
BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/AxKit.pm:${PORTSDIR}/www/p5-AxKit \
- ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI \
${SITE_PERL}/AxKit/XSP/Util.pm:${PORTSDIR}/www/p5-AxKit-XSP-Util
RUN_DEPENDS= ${BUILD_DEPENDS}
@@ -26,4 +25,14 @@ MAN3= AxKit::XSP::ESQL.3
PERL_CONFIGURE= yes
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI-137
+RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI-137
+.else
+BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
+RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
+.endif
+
+.include <bsd.port.post.mk>