aboutsummaryrefslogtreecommitdiffstats
path: root/www/p5-Bundle-Sledge
diff options
context:
space:
mode:
authorkrion <krion@FreeBSD.org>2005-08-05 19:38:14 +0800
committerkrion <krion@FreeBSD.org>2005-08-05 19:38:14 +0800
commitc1825cb061d7ddb4adebe9d8efbbc2ff1ca47597 (patch)
tree80a6f2199e90b6aabb3f3e612189221e2632ab94 /www/p5-Bundle-Sledge
parent872a3357963f813ca6aa0b8161ccff6593fca2da (diff)
downloadfreebsd-ports-gnome-c1825cb061d7ddb4adebe9d8efbbc2ff1ca47597.tar.gz
freebsd-ports-gnome-c1825cb061d7ddb4adebe9d8efbbc2ff1ca47597.tar.zst
freebsd-ports-gnome-c1825cb061d7ddb4adebe9d8efbbc2ff1ca47597.zip
Fix package build.
Approved by: portmgr (implicit)
Diffstat (limited to 'www/p5-Bundle-Sledge')
-rw-r--r--www/p5-Bundle-Sledge/Makefile14
1 files changed, 11 insertions, 3 deletions
diff --git a/www/p5-Bundle-Sledge/Makefile b/www/p5-Bundle-Sledge/Makefile
index b7b170895ca1..63ad7dcc4fd6 100644
--- a/www/p5-Bundle-Sledge/Makefile
+++ b/www/p5-Bundle-Sledge/Makefile
@@ -7,7 +7,7 @@
PORTNAME= Bundle-Sledge
PORTVERSION= 0.03
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= Bundle
@@ -36,7 +36,7 @@ PM_DEPENDS+= ${SITE_PERL}/HTML/FillInForm.pm:${PORTSDIR}/www/p5-HTML-FillInForm
PM_DEPENDS+= ${SITE_PERL}/HTML/Template.pm:${PORTSDIR}/www/p5-HTML-Template
PM_DEPENDS+= ${SITE_PERL}/HTML/StickyQuery.pm:${PORTSDIR}/www/p5-HTML-StickyQuery
PM_DEPENDS+= ${SITE_PERL}/IO/Stringy.pm:${PORTSDIR}/devel/p5-IO-stringy
-PM_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Jcode.pm:${PORTSDIR}/japanese/p5-Jcode
+PM_DEPENDS+= ${JCODE}:${PORTSDIR}/japanese/p5-Jcode
PM_DEPENDS+= ${SITE_PERL}/Test/Simple.pm:${PORTSDIR}/devel/p5-Test-Simple
PM_DEPENDS+= ${SITE_PERL}/Test/Harness.pm:${PORTSDIR}/devel/p5-Test-Harness
PM_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Time/HiRes.pm:${PORTSDIR}/devel/p5-Time-HiRes
@@ -51,4 +51,12 @@ PERL_CONFIGURE= yes
MAN3= Bundle::Sledge.3
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500801
+JCODE= ${SITE_PERL}/${PERL_ARCH}/Jcode.pm
+.else
+JCODE= ${SITE_PERL}/Jcode.pm
+.endif
+
+.include <bsd.port.post.mk>