aboutsummaryrefslogtreecommitdiffstats
path: root/www/p5-CGI-Cache/Makefile
diff options
context:
space:
mode:
authorwill <will@FreeBSD.org>2001-01-04 07:24:48 +0800
committerwill <will@FreeBSD.org>2001-01-04 07:24:48 +0800
commitdfb56261e8fc9ccea235bef29255aa520edd201c (patch)
treec5692e44fb0b16b596e5a9af8c2ea3d113d3ee78 /www/p5-CGI-Cache/Makefile
parent4e580df6402ca7e30003ae60c4cc09c119dd0400 (diff)
downloadfreebsd-ports-gnome-dfb56261e8fc9ccea235bef29255aa520edd201c.tar.gz
freebsd-ports-gnome-dfb56261e8fc9ccea235bef29255aa520edd201c.tar.zst
freebsd-ports-gnome-dfb56261e8fc9ccea235bef29255aa520edd201c.zip
Add p5-CGI-Cache 1.02, perl extension to cache output of time-intensive CGI
scripts.
Diffstat (limited to 'www/p5-CGI-Cache/Makefile')
-rw-r--r--www/p5-CGI-Cache/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/www/p5-CGI-Cache/Makefile b/www/p5-CGI-Cache/Makefile
new file mode 100644
index 000000000000..99fb2f19ad47
--- /dev/null
+++ b/www/p5-CGI-Cache/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: CGI-Cache
+# Date created: Mon Jan 1 11:26:17 2001
+# Whom: will
+#
+# $FreeBSD$
+#
+
+PORTNAME= CGI-Cache
+PORTVERSION= 1.02
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= CGI
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= ports@FreeBSD.org
+
+BUILD_DEPENDS= ${SITE_PERL}/File/Cache.pm:${PORTSDIR}/devel/p5-File-Cache
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+SITE_PERL= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}
+USE_PERL5= yes
+PERL_CONFIGURE= yes
+
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= CGI::Cache.3
+
+.include <bsd.port.mk>