aboutsummaryrefslogtreecommitdiffstats
path: root/www/p5-CGI-Session
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2003-04-13 20:28:23 +0800
committeredwin <edwin@FreeBSD.org>2003-04-13 20:28:23 +0800
commit48a241b76eec811abc57f7b6cb09e19340fc862c (patch)
treede759967af3bbf8379751e686f131f856622d20e /www/p5-CGI-Session
parent1f26dd33c2e40b49947e66b88565d60ed8c823d6 (diff)
downloadfreebsd-ports-gnome-48a241b76eec811abc57f7b6cb09e19340fc862c.tar.gz
freebsd-ports-gnome-48a241b76eec811abc57f7b6cb09e19340fc862c.tar.zst
freebsd-ports-gnome-48a241b76eec811abc57f7b6cb09e19340fc862c.zip
Conditionalize dependencies for moudules included in perl 5.8
Make dependencies on modules included in the perl 5.8 distribution conditional on the perl version installed. While I'm here, remove SITE_PERL and MAN(3)PREFIX. 17 + 29 + 234 = 280 PRs. It's about time he starts doing the work himself! PR: ports/50588 Submitted by: Erwin Lansing <erwin@lansing.dk>
Diffstat (limited to 'www/p5-CGI-Session')
-rw-r--r--www/p5-CGI-Session/Makefile12
1 files changed, 8 insertions, 4 deletions
diff --git a/www/p5-CGI-Session/Makefile b/www/p5-CGI-Session/Makefile
index 0aeb2962ccb4..a6555ac0fa46 100644
--- a/www/p5-CGI-Session/Makefile
+++ b/www/p5-CGI-Session/Makefile
@@ -15,9 +15,6 @@ PKGNAMEPREFIX= p5-
MAINTAINER= erwin@lansing.dk
COMMENT= Perl extension for persistent session management
-BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5
-RUN_DEPENDS= ${BUILD_DEPENDS}
-
PERL_CONFIGURE= yes
MAN3= CGI::Session::DB_File.3 \
@@ -35,4 +32,11 @@ MAN3= CGI::Session::DB_File.3 \
CGI::Session::CookBook.3 \
CGI::Session::Serialize::Storable.3
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5
+RUN_DEPENDS= ${BUILD_DEPENDS}
+.endif
+
+.include <bsd.port.post.mk>