aboutsummaryrefslogtreecommitdiffstats
path: root/www/p5-CGI
diff options
context:
space:
mode:
authorjfitz <jfitz@FreeBSD.org>1997-06-25 02:43:34 +0800
committerjfitz <jfitz@FreeBSD.org>1997-06-25 02:43:34 +0800
commit5cafe13f0d4bb398c9d0d7257a5690698385d9eb (patch)
treedaf5bfe3bf7b554d2376a303a250d14f858a016a /www/p5-CGI
parent3351443cc3e46b27c564a255306d3930d2368653 (diff)
downloadfreebsd-ports-gnome-5cafe13f0d4bb398c9d0d7257a5690698385d9eb.tar.gz
freebsd-ports-gnome-5cafe13f0d4bb398c9d0d7257a5690698385d9eb.tar.zst
freebsd-ports-gnome-5cafe13f0d4bb398c9d0d7257a5690698385d9eb.zip
Make all p5- ports use USE_PERL instead of explicitly stating the version number in each Makefile
In-Conjunction-With: Satoshi's patch to bsd.port.mk (note: unlike the last change in perl5 versions, I have only upgraded p5-* ports, not other ports that rely upon perl5.)
Diffstat (limited to 'www/p5-CGI')
-rw-r--r--www/p5-CGI/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/www/p5-CGI/Makefile b/www/p5-CGI/Makefile
index d1bf1b8b44f1..25c9e85d9262 100644
--- a/www/p5-CGI/Makefile
+++ b/www/p5-CGI/Makefile
@@ -3,7 +3,7 @@
# Date created: September 30th 1996
# Whom: James FitzGibbon <jfitz@FreeBSD.org>
#
-# $Id: Makefile,v 1.5 1997/04/20 21:26:43 jfitz Exp $
+# $Id: Makefile,v 1.6 1997/05/24 13:17:15 jfitz Exp $
#
DISTNAME= CGI-modules-2.76
@@ -14,9 +14,9 @@ MASTER_SITE_SUBDIR= CGI
MAINTAINER= jfitz@FreeBSD.ORG
-BUILD_DEPENDS= perl5.004:${PORTSDIR}/lang/perl5 \
- ${PREFIX}/lib/perl5/site_perl/URI/Escape.pm:${PORTSDIR}/www/p5-libwww
-RUN_DEPENDS= perl5.004:${PORTSDIR}/lang/perl5
+BUILD_DEPENDS= ${PREFIX}/lib/perl5/site_perl/URI/Escape.pm:${PORTSDIR}/www/p5-libwww
+
+USE_PERL5= YES
MAN3= CGI::Base.3 CGI::BasePlus.3 CGI::Carp.3 CGI::Form.3 \
CGI::MiniSvr.3 CGI::Request.3