aboutsummaryrefslogtreecommitdiffstats
path: root/www/p5-Catalyst-Plugin-Authentication-Store-DBIx-Class
diff options
context:
space:
mode:
authorlbr <lbr@FreeBSD.org>2007-07-30 20:45:19 +0800
committerlbr <lbr@FreeBSD.org>2007-07-30 20:45:19 +0800
commitfaf2fd3c10b101ed87bfa008589f6addba5f0314 (patch)
tree4d5e8fef032d95bf06f9d276da3847578be041be /www/p5-Catalyst-Plugin-Authentication-Store-DBIx-Class
parentc02234f5923f1f3befff0d19e2e96dd3b88f9991 (diff)
downloadfreebsd-ports-gnome-faf2fd3c10b101ed87bfa008589f6addba5f0314.tar.gz
freebsd-ports-gnome-faf2fd3c10b101ed87bfa008589f6addba5f0314.tar.zst
freebsd-ports-gnome-faf2fd3c10b101ed87bfa008589f6addba5f0314.zip
The Catalyst::Plugin::Authentication::Store::DBIx::Class class provides access
to authentication information stored in a database via DBIx::Class.
Diffstat (limited to 'www/p5-Catalyst-Plugin-Authentication-Store-DBIx-Class')
-rw-r--r--www/p5-Catalyst-Plugin-Authentication-Store-DBIx-Class/Makefile31
-rw-r--r--www/p5-Catalyst-Plugin-Authentication-Store-DBIx-Class/distinfo3
-rw-r--r--www/p5-Catalyst-Plugin-Authentication-Store-DBIx-Class/pkg-descr4
-rw-r--r--www/p5-Catalyst-Plugin-Authentication-Store-DBIx-Class/pkg-plist15
4 files changed, 53 insertions, 0 deletions
diff --git a/www/p5-Catalyst-Plugin-Authentication-Store-DBIx-Class/Makefile b/www/p5-Catalyst-Plugin-Authentication-Store-DBIx-Class/Makefile
new file mode 100644
index 000000000000..468fcca06099
--- /dev/null
+++ b/www/p5-Catalyst-Plugin-Authentication-Store-DBIx-Class/Makefile
@@ -0,0 +1,31 @@
+# Ports collection makefile for: p5-Catalyst-Plugin-Authentication-Store-DBIx-Class
+# Date created: Jul 30, 2007
+# Whom: Lars Balker Rasmussen <lbr@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Catalyst-Plugin-Authentication-Store-DBIx-Class
+PORTVERSION= 0.10
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Catalyst
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= lbr@FreeBSD.org
+COMMENT= A storage class for Catalyst Authentication using DBIx::Class
+
+RUN_DEPENDS= p5-Catalyst-Runtime>=5.7000:${PORTSDIR}/www/p5-Catalyst-Runtime \
+ p5-Catalyst-Plugin-Authentication>=0:${PORTSDIR}/www/p5-Catalyst-Plugin-Authentication
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Catalyst::Plugin::Authentication::Store::DBIx::Class.3 \
+ Catalyst::Plugin::Authentication::Store::DBIx::Class::User.3
+
+.include <bsd.port.pre.mk>
+.if ${PERL_LEVEL} < 500801
+IGNORE= requires at least Perl 5.8.1. Install lang/perl5.8, and try again
+.endif
+.include <bsd.port.post.mk>
diff --git a/www/p5-Catalyst-Plugin-Authentication-Store-DBIx-Class/distinfo b/www/p5-Catalyst-Plugin-Authentication-Store-DBIx-Class/distinfo
new file mode 100644
index 000000000000..2f5f6b73dfce
--- /dev/null
+++ b/www/p5-Catalyst-Plugin-Authentication-Store-DBIx-Class/distinfo
@@ -0,0 +1,3 @@
+MD5 (Catalyst-Plugin-Authentication-Store-DBIx-Class-0.10.tar.gz) = 8e93c25b494742903c0058e81ac8897e
+SHA256 (Catalyst-Plugin-Authentication-Store-DBIx-Class-0.10.tar.gz) = c2b7dd7195808f8ea4996aa47991d0449cf8d1527af42601d7acd3893937fe87
+SIZE (Catalyst-Plugin-Authentication-Store-DBIx-Class-0.10.tar.gz) = 32005
diff --git a/www/p5-Catalyst-Plugin-Authentication-Store-DBIx-Class/pkg-descr b/www/p5-Catalyst-Plugin-Authentication-Store-DBIx-Class/pkg-descr
new file mode 100644
index 000000000000..c2f57e4b8b17
--- /dev/null
+++ b/www/p5-Catalyst-Plugin-Authentication-Store-DBIx-Class/pkg-descr
@@ -0,0 +1,4 @@
+The Catalyst::Plugin::Authentication::Store::DBIx::Class class provides access
+to authentication information stored in a database via DBIx::Class.
+
+WWW: http://search.cpan.org/dist/Catalyst-Plugin-Authentication-Store-DBIx-Class/
diff --git a/www/p5-Catalyst-Plugin-Authentication-Store-DBIx-Class/pkg-plist b/www/p5-Catalyst-Plugin-Authentication-Store-DBIx-Class/pkg-plist
new file mode 100644
index 000000000000..f1bece71bd0d
--- /dev/null
+++ b/www/p5-Catalyst-Plugin-Authentication-Store-DBIx-Class/pkg-plist
@@ -0,0 +1,15 @@
+%%SITE_PERL%%/Catalyst/Plugin/Authentication/Store/DBIx/Class/User.pm
+%%SITE_PERL%%/Catalyst/Plugin/Authentication/Store/DBIx/Class.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Catalyst/Plugin/Authentication/Store/DBIx/Class/.packlist
+@dirrmtry %%SITE_PERL%%/Catalyst/Plugin/Authentication/Store/DBIx/Class
+@dirrmtry %%SITE_PERL%%/Catalyst/Plugin/Authentication/Store/DBIx
+@dirrmtry %%SITE_PERL%%/Catalyst/Plugin/Authentication/Store
+@dirrmtry %%SITE_PERL%%/Catalyst/Plugin/Authentication
+@dirrmtry %%SITE_PERL%%/Catalyst/Plugin
+@dirrmtry %%SITE_PERL%%/Catalyst
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Catalyst/Plugin/Authentication/Store/DBIx/Class
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Catalyst/Plugin/Authentication/Store/DBIx
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Catalyst/Plugin/Authentication/Store
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Catalyst/Plugin/Authentication
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Catalyst/Plugin
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Catalyst