aboutsummaryrefslogtreecommitdiffstats
path: root/www/p5-Catalyst-Plugin-Cache-FileCache
diff options
context:
space:
mode:
authorerwin <erwin@FreeBSD.org>2005-12-20 03:44:44 +0800
committererwin <erwin@FreeBSD.org>2005-12-20 03:44:44 +0800
commit93dd146d417a68218f582b638c61d01372d540e8 (patch)
treed2fb2b9da3422e347302abc5d783e1a94d372f3a /www/p5-Catalyst-Plugin-Cache-FileCache
parent0e50cb563eec251a4987fe32f1cd80743bf4a3ac (diff)
downloadfreebsd-ports-gnome-93dd146d417a68218f582b638c61d01372d540e8.tar.gz
freebsd-ports-gnome-93dd146d417a68218f582b638c61d01372d540e8.tar.zst
freebsd-ports-gnome-93dd146d417a68218f582b638c61d01372d540e8.zip
Extends base class with a file cache.
WWW: http://search.cpan.org/dist/Catalyst-Plugin-Cache-FileCache/ PR: ports/90662 Submitted by: Lars Balker Rasmussen <lars@balker.dk>
Diffstat (limited to 'www/p5-Catalyst-Plugin-Cache-FileCache')
-rw-r--r--www/p5-Catalyst-Plugin-Cache-FileCache/Makefile30
-rw-r--r--www/p5-Catalyst-Plugin-Cache-FileCache/distinfo3
-rw-r--r--www/p5-Catalyst-Plugin-Cache-FileCache/pkg-descr3
-rw-r--r--www/p5-Catalyst-Plugin-Cache-FileCache/pkg-plist4
4 files changed, 40 insertions, 0 deletions
diff --git a/www/p5-Catalyst-Plugin-Cache-FileCache/Makefile b/www/p5-Catalyst-Plugin-Cache-FileCache/Makefile
new file mode 100644
index 000000000000..0f6f62aaaf4d
--- /dev/null
+++ b/www/p5-Catalyst-Plugin-Cache-FileCache/Makefile
@@ -0,0 +1,30 @@
+# Ports collection makefile for: p5-Catalyst-Plugin-Cache-FileCache
+# Date created: Dec 19, 2005
+# Whom: Lars Balker Rasmussen <lars@balker.dk>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Catalyst-Plugin-Cache-FileCache
+PORTVERSION= 0.5
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Catalyst
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= lars@balker.dk
+COMMENT= File cache for Catalyst
+
+BUILD_DEPENDS= p5-Catalyst>=0:${PORTSDIR}/www/p5-Catalyst \
+ p5-Cache-Cache>=0:${PORTSDIR}/devel/p5-Cache-Cache
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_MODBUILD= yes
+
+MAN3= Catalyst::Plugin::Cache::FileCache.3
+
+.include <bsd.port.pre.mk>
+.if ${PERL_LEVEL} < 500801
+IGNORE= requires at least Perl 5.8.1. Install lang/perl5.8, and try again
+.endif
+.include <bsd.port.post.mk>
diff --git a/www/p5-Catalyst-Plugin-Cache-FileCache/distinfo b/www/p5-Catalyst-Plugin-Cache-FileCache/distinfo
new file mode 100644
index 000000000000..2c079e2365bc
--- /dev/null
+++ b/www/p5-Catalyst-Plugin-Cache-FileCache/distinfo
@@ -0,0 +1,3 @@
+MD5 (Catalyst-Plugin-Cache-FileCache-0.5.tar.gz) = 24cceca960d0a41c833aa3689204556a
+SHA256 (Catalyst-Plugin-Cache-FileCache-0.5.tar.gz) = a6083c136b90ef0cc4ea0d2dbfec81f241e5ca84cd24245f253433051ce948ae
+SIZE (Catalyst-Plugin-Cache-FileCache-0.5.tar.gz) = 2322
diff --git a/www/p5-Catalyst-Plugin-Cache-FileCache/pkg-descr b/www/p5-Catalyst-Plugin-Cache-FileCache/pkg-descr
new file mode 100644
index 000000000000..5891d9c3617e
--- /dev/null
+++ b/www/p5-Catalyst-Plugin-Cache-FileCache/pkg-descr
@@ -0,0 +1,3 @@
+Extends base class with a file cache.
+
+WWW: http://search.cpan.org/dist/Catalyst-Plugin-Cache-FileCache/
diff --git a/www/p5-Catalyst-Plugin-Cache-FileCache/pkg-plist b/www/p5-Catalyst-Plugin-Cache-FileCache/pkg-plist
new file mode 100644
index 000000000000..f4cf98e5ff6a
--- /dev/null
+++ b/www/p5-Catalyst-Plugin-Cache-FileCache/pkg-plist
@@ -0,0 +1,4 @@
+%%SITE_PERL%%/Catalyst/Plugin/Cache/FileCache.pm
+@unexec rmdir %D/%%SITE_PERL%%/Catalyst/Plugin/Cache 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Catalyst/Plugin 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Catalyst 2>/dev/null || true