aboutsummaryrefslogtreecommitdiffstats
path: root/www/p5-Catalyst-Plugin-CommandLine
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2009-04-24 01:06:40 +0800
committermiwi <miwi@FreeBSD.org>2009-04-24 01:06:40 +0800
commit9f3444958ad4af66293b27ab204f7fb864ee5770 (patch)
treec488c52df0926036e9106493b5c70b919e85b727 /www/p5-Catalyst-Plugin-CommandLine
parent8123e7efca603ad3b5ab71b657aeeca449d5539a (diff)
downloadfreebsd-ports-gnome-9f3444958ad4af66293b27ab204f7fb864ee5770.tar.gz
freebsd-ports-gnome-9f3444958ad4af66293b27ab204f7fb864ee5770.tar.zst
freebsd-ports-gnome-9f3444958ad4af66293b27ab204f7fb864ee5770.zip
Use this module if you need to have access to the Catalyst controllers or
models from command line script. WWW: http://search.cpan.org/dist/Catalyst-Plugin-CommandLine/ PR: ports/133923 Submitted by: Alexey V. Degtyarev <alexey at renatasystems.org>
Diffstat (limited to 'www/p5-Catalyst-Plugin-CommandLine')
-rw-r--r--www/p5-Catalyst-Plugin-CommandLine/Makefile26
-rw-r--r--www/p5-Catalyst-Plugin-CommandLine/distinfo3
-rw-r--r--www/p5-Catalyst-Plugin-CommandLine/pkg-descr4
-rw-r--r--www/p5-Catalyst-Plugin-CommandLine/pkg-plist7
4 files changed, 40 insertions, 0 deletions
diff --git a/www/p5-Catalyst-Plugin-CommandLine/Makefile b/www/p5-Catalyst-Plugin-CommandLine/Makefile
new file mode 100644
index 000000000000..366075a8693d
--- /dev/null
+++ b/www/p5-Catalyst-Plugin-CommandLine/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: p5-Catalyst-Plugin-CommandLine
+# Date created: Wed 22 Apr 2009
+# Whom: Alexey V. Degtyarev <alexey@renatasystems.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Catalyst-Plugin-CommandLine
+PORTVERSION= 0.05
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= alexey@renatasystems.org
+COMMENT= Catalyst plugin to make controllers or models available for scripts
+
+BUILD_DEPENDS= ${SITE_PERL}/Catalyst.pm:${PORTSDIR}/www/p5-Catalyst-Runtime \
+ ${SITE_PERL}/URI/http.pm:${PORTSDIR}/net/p5-URI \
+ ${SITE_PERL}/HTTP/Headers.pm:${PORTSDIR}/www/p5-libwww
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Catalyst::Plugin::CommandLine.3
+
+.include <bsd.port.mk>
diff --git a/www/p5-Catalyst-Plugin-CommandLine/distinfo b/www/p5-Catalyst-Plugin-CommandLine/distinfo
new file mode 100644
index 000000000000..4e5b73bf3a48
--- /dev/null
+++ b/www/p5-Catalyst-Plugin-CommandLine/distinfo
@@ -0,0 +1,3 @@
+MD5 (Catalyst-Plugin-CommandLine-0.05.tar.gz) = b88626d1d8cec8bf5b9a36b91c08d936
+SHA256 (Catalyst-Plugin-CommandLine-0.05.tar.gz) = 05d5d45aad97b86689203125544b04b8d64e76ee9df1a4a31b3a7dafc28bb2d1
+SIZE (Catalyst-Plugin-CommandLine-0.05.tar.gz) = 4314
diff --git a/www/p5-Catalyst-Plugin-CommandLine/pkg-descr b/www/p5-Catalyst-Plugin-CommandLine/pkg-descr
new file mode 100644
index 000000000000..deb9d0a97736
--- /dev/null
+++ b/www/p5-Catalyst-Plugin-CommandLine/pkg-descr
@@ -0,0 +1,4 @@
+Use this module if you need to have access to the Catalyst controllers or
+models from command line script.
+
+WWW: http://search.cpan.org/dist/Catalyst-Plugin-CommandLine/
diff --git a/www/p5-Catalyst-Plugin-CommandLine/pkg-plist b/www/p5-Catalyst-Plugin-CommandLine/pkg-plist
new file mode 100644
index 000000000000..3d27e09df753
--- /dev/null
+++ b/www/p5-Catalyst-Plugin-CommandLine/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/Catalyst/Plugin/CommandLine.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Catalyst/Plugin/CommandLine/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Catalyst/Plugin/CommandLine
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Catalyst/Plugin
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Catalyst
+@dirrmtry %%SITE_PERL%%/Catalyst/Plugin
+@dirrmtry %%SITE_PERL%%/Catalyst