aboutsummaryrefslogtreecommitdiffstats
path: root/www/p5-Catalyst-Plugin-Session-FastMmap
diff options
context:
space:
mode:
authorlth <lth@FreeBSD.org>2005-05-08 18:35:48 +0800
committerlth <lth@FreeBSD.org>2005-05-08 18:35:48 +0800
commitaafab2fae88497adb7693268d63af667a4d71952 (patch)
tree2f731006e01df9c1d3e4ffa32dbc0023d0014aa0 /www/p5-Catalyst-Plugin-Session-FastMmap
parent4540aca181c85a16326930af00ad2d827840fe07 (diff)
downloadfreebsd-ports-gnome-aafab2fae88497adb7693268d63af667a4d71952.tar.gz
freebsd-ports-gnome-aafab2fae88497adb7693268d63af667a4d71952.tar.zst
freebsd-ports-gnome-aafab2fae88497adb7693268d63af667a4d71952.zip
Add p5-Catalyst-Plugin-Session-FastMmap 0.09, FastMmap sessions for
Catalyst.
Diffstat (limited to 'www/p5-Catalyst-Plugin-Session-FastMmap')
-rw-r--r--www/p5-Catalyst-Plugin-Session-FastMmap/Makefile35
-rw-r--r--www/p5-Catalyst-Plugin-Session-FastMmap/distinfo2
-rw-r--r--www/p5-Catalyst-Plugin-Session-FastMmap/pkg-descr3
-rw-r--r--www/p5-Catalyst-Plugin-Session-FastMmap/pkg-plist9
4 files changed, 49 insertions, 0 deletions
diff --git a/www/p5-Catalyst-Plugin-Session-FastMmap/Makefile b/www/p5-Catalyst-Plugin-Session-FastMmap/Makefile
new file mode 100644
index 000000000000..1cd18f2ff555
--- /dev/null
+++ b/www/p5-Catalyst-Plugin-Session-FastMmap/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: www/p5-Catalyst-Plugin-Session-FastMmap
+# Date created: 08 May 2005
+# Whom: Lars Thegler <lth@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Catalyst-Plugin-Session-FastMmap
+PORTVERSION= 0.09
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ../by-authors/id/S/SR/SRI
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= lth@FreeBSD.org
+COMMENT= FastMmap sessions for Catalyst
+
+BUILD_DEPENDS= ${SITE_PERL}/URI.pm:${PORTSDIR}/net/p5-URI \
+ ${SITE_PERL}/${PERL_ARCH}/Cache/FastMmap.pm:${PORTSDIR}/devel/p5-Cache-FastMmap \
+ ${SITE_PERL}/Class/Accessor/Fast.pm:${PORTSDIR}/devel/p5-Class-Accessor \
+ ${SITE_PERL}/URI/Find.pm:${PORTSDIR}/textproc/p5-URI-Find \
+ ${SITE_PERL}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5 \
+ ${SITE_PERL}/Catalyst.pm:${PORTSDIR}/www/p5-Catalyst \
+ ${SITE_PERL}/Class/Data/Inheritable.pm:${PORTSDIR}/devel/p5-Class-Data-Inheritable
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Catalyst::Plugin::Session::FastMmap.3
+
+.include <bsd.port.pre.mk>
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires Perl 5.6. Install lang/perl5 or lang/perl5.8, and try again
+.endif
+.include <bsd.port.post.mk>
diff --git a/www/p5-Catalyst-Plugin-Session-FastMmap/distinfo b/www/p5-Catalyst-Plugin-Session-FastMmap/distinfo
new file mode 100644
index 000000000000..560bca9dd36f
--- /dev/null
+++ b/www/p5-Catalyst-Plugin-Session-FastMmap/distinfo
@@ -0,0 +1,2 @@
+MD5 (Catalyst-Plugin-Session-FastMmap-0.09.tar.gz) = 81b47be88edb516eb5639f4cedb66f50
+SIZE (Catalyst-Plugin-Session-FastMmap-0.09.tar.gz) = 2993
diff --git a/www/p5-Catalyst-Plugin-Session-FastMmap/pkg-descr b/www/p5-Catalyst-Plugin-Session-FastMmap/pkg-descr
new file mode 100644
index 000000000000..f4f71736ffa5
--- /dev/null
+++ b/www/p5-Catalyst-Plugin-Session-FastMmap/pkg-descr
@@ -0,0 +1,3 @@
+FastMmap sessions for Catalyst.
+
+WWW: http://search.cpan.org/dist/Catalyst-Plugin-Session-FastMmap
diff --git a/www/p5-Catalyst-Plugin-Session-FastMmap/pkg-plist b/www/p5-Catalyst-Plugin-Session-FastMmap/pkg-plist
new file mode 100644
index 000000000000..263572e5c269
--- /dev/null
+++ b/www/p5-Catalyst-Plugin-Session-FastMmap/pkg-plist
@@ -0,0 +1,9 @@
+%%SITE_PERL%%/Catalyst/Plugin/Session/FastMmap.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Catalyst/Plugin/Session/FastMmap/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Catalyst/Plugin/Session/FastMmap
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Catalyst/Plugin/Session
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Catalyst/Plugin 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Catalyst 2>/dev/null || true
+@dirrm %%SITE_PERL%%/Catalyst/Plugin/Session
+@unexec rmdir %D/%%SITE_PERL%%/Catalyst/Plugin 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Catalyst 2>/dev/null || true