aboutsummaryrefslogtreecommitdiffstats
path: root/www/p5-CatalystX-InjectComponent
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2012-04-21 02:11:39 +0800
committersunpoet <sunpoet@FreeBSD.org>2012-04-21 02:11:39 +0800
commit4b9d8fcccbd3e3fef5c5f79232d3bc4ffe445790 (patch)
tree9a07052363277200b71447c74d01e8efac2d7096 /www/p5-CatalystX-InjectComponent
parenta449703a16f5a886b204eef431428944a6b8051c (diff)
downloadfreebsd-ports-gnome-4b9d8fcccbd3e3fef5c5f79232d3bc4ffe445790.tar.gz
freebsd-ports-gnome-4b9d8fcccbd3e3fef5c5f79232d3bc4ffe445790.tar.zst
freebsd-ports-gnome-4b9d8fcccbd3e3fef5c5f79232d3bc4ffe445790.zip
- Fix *_DEPENDS:
- p5-Module-Pluggable is already in all supported Perl releases - p5-parent is in core since Perl 5.10.1 - Bump PORTREVISION for dependency change
Diffstat (limited to 'www/p5-CatalystX-InjectComponent')
-rw-r--r--www/p5-CatalystX-InjectComponent/Makefile20
1 files changed, 11 insertions, 9 deletions
diff --git a/www/p5-CatalystX-InjectComponent/Makefile b/www/p5-CatalystX-InjectComponent/Makefile
index f02476320690..426787141ea7 100644
--- a/www/p5-CatalystX-InjectComponent/Makefile
+++ b/www/p5-CatalystX-InjectComponent/Makefile
@@ -7,27 +7,29 @@
PORTNAME= CatalystX-InjectComponent
PORTVERSION= 0.024
+PORTREVISION= 1
CATEGORIES= www perl5
MASTER_SITES= CPAN
-MASTER_SITE_SUBDIR= CPAN:RKRIMEN
PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Inject components into your Catalyst application
BUILD_DEPENDS= p5-Catalyst-Runtime>=5.8:${PORTSDIR}/www/p5-Catalyst-Runtime \
- p5-Class-Inspector>=0:${PORTSDIR}/devel/p5-Class-Inspector \
- p5-Module-Pluggable>=0:${PORTSDIR}/devel/p5-Module-Pluggable \
- p5-parent>=0:${PORTSDIR}/devel/p5-parent
+ p5-Class-Inspector>=0:${PORTSDIR}/devel/p5-Class-Inspector
RUN_DEPENDS= p5-Catalyst-Runtime>=5.8:${PORTSDIR}/www/p5-Catalyst-Runtime \
- p5-Class-Inspector>=0:${PORTSDIR}/devel/p5-Class-Inspector \
- p5-Module-Pluggable>=0:${PORTSDIR}/devel/p5-Module-Pluggable \
- p5-parent>=0:${PORTSDIR}/devel/p5-parent
+ p5-Class-Inspector>=0:${PORTSDIR}/devel/p5-Class-Inspector
TEST_DEPENDS= p5-Test-Most>=0:${PORTSDIR}/devel/p5-Test-Most
-USE_PERL5= yes
PERL_CONFIGURE= yes
MAN3= CatalystX::InjectComponent.3
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 501001
+BUILD_DEPENDS+= p5-parent>=0:${PORTSDIR}/devel/p5-parent
+RUN_DEPENDS+= p5-parent>=0:${PORTSDIR}/devel/p5-parent
+.endif
+
+.include <bsd.port.post.mk>