aboutsummaryrefslogtreecommitdiffstats
path: root/www/p5-Data-Validate-URI
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2008-01-14 19:42:27 +0800
committermiwi <miwi@FreeBSD.org>2008-01-14 19:42:27 +0800
commitff052f2d7b517d6cbfa41e8598430b2481dbfaa3 (patch)
tree13fb588b9e082bbdc995bf1aed0d195a5c392a21 /www/p5-Data-Validate-URI
parent6557c791ee2fd871a3580677a2bfe6d9aae64059 (diff)
downloadfreebsd-ports-gnome-ff052f2d7b517d6cbfa41e8598430b2481dbfaa3.tar.gz
freebsd-ports-gnome-ff052f2d7b517d6cbfa41e8598430b2481dbfaa3.tar.zst
freebsd-ports-gnome-ff052f2d7b517d6cbfa41e8598430b2481dbfaa3.zip
This module collects common URI validation routines to make input validation,
and untainting easier and more readable. All functions return an untainted value if the test passes, and undef if it fails. This means that you should always check for a defined status explicitly. Don't assume the return will be true. The value to test is always the first (and often only) argument. There are a number of other URI validation modules out there as well. This one focuses on being fast, lightweight, and relatively 'real-world'. i.e. it's good if you want to check user input, and don't need to parse out the URI/URL into chunks. Right now the module focuses on HTTP URIs, since they're arguably the most common. WWW: http://search.cpan.org/dist/Data-Validate-URI PR: ports/119264 Submitted by: Tuc <freebsd-ports at t-b-o-h.net>
Diffstat (limited to 'www/p5-Data-Validate-URI')
-rw-r--r--www/p5-Data-Validate-URI/Makefile27
-rw-r--r--www/p5-Data-Validate-URI/distinfo3
-rw-r--r--www/p5-Data-Validate-URI/pkg-descr18
-rw-r--r--www/p5-Data-Validate-URI/pkg-plist17
4 files changed, 65 insertions, 0 deletions
diff --git a/www/p5-Data-Validate-URI/Makefile b/www/p5-Data-Validate-URI/Makefile
new file mode 100644
index 000000000000..27f4e0283baf
--- /dev/null
+++ b/www/p5-Data-Validate-URI/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: www/p5-Data-Validate-URI
+# Date created: 02 January 2008
+# Whom: Tuc <freebsd-ports@t-b-o-h.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Data-Validate-URI
+PORTVERSION= 0.04
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= Data
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= freebsd-ports@t-b-o-h.net
+COMMENT= Common data validation methods for URIs
+
+BUILD_DEPENDS= ${SITE_PERL}/Data/Validate/Domain.pm:${PORTSDIR}/dns/p5-Data-Validate-Domain \
+ ${SITE_PERL}/Data/Validate/IP.pm:${PORTSDIR}/net-mgmt/p5-Data-Validate-IP
+RUN_DEPENDS= ${SITE_PERL}/Data/Validate/Domain.pm:${PORTSDIR}/dns/p5-Data-Validate-Domain \
+ ${SITE_PERL}/Data/Validate/IP.pm:${PORTSDIR}/net-mgmt/p5-Data-Validate-IP
+
+PERL_CONFIGURE= yes
+
+MAN3= Data::Validate::URI.3
+
+.include <bsd.port.mk>
diff --git a/www/p5-Data-Validate-URI/distinfo b/www/p5-Data-Validate-URI/distinfo
new file mode 100644
index 000000000000..2d0b78ea9092
--- /dev/null
+++ b/www/p5-Data-Validate-URI/distinfo
@@ -0,0 +1,3 @@
+MD5 (Data-Validate-URI-0.04.tar.gz) = 1cbada5653a33e496e07b2c3c70c80ae
+SHA256 (Data-Validate-URI-0.04.tar.gz) = 5b0acd34dd08f7e6db6b5c76c0cdf26cece3729ae06a4ff1da7b86e985b5035a
+SIZE (Data-Validate-URI-0.04.tar.gz) = 10313
diff --git a/www/p5-Data-Validate-URI/pkg-descr b/www/p5-Data-Validate-URI/pkg-descr
new file mode 100644
index 000000000000..0aa1d7d28f8f
--- /dev/null
+++ b/www/p5-Data-Validate-URI/pkg-descr
@@ -0,0 +1,18 @@
+This module collects common URI validation routines to make input validation,
+and untainting easier and more readable.
+
+All functions return an untainted value if the test passes, and undef if it
+fails. This means that you should always check for a defined status
+explicitly. Don't assume the return will be true.
+
+The value to test is always the first (and often only) argument.
+
+There are a number of other URI validation modules out there as well.
+This one focuses on being fast, lightweight, and relatively 'real-world'.
+i.e. it's good if you want to check user input, and don't need to parse
+out the URI/URL into chunks.
+
+Right now the module focuses on HTTP URIs, since they're arguably the most
+common.
+
+WWW: http://search.cpan.org/dist/Data-Validate-URI
diff --git a/www/p5-Data-Validate-URI/pkg-plist b/www/p5-Data-Validate-URI/pkg-plist
new file mode 100644
index 000000000000..c0c0737d20b0
--- /dev/null
+++ b/www/p5-Data-Validate-URI/pkg-plist
@@ -0,0 +1,17 @@
+%%SITE_PERL%%/Data/Validate/URI.pm
+%%SITE_PERL%%/auto/Data/Validate/URI/new.al
+%%SITE_PERL%%/auto/Data/Validate/URI/is_uri.al
+%%SITE_PERL%%/auto/Data/Validate/URI/is_http_uri.al
+%%SITE_PERL%%/auto/Data/Validate/URI/is_https_uri.al
+%%SITE_PERL%%/auto/Data/Validate/URI/is_web_uri.al
+%%SITE_PERL%%/auto/Data/Validate/URI/_split_uri.al
+%%SITE_PERL%%/auto/Data/Validate/URI/autosplit.ix
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Data/Validate/URI/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Data/Validate/URI
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Data/Validate
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Data
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto
+@dirrmtry %%SITE_PERL%%/auto/Data/Validate/URI
+@dirrmtry %%SITE_PERL%%/auto/Data/Validate
+@dirrmtry %%SITE_PERL%%/auto/Data
+@dirrmtry %%SITE_PERL%%/Data