aboutsummaryrefslogtreecommitdiffstats
path: root/www/p5-Emplacken/Makefile
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2011-03-10 00:44:16 +0800
committermiwi <miwi@FreeBSD.org>2011-03-10 00:44:16 +0800
commit588cacefb7be94ae972a29e8046e44f5fb29aeab (patch)
tree2a7947d9013b82801e3408f2e83f99e279668ea5 /www/p5-Emplacken/Makefile
parent29398138ff0dc5f073e563f30396c59483684ddb (diff)
downloadfreebsd-ports-gnome-588cacefb7be94ae972a29e8046e44f5fb29aeab.tar.gz
freebsd-ports-gnome-588cacefb7be94ae972a29e8046e44f5fb29aeab.tar.zst
freebsd-ports-gnome-588cacefb7be94ae972a29e8046e44f5fb29aeab.zip
Emplacken is a tool for managing a set of Plack applications based on
config files. It also adds support for privilege dropping and error logs to those Plack servers that don't support these features natively. It works be reading a config file and using that to generate a PSGI application file based on your config. It knows how to generate Catalyst, Mojo, and Mason app files natively. For other apps, or more complicated setups, you can supply a template to Emplacken and it will use that to generate the PSGI app. WWW: http://search.cpan.org/dist/Emplacken/ PR: ports/154812 Submitted by: Gea-Suan Lin <gslin at gslin.org>
Diffstat (limited to 'www/p5-Emplacken/Makefile')
-rw-r--r--www/p5-Emplacken/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/www/p5-Emplacken/Makefile b/www/p5-Emplacken/Makefile
new file mode 100644
index 000000000000..99b78cf1e9a3
--- /dev/null
+++ b/www/p5-Emplacken/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: p5-Emplacken
+# Date created: 2011-02-16
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Emplacken
+PORTVERSION= 0.01
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= ../../authors/id/D/DR/DROLSKY
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gslin@gslin.org
+COMMENT= Manage multiple plack apps with a directory of config files
+
+RUN_DEPENDS= p5-Class-Load>=0:${PORTSDIR}/devel/p5-Class-Load \
+ p5-Config-Any>=0:${PORTSDIR}/devel/p5-Config-Any \
+ p5-File-Pid>=0:${PORTSDIR}/devel/p5-File-Pid \
+ p5-List-AllUtils>=0:${PORTSDIR}/devel/p5-List-AllUtils \
+ p5-Moose>=0:${PORTSDIR}/devel/p5-Moose \
+ p5-MooseX-Getopt>=0:${PORTSDIR}/devel/p5-MooseX-Getopt \
+ p5-MooseX-Types>=0:${PORTSDIR}/devel/p5-MooseX-Types \
+ p5-MooseX-Types-Path-Class>=0:${PORTSDIR}/devel/p5-MooseX-Types-Path-Class \
+ p5-MooseX-Types-Perl>=0:${PORTSDIR}/devel/p5-MooseX-Types-Perl \
+ p5-Path-Class>=0:${PORTSDIR}/devel/p5-Path-Class \
+ p5-Text-Template>=0:${PORTSDIR}/textproc/p5-Text-Template \
+ p5-autodie>=0:${PORTSDIR}/devel/p5-autodie \
+ p5-namespace-autoclean>=0:${PORTSDIR}/devel/p5-namespace-autoclean
+
+PERL_CONFIGURE= yes
+
+MAN3= Emplacken.3 \
+ Emplacken::Types.3
+
+.include <bsd.port.mk>