aboutsummaryrefslogtreecommitdiffstats
path: root/www/p5-FCGI-ProcManager
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2007-12-31 08:28:05 +0800
committermiwi <miwi@FreeBSD.org>2007-12-31 08:28:05 +0800
commit9d66ee516e5cd3c2b79d11b5b36b6538ced98dbf (patch)
treea34e81e4b3b4d36cac5e7e07c1d009aa3c65bec4 /www/p5-FCGI-ProcManager
parentb9ab8729ac6d4f5278c02feba843161b65d5c6b1 (diff)
downloadfreebsd-ports-gnome-9d66ee516e5cd3c2b79d11b5b36b6538ced98dbf.tar.gz
freebsd-ports-gnome-9d66ee516e5cd3c2b79d11b5b36b6538ced98dbf.tar.zst
freebsd-ports-gnome-9d66ee516e5cd3c2b79d11b5b36b6538ced98dbf.zip
FCGI::ProcManager is used to serve as a FastCGI process manager. By
re-implementing it in perl, developers can more finely tune performance in their web applications, and can take advantage of copy-on-write semantics prevalent in UNIX kernel process management. The process manager should be invoked before the caller''s request loop WWW: http://search.cpan.org/dist/FCGI-ProcManager/ PR: ports/119009 Submitted by: Peter <peter at vereshagin.org>
Diffstat (limited to 'www/p5-FCGI-ProcManager')
-rw-r--r--www/p5-FCGI-ProcManager/Makefile22
-rw-r--r--www/p5-FCGI-ProcManager/distinfo3
-rw-r--r--www/p5-FCGI-ProcManager/pkg-descr7
-rw-r--r--www/p5-FCGI-ProcManager/pkg-plist5
4 files changed, 37 insertions, 0 deletions
diff --git a/www/p5-FCGI-ProcManager/Makefile b/www/p5-FCGI-ProcManager/Makefile
new file mode 100644
index 000000000000..591dc25520fd
--- /dev/null
+++ b/www/p5-FCGI-ProcManager/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: p5-FCGI-ProcManager
+# Date created: 2007-12-28
+# Whom: Peter <peter@vereshagin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= FCGI-ProcManager
+PORTVERSION= 0.17
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= FCGI
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= peter@vereshagin.org
+COMMENT= Functions for managing FastCGI applications
+
+PERL_CONFIGURE= yes
+
+MAN3= FCGI::ProcManager.3
+
+.include <bsd.port.mk>
diff --git a/www/p5-FCGI-ProcManager/distinfo b/www/p5-FCGI-ProcManager/distinfo
new file mode 100644
index 000000000000..089a6d24a491
--- /dev/null
+++ b/www/p5-FCGI-ProcManager/distinfo
@@ -0,0 +1,3 @@
+MD5 (FCGI-ProcManager-0.17.tar.gz) = bd59bf793574d68024060a8a197419f7
+SHA256 (FCGI-ProcManager-0.17.tar.gz) = c323ae1a0f91aebcb8467444e451c0915cd34f0556ccd6433fb7dd360d739486
+SIZE (FCGI-ProcManager-0.17.tar.gz) = 18192
diff --git a/www/p5-FCGI-ProcManager/pkg-descr b/www/p5-FCGI-ProcManager/pkg-descr
new file mode 100644
index 000000000000..dfc8dd29a17d
--- /dev/null
+++ b/www/p5-FCGI-ProcManager/pkg-descr
@@ -0,0 +1,7 @@
+FCGI::ProcManager is used to serve as a FastCGI process manager. By
+re-implementing it in perl, developers can more finely tune performance in
+their web applications, and can take advantage of copy-on-write semantics
+prevalent in UNIX kernel process management. The process manager should
+be invoked before the caller''s request loop
+
+WWW: http://search.cpan.org/dist/FCGI-ProcManager/
diff --git a/www/p5-FCGI-ProcManager/pkg-plist b/www/p5-FCGI-ProcManager/pkg-plist
new file mode 100644
index 000000000000..e0d5d04bdf82
--- /dev/null
+++ b/www/p5-FCGI-ProcManager/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/FCGI/ProcManager.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/FCGI/ProcManager/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/FCGI/ProcManager
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/FCGI
+@dirrmtry %%SITE_PERL%%/FCGI