aboutsummaryrefslogtreecommitdiffstats
path: root/www/p5-Gantry
diff options
context:
space:
mode:
authorvanilla <vanilla@FreeBSD.org>2013-11-07 22:09:15 +0800
committervanilla <vanilla@FreeBSD.org>2013-11-07 22:09:15 +0800
commit214e27ba514a16621544bc7709ab28cdde668046 (patch)
treeace721ee9227790a9b45fc4d5656eea64167a533 /www/p5-Gantry
parent8b0e2b45fafd1c973738bbb915656daa4a03a04c (diff)
downloadfreebsd-ports-gnome-214e27ba514a16621544bc7709ab28cdde668046.tar.gz
freebsd-ports-gnome-214e27ba514a16621544bc7709ab28cdde668046.tar.zst
freebsd-ports-gnome-214e27ba514a16621544bc7709ab28cdde668046.zip
Fix pkg-plist.
Diffstat (limited to 'www/p5-Gantry')
-rw-r--r--www/p5-Gantry/Makefile4
-rw-r--r--www/p5-Gantry/files/patch-Build.PL36
-rw-r--r--www/p5-Gantry/pkg-plist83
3 files changed, 116 insertions, 7 deletions
diff --git a/www/p5-Gantry/Makefile b/www/p5-Gantry/Makefile
index 245986ada36b..7ea99e693021 100644
--- a/www/p5-Gantry/Makefile
+++ b/www/p5-Gantry/Makefile
@@ -33,6 +33,7 @@ TEST_DEPENDS= p5-Test-Exception>=0:${PORTSDIR}/devel/p5-Test-Exception
USES= perl5
USE_PERL5= modbuild
CONFIGURE_ARGS= </dev/null
+PLIST_SUB+= WWWDIR=${WWWDIR}
WWWDIR= ${PREFIX}/www/${PORTNAME:L}
@@ -41,7 +42,4 @@ post-patch:
-e 's,\$ENV{'GANTRY_TEMPLATE_PATH'},${WWWDIR},g' \
${WRKSRC}/Build.PL
-pre-su-install:
- @${MKDIR} ${STAGEDIR}${WWWDIR}
-
.include <bsd.port.mk>
diff --git a/www/p5-Gantry/files/patch-Build.PL b/www/p5-Gantry/files/patch-Build.PL
index 04ca30f4cf8b..8d61846e2bfa 100644
--- a/www/p5-Gantry/files/patch-Build.PL
+++ b/www/p5-Gantry/files/patch-Build.PL
@@ -1,5 +1,5 @@
--- Build.PL.orig 2010-01-14 01:33:31.000000000 +0800
-+++ Build.PL 2013-11-07 20:14:30.000000000 +0800
++++ Build.PL 2013-11-07 22:04:58.000000000 +0800
@@ -107,27 +107,6 @@ if (! $template_path) {
$build->notes( install_web_directory => $template_path );
@@ -45,9 +45,39 @@
# write Init.pm file with install options
-@@ -236,10 +214,6 @@ EO_INIT
+@@ -207,14 +185,15 @@ EO_INIT
+ chmod $orig_mode, $dst or die "Can't chmod $orig_mode $dst: $!";
+ }
+
++ my $www_dir = $destdir . $tmpl_dir;
+ eval {
+ # this should have been done during perl Build.PL
+- if ( not -d $tmpl_dir ) {
+- File::Path::mkpath( $tmpl_dir );
++ if ( not -d $www_dir ) {
++ File::Path::mkpath( $www_dir );
+ }
+ };
+ if ( $@ ) {
+- print "Error: unable to create directory $tmpl_dir\n";
++ print "Error: unable to create directory $www_dir\n";
+ $@ =~ s/ at .+?$//;
+ die( "$@\n" );
+ }
+@@ -227,19 +206,15 @@ EO_INIT
+ require File::Copy::Recursive;
+ import File::Copy::Recursive 'dircopy';
+
+- $num = dircopy($blib_tmpl_dir, $tmpl_dir) || 0;
++ $num = dircopy($blib_tmpl_dir, $www_dir) || 0;
+ };
+ if ( $@ ) {
+ print "\nError coping templates:\n";
+ print $@ . "\n";
+ }
else {
- print "\n$num Gantry templates copied to $tmpl_dir\n";
+- print "\n$num Gantry templates copied to $tmpl_dir\n";
++ print "\n$num Gantry templates copied to $www_dir\n";
}
- }
- else {
diff --git a/www/p5-Gantry/pkg-plist b/www/p5-Gantry/pkg-plist
index 11c406f661c7..1da5a8c8f3ad 100644
--- a/www/p5-Gantry/pkg-plist
+++ b/www/p5-Gantry/pkg-plist
@@ -215,7 +215,88 @@
%%SITE_PERL%%/Gantry/Utils/Threeway.pm
%%SITE_PERL%%/Gantry/Utils/Validate.pm
%%SITE_PERL%%/Template/Plugin/GantryAuthCookie.pm
-@dirrmtry www/gantry
+%%WWWDIR%%/bookerrata.html
+%%WWWDIR%%/control_wrapper.tt
+%%WWWDIR%%/css/default.css
+%%WWWDIR%%/css/gantry_datepicker.css
+%%WWWDIR%%/css/gantry_forms.css
+%%WWWDIR%%/css/gantry_layout.css
+%%WWWDIR%%/css/gantry_site.css
+%%WWWDIR%%/css/my.css
+%%WWWDIR%%/css/pod_style.css
+%%WWWDIR%%/data.tt
+%%WWWDIR%%/default.tt
+%%WWWDIR%%/delete.tt
+%%WWWDIR%%/editor_init.ttc
+%%WWWDIR%%/form.tt
+%%WWWDIR%%/form_ajax.tt
+%%WWWDIR%%/gantry_site.html
+%%WWWDIR%%/gantrybookcode.tar.gz
+%%WWWDIR%%/images/bar.a-center-gray.png
+%%WWWDIR%%/images/bar.a-left-gray.png
+%%WWWDIR%%/images/bar.a-right-gray.png
+%%WWWDIR%%/images/bar2-center-gray.png
+%%WWWDIR%%/images/bar2-left-gray.png
+%%WWWDIR%%/images/bar2-right-gray.png
+%%WWWDIR%%/images/blc-gray-block.gif
+%%WWWDIR%%/images/bookcover.gif
+%%WWWDIR%%/images/brc-gray-block.gif
+%%WWWDIR%%/images/building240.jpg
+%%WWWDIR%%/images/form.png
+%%WWWDIR%%/images/gantry_gears.jpg
+%%WWWDIR%%/images/gantry_logo.png
+%%WWWDIR%%/images/mainlist.png
+%%WWWDIR%%/images/pdf.gif
+%%WWWDIR%%/images/tenttut/appbody.png
+%%WWWDIR%%/images/tenttut/appconfig.png
+%%WWWDIR%%/images/tenttut/appstat.png
+%%WWWDIR%%/images/tenttut/backends.png
+%%WWWDIR%%/images/tenttut/controledit.png
+%%WWWDIR%%/images/tenttut/dataedit.png
+%%WWWDIR%%/images/tenttut/fieldedit.png
+%%WWWDIR%%/images/tenttut/fieldedit2.png
+%%WWWDIR%%/images/tenttut/formedit.png
+%%WWWDIR%%/images/tenttut/joiner.png
+%%WWWDIR%%/images/tenttut/main_listingout.png
+%%WWWDIR%%/images/tenttut/mainlistedit.png
+%%WWWDIR%%/images/tenttut/optionsedit.png
+%%WWWDIR%%/images/tenttut/quickedit.png
+%%WWWDIR%%/images/tenttut/stubmethedit.png
+%%WWWDIR%%/images/tenttut/tableedit.png
+%%WWWDIR%%/images/tenttut/tentopening.png
+%%WWWDIR%%/images/tlc-gray-block.gif
+%%WWWDIR%%/images/trc-gray-block.gif
+%%WWWDIR%%/js/datePicker.js
+%%WWWDIR%%/js/gantry-yui-calendar.js
+%%WWWDIR%%/js/gantry.js
+%%WWWDIR%%/js/jquery.js
+%%WWWDIR%%/login.tt
+%%WWWDIR%%/main.tt
+%%WWWDIR%%/moxie/delete.tt
+%%WWWDIR%%/moxie/form.tt
+%%WWWDIR%%/moxie/form_onetomany.tt
+%%WWWDIR%%/moxie/gantry_wrapper.tt
+%%WWWDIR%%/moxie/results.tt
+%%WWWDIR%%/moxie/threeway.tt
+%%WWWDIR%%/paging.ttc
+%%WWWDIR%%/pod.tt
+%%WWWDIR%%/pod_wrapper.tt
+%%WWWDIR%%/results.tt
+%%WWWDIR%%/sample_wrapper.tt
+%%WWWDIR%%/search.tt
+%%WWWDIR%%/sfbb/form.tt
+%%WWWDIR%%/threeway.tt
+%%WWWDIR%%/wrapper.tt
+%%WWWDIR%%/wsdl.tt
+%%WWWDIR%%/wsdldoc.tt
+%%WWWDIR%%/yapcna2007.pdf
+@dirrmtry %%WWWDIR%%/sfbb
+@dirrmtry %%WWWDIR%%/moxie
+@dirrmtry %%WWWDIR%%/js
+@dirrmtry %%WWWDIR%%/images/tenttut
+@dirrmtry %%WWWDIR%%/images
+@dirrmtry %%WWWDIR%%/css
+@dirrmtry %%WWWDIR%%
@dirrmtry %%SITE_PERL%%/Template/Plugin
@dirrmtry %%SITE_PERL%%/Template
@dirrmtry %%SITE_PERL%%/Gantry/Utils/Model