aboutsummaryrefslogtreecommitdiffstats
path: root/www/p5-HTML-Mason
diff options
context:
space:
mode:
authorflz <flz@FreeBSD.org>2005-11-30 19:11:49 +0800
committerflz <flz@FreeBSD.org>2005-11-30 19:11:49 +0800
commite079071fd40b1dbf1220f3e1f52b2a81e04baf5a (patch)
treefba9598d58bc856a6bfb8dd875da3fe58678084a /www/p5-HTML-Mason
parentd1d8973fd3430887de80e57692d2319371648af0 (diff)
downloadfreebsd-ports-gnome-e079071fd40b1dbf1220f3e1f52b2a81e04baf5a.tar.gz
freebsd-ports-gnome-e079071fd40b1dbf1220f3e1f52b2a81e04baf5a.tar.zst
freebsd-ports-gnome-e079071fd40b1dbf1220f3e1f52b2a81e04baf5a.zip
- Add a patch to fix UTF-8 strings escaping.
PR: ports/89750 Submitted by: maintainer
Diffstat (limited to 'www/p5-HTML-Mason')
-rw-r--r--www/p5-HTML-Mason/Makefile1
-rw-r--r--www/p5-HTML-Mason/distinfo1
-rw-r--r--www/p5-HTML-Mason/files/patch-Escapes.pm10
3 files changed, 12 insertions, 0 deletions
diff --git a/www/p5-HTML-Mason/Makefile b/www/p5-HTML-Mason/Makefile
index 0c91b4814427..7bf89286f10e 100644
--- a/www/p5-HTML-Mason/Makefile
+++ b/www/p5-HTML-Mason/Makefile
@@ -7,6 +7,7 @@
PORTNAME= HTML-Mason
PORTVERSION= 1.31.0.1
+PORTREVISION= 1
CATEGORIES= www perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= HTML
diff --git a/www/p5-HTML-Mason/distinfo b/www/p5-HTML-Mason/distinfo
index b5744fdcecce..b757e026ba2c 100644
--- a/www/p5-HTML-Mason/distinfo
+++ b/www/p5-HTML-Mason/distinfo
@@ -1,2 +1,3 @@
MD5 (HTML-Mason-1.3101.tar.gz) = 4904681296efeb9c58bf0d9926d37407
+SHA256 (HTML-Mason-1.3101.tar.gz) = 0837a43aa08f783b15d61f8068655564172588ceb9183608316291d258c104c7
SIZE (HTML-Mason-1.3101.tar.gz) = 386074
diff --git a/www/p5-HTML-Mason/files/patch-Escapes.pm b/www/p5-HTML-Mason/files/patch-Escapes.pm
new file mode 100644
index 000000000000..4e96c63d4d84
--- /dev/null
+++ b/www/p5-HTML-Mason/files/patch-Escapes.pm
@@ -0,0 +1,10 @@
+--- lib/HTML/Mason/Escapes.pm.orig Tue Aug 23 19:18:12 2005
++++ lib/HTML/Mason/Escapes.pm Wed Nov 30 12:10:55 2005
+@@ -37,6 +37,7 @@
+ {
+ return unless defined ${ $_[0] };
+
++ use bytes;
+ ${ $_[0] } =~ s/([^a-zA-Z0-9_.-])/uc sprintf("%%%02x",ord($1))/eg;
+ }
+