aboutsummaryrefslogtreecommitdiffstats
path: root/www/p5-HTML-Mason
diff options
context:
space:
mode:
authorwill <will@FreeBSD.org>2000-06-17 10:37:15 +0800
committerwill <will@FreeBSD.org>2000-06-17 10:37:15 +0800
commit6dd7168cddcf03645b7b524d0eaec762ba4a5c26 (patch)
treedde5ee054b255f449dc09b875bfef1cb678c4d3e /www/p5-HTML-Mason
parent09860925596143f36628cd7f462f54e90412d7ae (diff)
downloadfreebsd-ports-gnome-6dd7168cddcf03645b7b524d0eaec762ba4a5c26.tar.gz
freebsd-ports-gnome-6dd7168cddcf03645b7b524d0eaec762ba4a5c26.tar.zst
freebsd-ports-gnome-6dd7168cddcf03645b7b524d0eaec762ba4a5c26.zip
Lots and lots of cleanups. Teach p5-* in general about PKGNAMEPREFIX.
Add some missing/wrong dependencies. Show how to respect CC/CFLAGS. Many miscellaneous modifications. I used more excessive hacks to force p5-Jcode and p5-WWW-Search to respect CC/CFLAGS. Patches largely done by: Christian Weisgerber <naddy@mips.inka.de>
Diffstat (limited to 'www/p5-HTML-Mason')
-rw-r--r--www/p5-HTML-Mason/Makefile5
1 files changed, 2 insertions, 3 deletions
diff --git a/www/p5-HTML-Mason/Makefile b/www/p5-HTML-Mason/Makefile
index 63767b0d91d7..3996d54ff167 100644
--- a/www/p5-HTML-Mason/Makefile
+++ b/www/p5-HTML-Mason/Makefile
@@ -11,14 +11,13 @@ CATEGORIES= www perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= HTML
PKGNAMEPREFIX= p5-
-DISTNAME= ${PKGNAME:S/p5-//}
MAINTAINER= dsh@vlink.ru
RUN_DEPENDS= ${SITE_PERL}/MLDBM.pm:${PORTSDIR}/databases/p5-MLDBM
SITE_PERL= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/
-USE_PERL5= YES
+USE_PERL5= yes
MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
MAN3= Bundle::HTML::Mason.3 HTML::Mason.3 HTML::Mason::Admin.3 \
@@ -28,6 +27,6 @@ MAN3= Bundle::HTML::Mason.3 HTML::Mason.3 HTML::Mason::Admin.3 \
HTML::Mason::Parser.3 HTML::Mason::Request.3
do-configure:
- @cd ${WRKSRC}; ${SETENV} ${CONFIGURE_ENV} ${PERL5} Makefile.PL
+ @cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PERL5} Makefile.PL
.include <bsd.port.mk>