aboutsummaryrefslogtreecommitdiffstats
path: root/www/p5-HTML-Webmake/Makefile
diff options
context:
space:
mode:
authorjkoshy <jkoshy@FreeBSD.org>2002-06-27 15:46:35 +0800
committerjkoshy <jkoshy@FreeBSD.org>2002-06-27 15:46:35 +0800
commit715b1d2baa10096210d4a860d33476a0f50ce182 (patch)
treed0a1cfdbe989ce81f16856a4cb29d02faf7c96c7 /www/p5-HTML-Webmake/Makefile
parentffd132af8b3e6e10d5e2a8c2ddc465bdb1d53768 (diff)
downloadfreebsd-ports-gnome-715b1d2baa10096210d4a860d33476a0f50ce182.tar.gz
freebsd-ports-gnome-715b1d2baa10096210d4a860d33476a0f50ce182.tar.zst
freebsd-ports-gnome-715b1d2baa10096210d4a860d33476a0f50ce182.zip
`p5-HTML-WebMake', a perl based website management tool.
Diffstat (limited to 'www/p5-HTML-Webmake/Makefile')
-rw-r--r--www/p5-HTML-Webmake/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/www/p5-HTML-Webmake/Makefile b/www/p5-HTML-Webmake/Makefile
new file mode 100644
index 000000000000..90d8d5315228
--- /dev/null
+++ b/www/p5-HTML-Webmake/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: p5-HTML-Parser
+# Date created: 21 June 2002
+# Whom: Joseph Koshy <jkoshy@freebsd.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= HTML-WebMake
+PORTVERSION= 2.3
+CATEGORIES= www perl5
+MASTER_SITES= http://webmake.sourceforge.net/devel/ \
+ http://webmake.taint.org/devel/
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= jkoshy@FreeBSD.org
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/HTML/Parser.pm:${PORTSDIR}/www/p5-HTML-Parser \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Text/EtText.pm:${PORTSDIR}/textproc/p5-Text-EtText \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/IO/String.pm:${PORTSDIR}/devel/p5-IO-String \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/XML/Sablotron.pm:${PORTSDIR}/textproc/p5-XML-Sablotron
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN1= webmake.1
+MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= HTML::WebMake.3 HTML::WebMake::PerlCodeLibrary.3 \
+ HTML::WebMake::Content.3 HTML::WebMake::Main.3
+
+.include <bsd.port.mk>