aboutsummaryrefslogtreecommitdiffstats
path: root/www/p5-HTTP-Server-Simple-PSGI
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2010-03-21 02:58:28 +0800
committermiwi <miwi@FreeBSD.org>2010-03-21 02:58:28 +0800
commit056e3327552b97cd90919f24bc6db317d060e7db (patch)
treeb6d4becc38e79ed1501eebdd17b7ba33d19088ee /www/p5-HTTP-Server-Simple-PSGI
parenta8732cf2620712ba8de3bae0bb44c00b41a0bf69 (diff)
downloadfreebsd-ports-gnome-056e3327552b97cd90919f24bc6db317d060e7db.tar.gz
freebsd-ports-gnome-056e3327552b97cd90919f24bc6db317d060e7db.tar.zst
freebsd-ports-gnome-056e3327552b97cd90919f24bc6db317d060e7db.zip
HTTP::Server::Simple::PSGI is a HTTP::Server::Simple based HTTP server
that can run PSGI applications. This module only depends on HTTP::Server::Simple, which itself doesn't depend on any non-core modules so it's best to be used as an embedded web server. WWW: http://search.cpan.org/dist/HTTP-Server-Simple-PSGI/ PR: ports/144795 Submitted by: ports at c0decafe.net
Diffstat (limited to 'www/p5-HTTP-Server-Simple-PSGI')
-rw-r--r--www/p5-HTTP-Server-Simple-PSGI/Makefile24
-rw-r--r--www/p5-HTTP-Server-Simple-PSGI/distinfo3
-rw-r--r--www/p5-HTTP-Server-Simple-PSGI/pkg-descr6
-rw-r--r--www/p5-HTTP-Server-Simple-PSGI/pkg-plist9
4 files changed, 42 insertions, 0 deletions
diff --git a/www/p5-HTTP-Server-Simple-PSGI/Makefile b/www/p5-HTTP-Server-Simple-PSGI/Makefile
new file mode 100644
index 000000000000..5472c5700441
--- /dev/null
+++ b/www/p5-HTTP-Server-Simple-PSGI/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: p5-HTTP-Server-Simple-PSGI
+# Date created: 2010-03-16
+# Whom: ports@c0decafe.net
+#
+# $FreeBSD$
+#
+
+PORTNAME= HTTP-Server-Simple-PSGI
+PORTVERSION= 0.14
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= ports@c0decafe.net
+COMMENT= PSGI handler for HTTP::Server::Simple
+
+RUN_DEPENDS= ${SITE_PERL}/HTTP/Server/Simple.pm:${PORTSDIR}/www/p5-HTTP-Server-Simple
+
+USE_PERL5= YES
+PERL_CONFIGURE= YES
+
+MAN3= HTTP::Server::Simple::PSGI.3
+
+.include <bsd.port.mk>
diff --git a/www/p5-HTTP-Server-Simple-PSGI/distinfo b/www/p5-HTTP-Server-Simple-PSGI/distinfo
new file mode 100644
index 000000000000..f6d328d02181
--- /dev/null
+++ b/www/p5-HTTP-Server-Simple-PSGI/distinfo
@@ -0,0 +1,3 @@
+MD5 (HTTP-Server-Simple-PSGI-0.14.tar.gz) = c26795112c9f616dbd37ece1c5895b55
+SHA256 (HTTP-Server-Simple-PSGI-0.14.tar.gz) = 44c25aeb1923728ee011889fe73be56838e60249c0938a5b7a94e51d79900a51
+SIZE (HTTP-Server-Simple-PSGI-0.14.tar.gz) = 3890
diff --git a/www/p5-HTTP-Server-Simple-PSGI/pkg-descr b/www/p5-HTTP-Server-Simple-PSGI/pkg-descr
new file mode 100644
index 000000000000..4d05db5f9a6b
--- /dev/null
+++ b/www/p5-HTTP-Server-Simple-PSGI/pkg-descr
@@ -0,0 +1,6 @@
+HTTP::Server::Simple::PSGI is a HTTP::Server::Simple based HTTP server
+that can run PSGI applications. This module only depends on
+HTTP::Server::Simple, which itself doesn't depend on any non-core
+modules so it's best to be used as an embedded web server.
+
+WWW: http://search.cpan.org/dist/HTTP-Server-Simple-PSGI/
diff --git a/www/p5-HTTP-Server-Simple-PSGI/pkg-plist b/www/p5-HTTP-Server-Simple-PSGI/pkg-plist
new file mode 100644
index 000000000000..e45f64dd201c
--- /dev/null
+++ b/www/p5-HTTP-Server-Simple-PSGI/pkg-plist
@@ -0,0 +1,9 @@
+%%SITE_PERL%%/HTTP/Server/Simple/PSGI.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/HTTP/Server/Simple/PSGI/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/HTTP/Server/Simple/PSGI
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/HTTP/Server/Simple
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/HTTP/Server
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/HTTP
+@dirrmtry %%SITE_PERL%%/HTTP/Server/Simple
+@dirrmtry %%SITE_PERL%%/HTTP/Server
+@dirrmtry %%SITE_PERL%%/HTTP