aboutsummaryrefslogtreecommitdiffstats
path: root/www/p5-HTTP-Size
diff options
context:
space:
mode:
authoraaron <aaron@FreeBSD.org>2006-06-19 15:23:57 +0800
committeraaron <aaron@FreeBSD.org>2006-06-19 15:23:57 +0800
commit7dbd2f0786d038d1ae1896008227f1163f5b53d7 (patch)
treea2c2dad723982469f27eb66e8ae7b2a7dc69ab73 /www/p5-HTTP-Size
parent06562c718c2dcb58003d886d1f858623d1cc40bc (diff)
downloadfreebsd-ports-gnome-7dbd2f0786d038d1ae1896008227f1163f5b53d7.tar.gz
freebsd-ports-gnome-7dbd2f0786d038d1ae1896008227f1163f5b53d7.tar.zst
freebsd-ports-gnome-7dbd2f0786d038d1ae1896008227f1163f5b53d7.zip
Adding port www/p5-HTTP-Size, Get the byte size of an internet resource.
Approved by: tobez (implicit)
Diffstat (limited to 'www/p5-HTTP-Size')
-rw-r--r--www/p5-HTTP-Size/Makefile33
-rw-r--r--www/p5-HTTP-Size/distinfo3
-rw-r--r--www/p5-HTTP-Size/pkg-descr4
-rw-r--r--www/p5-HTTP-Size/pkg-plist5
4 files changed, 45 insertions, 0 deletions
diff --git a/www/p5-HTTP-Size/Makefile b/www/p5-HTTP-Size/Makefile
new file mode 100644
index 000000000000..d372ab33b79b
--- /dev/null
+++ b/www/p5-HTTP-Size/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: p5-HTTP-Size
+# Date created: 19 Jun 2006
+# Whom: Aaron Dalton <aaron@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= HTTP-Size
+PORTVERSION= 1.11
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= HTTP
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= aaron@FreeBSD.org
+COMMENT= Get the byte size of an internet resource
+
+BUILD_DEPENDS= p5-libwww>0:${PORTSDIR}/www/p5-libwww \
+ p5-URI>0:${PORTSDIR}/net/p5-URI \
+ p5-HTML-SimpleLinkExtor>0:${PORTSDIR}/www/p5-HTML-SimpleLinkExtor
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+MAN3= HTTP::Size.3
+
+PERL_CONFIGURE= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600 # inherited from p5-libwww
+IGNORE= requires at least Perl 5.6. Please install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/www/p5-HTTP-Size/distinfo b/www/p5-HTTP-Size/distinfo
new file mode 100644
index 000000000000..140a7f5aaa08
--- /dev/null
+++ b/www/p5-HTTP-Size/distinfo
@@ -0,0 +1,3 @@
+MD5 (HTTP-Size-1.11.tar.gz) = 3b5e368c0f9b08285ad92cc86e60b50d
+SHA256 (HTTP-Size-1.11.tar.gz) = 6d3faabc2f682b50a11ab2db6150e105e41d8b3471075d397ae05cb8b7111caf
+SIZE (HTTP-Size-1.11.tar.gz) = 25680
diff --git a/www/p5-HTTP-Size/pkg-descr b/www/p5-HTTP-Size/pkg-descr
new file mode 100644
index 000000000000..ea8640777efa
--- /dev/null
+++ b/www/p5-HTTP-Size/pkg-descr
@@ -0,0 +1,4 @@
+Gets the byte size of an internet resource.
+
+WWW: http://search.cpan.org/dist/HTTP-Size
+Author: brian d foy <bdfoy@cpan.org>
diff --git a/www/p5-HTTP-Size/pkg-plist b/www/p5-HTTP-Size/pkg-plist
new file mode 100644
index 000000000000..f26e0de22481
--- /dev/null
+++ b/www/p5-HTTP-Size/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/HTTP/Size.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/HTTP/Size/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/HTTP/Size
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/HTTP
+@dirrmtry %%SITE_PERL%%/HTTP