aboutsummaryrefslogtreecommitdiffstats
path: root/www/p5-Handel
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2008-01-10 20:00:10 +0800
committermiwi <miwi@FreeBSD.org>2008-01-10 20:00:10 +0800
commitfd5b7c3a2ff09b3b47ed4f669c9379ba77af759c (patch)
tree61ff081d76100ee08943746402d4e5421f926fb1 /www/p5-Handel
parent6aeeb00da95b08ef321fe31146bebd95c84df33c (diff)
downloadfreebsd-ports-gnome-fd5b7c3a2ff09b3b47ed4f669c9379ba77af759c.tar.gz
freebsd-ports-gnome-fd5b7c3a2ff09b3b47ed4f669c9379ba77af759c.tar.zst
freebsd-ports-gnome-fd5b7c3a2ff09b3b47ed4f669c9379ba77af759c.zip
- Update to 1.00007
PR: 119340 Submitted by: hideo <hideo@lastamericanempire.com> (maintainer)
Diffstat (limited to 'www/p5-Handel')
-rw-r--r--www/p5-Handel/Makefile95
-rw-r--r--www/p5-Handel/distinfo6
-rw-r--r--www/p5-Handel/pkg-plist64
3 files changed, 128 insertions, 37 deletions
diff --git a/www/p5-Handel/Makefile b/www/p5-Handel/Makefile
index fb9f4825a069..46e2789192ef 100644
--- a/www/p5-Handel/Makefile
+++ b/www/p5-Handel/Makefile
@@ -6,46 +6,44 @@
#
PORTNAME= Handel
-PORTVERSION= 0.33
+PORTVERSION= 1.00007
CATEGORIES= www perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= Template
PKGNAMEPREFIX= p5-
MAINTAINER= hideo@lastamericanempire.com
-COMMENT= Simple commerce framework with AxKit/TT/Catalyst support
+COMMENT= Simple ecommerce framework with AxKit/Catalyst support
-BUILD_DEPENDS= ${SITE_PERL}/Test/Strict.pm:${PORTSDIR}/devel/p5-Test-Strict \
- ${SITE_PERL}/Path/Class.pm:${PORTSDIR}/devel/p5-Path-Class \
+BUILD_DEPENDS= ${SITE_PERL}/Error.pm:${PORTSDIR}/lang/p5-Error \
${SITE_PERL}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple \
- ${SITE_PERL}/Pod/Coverage.pm:${PORTSDIR}/devel/p5-Pod-Coverage \
- ${SITE_PERL}/Test/Pod.pm:${PORTSDIR}/devel/p5-Test-Pod \
- ${SITE_PERL}/Test/Pod/Coverage.pm:${PORTSDIR}/devel/p5-Test-Pod-Coverage \
- ${SITE_PERL}/Error.pm:${PORTSDIR}/lang/p5-Error \
- ${SITE_PERL}/${PERL_ARCH}/Data/UUID.pm:${PORTSDIR}/devel/p5-Data-UUID \
- ${SITE_PERL}/Class/DBI.pm:${PORTSDIR}/databases/p5-Class-DBI \
${SITE_PERL}/Locale/Maketext.pm:${PORTSDIR}/devel/p5-Locale-Maketext \
- ${SITE_PERL}/Module/Pluggable.pm:${PORTSDIR}/devel/p5-Module-Pluggable
-RUN_DEPENDS= ${SITE_PERL}/Error.pm:${PORTSDIR}/lang/p5-Error \
${SITE_PERL}/Module/Pluggable.pm:${PORTSDIR}/devel/p5-Module-Pluggable \
- ${SITE_PERL}/${PERL_ARCH}/Data/UUID.pm:${PORTSDIR}/devel/p5-Data-UUID \
- ${SITE_PERL}/Class/DBI.pm:${PORTSDIR}/databases/p5-Class-DBI \
- ${SITE_PERL}/Locale/Maketext.pm:${PORTSDIR}/devel/p5-Locale-Maketext
+ ${SITE_PERL}/Class/Accessor/Grouped.pm:${PORTSDIR}/devel/p5-Class-Accessor-Grouped \
+ ${SITE_PERL}/Data/Currency.pm:${PORTSDIR}/finance/p5-Data-Currency \
+ ${SITE_PERL}/${PERL_ARCH}/DBD/SQLite.pm:${PORTSDIR}/databases/p5-DBD-SQLite \
+ ${SITE_PERL}/DBIx/Class/UUIDColumns.pm:${PORTSDIR}/databases/p5-DBIx-Class-UUIDColumns \
+ ${SITE_PERL}/DBIx/Class/Validation.pm:${PORTSDIR}/databases/p5-DBIx-Class-Validation \
+ ${SITE_PERL}/SQL/Translator.pm:${PORTSDIR}/databases/p5-SQL-Translator \
+ ${SITE_PERL}/Finance/Currency/Convert/WebserviceX.pm:${PORTSDIR}/finance/p5-Finance-Currency-Convert-WebserviceX \
+ ${SITE_PERL}/DateTime/Format/MySQL.pm:${PORTSDIR}/devel/p5-DateTime-Format-MySQL \
+ ${SITE_PERL}/Module/Starter.pm:${PORTSDIR}/devel/p5-Module-Starter \
+ ${SITE_PERL}/FormValidator/Simple.pm:${PORTSDIR}/textproc/p5-FormValidator-Simple \
+ ${SITE_PERL}/Locale/Currency/Format.pm:${PORTSDIR}/finance/p5-Locale-Currency-Format \
+ ${SITE_PERL}/${PERL_ARCH}/Clone.pm:${PORTSDIR}/devel/p5-Clone
+RUN_DEPENDS= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
-OPTIONS=CURRENCY_FORMAT "Currency formatting support" off \
- WEBSERVICEX "WebserviceX currency conversion support" off \
- CURRENCY_CODE "ISO currency code verification support" off \
-
+MAN1= handel.pl.1
MAN3= Handel::Iterator.3 \
- Handel::DBI.3 \
Template::Plugin::Handel::Order.3 \
Template::Plugin::Handel::Checkout.3 \
Catalyst::Helper::Controller::Handel::Checkout.3 \
AxKit::XSP::Handel::Checkout.3 \
Handel::Checkout.3 \
Handel::Constants.3 \
+ Handel::L10N::bg.3 \
Handel::L10N::fr.3 \
Handel::L10N::en_us.3 \
Handel::Checkout::Message.3 \
@@ -58,7 +56,6 @@ MAN3= Handel::Iterator.3 \
Catalyst::Helper::Controller::Handel::Order.3 \
Catalyst::Helper::Model::Handel::Order.3 \
Handel::Checkout::Plugin::AssignOrderNumber.3 \
- Handel::L10N::zh_tw.3 \
Catalyst::Helper::Controller::Handel::Cart.3 \
Template::Plugin::Handel::Cart.3 \
Handel::Exception.3 \
@@ -72,20 +69,56 @@ MAN3= Handel::Iterator.3 \
Handel::ConfigReader.3 \
Handel::Order.3 \
Handel::Currency.3 \
- Handel::Cart::Item.3
+ Handel::Cart::Item.3 \
+ Handel::Storage::DBIC::Cart.3 \
+ Handel::Storage::DBIC::Result.3 \
+ Handel::Components::DefaultValues.3 \
+ Handel::Schema::DBIC::Order.3 \
+ Handel::Cart::Schema.3 \
+ Handel::Manual::QuickStart.3 \
+ Handel::Manual::Intro.3 \
+ Handel::Storage::DBIC.3 \
+ Handel::Manual::Cookbook.3 \
+ Handel::Compat::Currency.3 \
+ Handel::Manual::Requirements.3 \
+ Handel::Schema::DBIC::Cart.3 \
+ Handel::Storage::DBIC::Cart::Item.3 \
+ Handel::Manual.3 \
+ Handel::Iterator::Results.3 \
+ Handel::Iterator::List.3 \
+ Handel::Manual::Storage::DBIC.3 \
+ Handel::Manual::Cookbook::AddingColumns.3 \
+ Handel::Schema::DBIC::Cart::Item.3 \
+ Handel::Compat.3 \
+ Handel::Manual::Storage.3 \
+ Handel::Components::Validation.3 \
+ Module::Starter::Handel.3 \
+ Catalyst::Helper::Handel.3 \
+ Handel::Order::Schema.3 \
+ Handel::Base.3 \
+ Handel::Manual::Schema.3 \
+ Handel::Manual::KnownIssues.3 \
+ Handel::Storage::DBIC::Order::Item.3 \
+ Handel::Schema::DBIC::Order::Item.3 \
+ Handel::Storage::Result.3 \
+ Catalyst::Model::Handel::Cart.3 \
+ Catalyst::Model::Handel::Order.3 \
+ Handel::Components::Constraints.3 \
+ Handel::Storage::DBIC::Order.3 \
+ Handel::Manual::Upgrading.3 \
+ Handel::Storage.3 \
+ Handel::Manual::Cookbook::WritingCustomStorage.3 \
+ Handel::Schema.3 \
+ Handel::Iterator::DBIC.3 \
+ Handel::Manual::About.3
.include <bsd.port.pre.mk>
-.if defined(WITH_CURRENCY_FORMAT)
-RUN_DEPENDS+= ${SITE_PERL}/Locale/Currency/Format.pm:${PORTSDIR}/finance/p5-Locale-Currency-Format
-.endif
-
-.if defined(WITH_WEBSERVICEX)
-RUN_DEPENDS+= ${SITE_PERL}/Finance/Currency/Convert/WebserviceX.pm:${PORTSDIR}/finance/p5-Finance-Currency-Convert-WebserviceX
-.endif
+post-extract:
+ @${PERL} -pi -e '$$_ = undef if /^auto_install/' ${WRKSRC}/Makefile.PL
-.if defined(WITH_CURRENCY_CODE)
-RUN_DEPENDS+= ${SITE_PERL}/Locale/Currency.pm:${PORTSDIR}/misc/p5-Locale-Codes
+.if ${PERL_LEVEL} < 500600
+IGNORE= perl 5.6 or newer required. Install lang/perl5.8 or lang/perl5 and try again
.endif
.include <bsd.port.post.mk>
diff --git a/www/p5-Handel/distinfo b/www/p5-Handel/distinfo
index da62f2931be6..642c2f5336c7 100644
--- a/www/p5-Handel/distinfo
+++ b/www/p5-Handel/distinfo
@@ -1,3 +1,3 @@
-MD5 (Handel-0.33.tar.gz) = f80debafb5974363cece303a45d2f80a
-SHA256 (Handel-0.33.tar.gz) = bcca4c505401e14be22846b91454c02dc358fbda9a3957e89ef44a27c75c7ba0
-SIZE (Handel-0.33.tar.gz) = 180337
+MD5 (Handel-1.00007.tar.gz) = 8483c0599e06ceeeeaa471cb8f53086b
+SHA256 (Handel-1.00007.tar.gz) = 480e6d1e6dd79860a718a2f541000e856989d071f445db97b1b79a6229d2f75a
+SIZE (Handel-1.00007.tar.gz) = 308892
diff --git a/www/p5-Handel/pkg-plist b/www/p5-Handel/pkg-plist
index 0cdade859bbb..9ac54e95c815 100644
--- a/www/p5-Handel/pkg-plist
+++ b/www/p5-Handel/pkg-plist
@@ -1,11 +1,12 @@
+bin/handel.pl
%%SITE_PERL%%/Handel/Iterator.pm
-%%SITE_PERL%%/Handel/DBI.pm
%%SITE_PERL%%/Template/Plugin/Handel/Checkout.pm
%%SITE_PERL%%/Template/Plugin/Handel/Order.pm
%%SITE_PERL%%/Catalyst/Helper/Controller/Handel/Checkout.pm
%%SITE_PERL%%/AxKit/XSP/Handel/Checkout.pm
%%SITE_PERL%%/Handel/Checkout.pm
%%SITE_PERL%%/Handel/Constants.pm
+%%SITE_PERL%%/Handel/L10N/bg.pm
%%SITE_PERL%%/Handel/L10N/fr.pm
%%SITE_PERL%%/Handel/L10N/en_us.pm
%%SITE_PERL%%/Handel/Checkout/Message.pm
@@ -18,7 +19,6 @@
%%SITE_PERL%%/Catalyst/Helper/Model/Handel/Order.pm
%%SITE_PERL%%/Catalyst/Helper/Controller/Handel/Order.pm
%%SITE_PERL%%/Handel/Checkout/Plugin/AssignOrderNumber.pm
-%%SITE_PERL%%/Handel/L10N/zh_tw.pm
%%SITE_PERL%%/Catalyst/Helper/Controller/Handel/Cart.pm
%%SITE_PERL%%/Template/Plugin/Handel/Cart.pm
%%SITE_PERL%%/Handel/Exception.pm
@@ -34,6 +34,47 @@
%%SITE_PERL%%/Handel/Currency.pm
%%SITE_PERL%%/Handel/Cart/Item.pm
%%SITE_PERL%%/%%PERL_ARCH%%/auto/Handel/.packlist
+%%SITE_PERL%%/Handel/Manual.pod
+%%SITE_PERL%%/Handel/Compat.pm
+%%SITE_PERL%%/Handel/Base.pm
+%%SITE_PERL%%/Handel/Storage.pm
+%%SITE_PERL%%/Handel/Schema.pm
+%%SITE_PERL%%/Handel/Storage/DBIC.pm
+%%SITE_PERL%%/Handel/Storage/Result.pm
+%%SITE_PERL%%/Handel/Storage/DBIC/Cart.pm
+%%SITE_PERL%%/Handel/Storage/DBIC/Result.pm
+%%SITE_PERL%%/Handel/Storage/DBIC/Order.pm
+%%SITE_PERL%%/Handel/Storage/DBIC/Cart/Item.pm
+%%SITE_PERL%%/Handel/Storage/DBIC/Order/Item.pm
+%%SITE_PERL%%/Handel/Components/DefaultValues.pm
+%%SITE_PERL%%/Handel/Components/Validation.pm
+%%SITE_PERL%%/Handel/Components/Constraints.pm
+%%SITE_PERL%%/Handel/Schema/DBIC/Order.pm
+%%SITE_PERL%%/Handel/Schema/DBIC/Cart.pm
+%%SITE_PERL%%/Handel/Schema/DBIC/Cart/Item.pm
+%%SITE_PERL%%/Handel/Schema/DBIC/Order/Item.pm
+%%SITE_PERL%%/Handel/Cart/Schema.pm
+%%SITE_PERL%%/Handel/Manual/QuickStart.pod
+%%SITE_PERL%%/Handel/Manual/Intro.pod
+%%SITE_PERL%%/Handel/Manual/Cookbook.pod
+%%SITE_PERL%%/Handel/Manual/Requirements.pod
+%%SITE_PERL%%/Handel/Manual/Storage.pod
+%%SITE_PERL%%/Handel/Manual/Schema.pod
+%%SITE_PERL%%/Handel/Manual/KnownIssues.pod
+%%SITE_PERL%%/Handel/Manual/Upgrading.pod
+%%SITE_PERL%%/Handel/Manual/About.pod
+%%SITE_PERL%%/Handel/Manual/Storage/DBIC.pod
+%%SITE_PERL%%/Handel/Manual/Cookbook/AddingColumns.pod
+%%SITE_PERL%%/Handel/Manual/Cookbook/WritingCustomStorage.pod
+%%SITE_PERL%%/Handel/Compat/Currency.pm
+%%SITE_PERL%%/Handel/Iterator/Results.pm
+%%SITE_PERL%%/Handel/Iterator/List.pm
+%%SITE_PERL%%/Handel/Iterator/DBIC.pm
+%%SITE_PERL%%/Handel/Order/Schema.pm
+%%SITE_PERL%%/Catalyst/Helper/Handel.pm
+%%SITE_PERL%%/Catalyst/Model/Handel/Cart.pm
+%%SITE_PERL%%/Catalyst/Model/Handel/Order.pm
+%%SITE_PERL%%/Module/Starter/Handel.pm
@dirrm %%SITE_PERL%%/Template/Plugin/Handel
@dirrm %%SITE_PERL%%/Catalyst/Helper/Controller/Handel
@dirrm %%SITE_PERL%%/AxKit/XSP/Handel
@@ -44,8 +85,25 @@
@dirrm %%SITE_PERL%%/Handel/Checkout
@dirrm %%SITE_PERL%%/Handel/L10N
@dirrm %%SITE_PERL%%/Handel/Order
-@dirrm %%SITE_PERL%%/Handel
@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Handel
+@dirrm %%SITE_PERL%%/Module/Starter
+@dirrm %%SITE_PERL%%/Handel/Storage/DBIC/Order
+@dirrm %%SITE_PERL%%/Handel/Storage/DBIC/Cart
+@dirrm %%SITE_PERL%%/Handel/Storage/DBIC
+@dirrm %%SITE_PERL%%/Handel/Storage
+@dirrm %%SITE_PERL%%/Handel/Schema/DBIC/Order
+@dirrm %%SITE_PERL%%/Handel/Schema/DBIC/Cart
+@dirrm %%SITE_PERL%%/Handel/Schema/DBIC
+@dirrm %%SITE_PERL%%/Handel/Schema
+@dirrm %%SITE_PERL%%/Handel/Manual/Storage
+@dirrm %%SITE_PERL%%/Handel/Manual/Cookbook
+@dirrm %%SITE_PERL%%/Handel/Manual
+@dirrm %%SITE_PERL%%/Handel/Iterator
+@dirrm %%SITE_PERL%%/Handel/Components
+@dirrm %%SITE_PERL%%/Handel/Compat
+@dirrm %%SITE_PERL%%/Handel
+@dirrm %%SITE_PERL%%/Catalyst/Model/Handel
+@dirrmtry %%SITE_PERL%%/Catalyst/Model
@dirrmtry %%SITE_PERL%%/Template/Plugin
@dirrmtry %%SITE_PERL%%/Template
@dirrmtry %%SITE_PERL%%/Catalyst/Helper/Controller