aboutsummaryrefslogtreecommitdiffstats
path: root/www/p5-MasonX-Interp-WithCallbacks/Makefile
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2004-05-25 16:47:41 +0800
committermat <mat@FreeBSD.org>2004-05-25 16:47:41 +0800
commitd0ece724af1419c09f46fe047310861c9ffb7db7 (patch)
tree24b3a3ab0fc2b91e366025c6d336db68e2b6370b /www/p5-MasonX-Interp-WithCallbacks/Makefile
parent482c0c0c01b4dc4439976a564dbc24bb6df5cd48 (diff)
downloadfreebsd-ports-gnome-d0ece724af1419c09f46fe047310861c9ffb7db7.tar.gz
freebsd-ports-gnome-d0ece724af1419c09f46fe047310861c9ffb7db7.tar.zst
freebsd-ports-gnome-d0ece724af1419c09f46fe047310861c9ffb7db7.zip
Add p5-MasonX-Interp-WithCallbacks 1.11, mason callback support via
Params::CallbackRequest. PR: ports/67023 Submitted by: Rod Taylor <ports@rbt.ca>
Diffstat (limited to 'www/p5-MasonX-Interp-WithCallbacks/Makefile')
-rw-r--r--www/p5-MasonX-Interp-WithCallbacks/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/www/p5-MasonX-Interp-WithCallbacks/Makefile b/www/p5-MasonX-Interp-WithCallbacks/Makefile
new file mode 100644
index 000000000000..72165558c74e
--- /dev/null
+++ b/www/p5-MasonX-Interp-WithCallbacks/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: p5-MasonX-Interp-WithCallbacks
+# Date created: May 21, 2004
+# Whom: Rod Taylor <ports@rbt.ca>
+#
+# $FreeBSD$
+#
+
+PORTNAME= MasonX-Interp-WithCallbacks
+PORTVERSION= 1.11
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= MasonX/DWHEELER
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= ports@rbt.ca
+COMMENT= Mason callback support via Params::CallbackRequest
+
+BUILD_DEPENDS= ${SITE_PERL}/HTML/Mason.pm:${PORTSDIR}/www/p5-HTML-Mason \
+ ${SITE_PERL}/Params/CallbackRequest.pm:${PORTSDIR}/devel/p5-Params-CallbackRequest
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= MasonX::Interp::WithCallbacks.3
+
+.include <bsd.port.mk>