aboutsummaryrefslogtreecommitdiffstats
path: root/www/p5-POE-Component-Server-HTTPServer
diff options
context:
space:
mode:
authorlth <lth@FreeBSD.org>2005-09-16 02:40:34 +0800
committerlth <lth@FreeBSD.org>2005-09-16 02:40:34 +0800
commit0b24903f9ef25690fb8e677fe14ed32de33fa61e (patch)
tree1379277162c828165085dcd09b0dd45367c8d7a5 /www/p5-POE-Component-Server-HTTPServer
parent5bdd768de87c0e997ff10a23756383ef1fa7217b (diff)
downloadfreebsd-ports-gnome-0b24903f9ef25690fb8e677fe14ed32de33fa61e.tar.gz
freebsd-ports-gnome-0b24903f9ef25690fb8e677fe14ed32de33fa61e.tar.zst
freebsd-ports-gnome-0b24903f9ef25690fb8e677fe14ed32de33fa61e.zip
Add p5-POE-Component-Server-HTTPServer 0.9.2, POE Component to server
HTTP requests. PR: ports/77980 Submitted by: Zach Thompson <lin-chi@lastamericanempire.com>
Diffstat (limited to 'www/p5-POE-Component-Server-HTTPServer')
-rw-r--r--www/p5-POE-Component-Server-HTTPServer/Makefile43
-rw-r--r--www/p5-POE-Component-Server-HTTPServer/distinfo2
-rw-r--r--www/p5-POE-Component-Server-HTTPServer/pkg-descr9
-rw-r--r--www/p5-POE-Component-Server-HTTPServer/pkg-plist17
4 files changed, 71 insertions, 0 deletions
diff --git a/www/p5-POE-Component-Server-HTTPServer/Makefile b/www/p5-POE-Component-Server-HTTPServer/Makefile
new file mode 100644
index 000000000000..5fd3e43ec94c
--- /dev/null
+++ b/www/p5-POE-Component-Server-HTTPServer/Makefile
@@ -0,0 +1,43 @@
+# New ports collection makefile for: POE-Component-Server-HTTPServer
+# Date created: 23 Feb 2005
+# Whom: Zach Thompson <lin-chi@lastamericanempire.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= POE-Component-Server-HTTPServer
+PORTVERSION= 0.9.2
+CATEGORIES= www devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= POE
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= lin-chi@lastamericanempire.com
+COMMENT= POE Component to server HTTP requests
+
+BUILD_DEPENDS= ${SITE_PERL}/POE.pm:${PORTSDIR}/devel/p5-POE \
+ ${SITE_PERL}/HTTP/Message.pm:${PORTSDIR}/www/p5-libwww \
+ ${SITE_PERL}/HTTP/Status.pm:${PORTSDIR}/www/p5-libwww \
+ ${SITE_PERL}/URI/Escape.pm:${PORTSDIR}/www/p5-libwww \
+ ${SITE_PERL}/HTML/Template/HashWrapper.pm:${PORTSDIR}/www/p5-HTML-Template-HashWrapper \
+ ${SITE_PERL}/MIME/Types.pm:${PORTSDIR}/mail/p5-MIME-Types
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= POE::Component::Server::HTTPServer.3 \
+ POE::Component::Server::HTTPServer::BasicAuthenHandler.3 \
+ POE::Component::Server::HTTPServer::Examples.3 \
+ POE::Component::Server::HTTPServer::Handler.3 \
+ POE::Component::Server::HTTPServer::NotFoundHandler.3 \
+ POE::Component::Server::HTTPServer::ParameterParseHandler.3 \
+ POE::Component::Server::HTTPServer::StaticHandler.3 \
+ POE::Component::Server::HTTPServer::TemplateHandler.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+IGNORE= requires perl 5.8.x or later. Install lang/perl5.8 then try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/www/p5-POE-Component-Server-HTTPServer/distinfo b/www/p5-POE-Component-Server-HTTPServer/distinfo
new file mode 100644
index 000000000000..f256c47e7ee8
--- /dev/null
+++ b/www/p5-POE-Component-Server-HTTPServer/distinfo
@@ -0,0 +1,2 @@
+MD5 (POE-Component-Server-HTTPServer-0.9.2.tar.gz) = 766c06301099868fca4bbc8bd5cb358d
+SIZE (POE-Component-Server-HTTPServer-0.9.2.tar.gz) = 15389
diff --git a/www/p5-POE-Component-Server-HTTPServer/pkg-descr b/www/p5-POE-Component-Server-HTTPServer/pkg-descr
new file mode 100644
index 000000000000..d940cd92b53d
--- /dev/null
+++ b/www/p5-POE-Component-Server-HTTPServer/pkg-descr
@@ -0,0 +1,9 @@
+POE component to serve HTTP requests with a slightly different
+approach than POCo::Server::HTTP. Several useful built-in
+handlers for URIs not found, basic authentication, and
+parameter parsing.
+
+WWW: http://search.cpan.org/dist/POE-Component-Server-HTTPServer/
+
+- Zach Thompson
+lin-chi@lastamericanempire.com
diff --git a/www/p5-POE-Component-Server-HTTPServer/pkg-plist b/www/p5-POE-Component-Server-HTTPServer/pkg-plist
new file mode 100644
index 000000000000..b8454721da28
--- /dev/null
+++ b/www/p5-POE-Component-Server-HTTPServer/pkg-plist
@@ -0,0 +1,17 @@
+%%SITE_PERL%%/POE/Component/Server/HTTPServer.pm
+%%SITE_PERL%%/POE/Component/Server/HTTPServer/BasicAuthenHandler.pm
+%%SITE_PERL%%/POE/Component/Server/HTTPServer/Examples.pod
+%%SITE_PERL%%/POE/Component/Server/HTTPServer/Handler.pm
+%%SITE_PERL%%/POE/Component/Server/HTTPServer/NotFoundHandler.pm
+%%SITE_PERL%%/POE/Component/Server/HTTPServer/ParameterParseHandler.pm
+%%SITE_PERL%%/POE/Component/Server/HTTPServer/StaticHandler.pm
+%%SITE_PERL%%/POE/Component/Server/HTTPServer/TemplateHandler.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/Component/Server/HTTPServer/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/Component/Server/HTTPServer
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/Component/Server 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/Component 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/POE 2>/dev/null || true
+@dirrm %%SITE_PERL%%/POE/Component/Server/HTTPServer
+@unexec rmdir %D/%%SITE_PERL%%/POE/Component/Server 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/POE/Component 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/POE 2>/dev/null || true