aboutsummaryrefslogtreecommitdiffstats
path: root/www/p5-POE-Component-Server-SimpleHTTP
diff options
context:
space:
mode:
authorlth <lth@FreeBSD.org>2007-01-11 03:46:42 +0800
committerlth <lth@FreeBSD.org>2007-01-11 03:46:42 +0800
commitbd71b3576930439676df945fb23b0ade79741caa (patch)
treeedc038be5309bcb74f816cd9e8dc04140cb534c3 /www/p5-POE-Component-Server-SimpleHTTP
parentf5b8053511b9fc9bed662cc17a34c99c535cc885 (diff)
downloadfreebsd-ports-gnome-bd71b3576930439676df945fb23b0ade79741caa.tar.gz
freebsd-ports-gnome-bd71b3576930439676df945fb23b0ade79741caa.tar.zst
freebsd-ports-gnome-bd71b3576930439676df945fb23b0ade79741caa.zip
Update to 1.15
Diffstat (limited to 'www/p5-POE-Component-Server-SimpleHTTP')
-rw-r--r--www/p5-POE-Component-Server-SimpleHTTP/Makefile14
-rw-r--r--www/p5-POE-Component-Server-SimpleHTTP/distinfo6
-rw-r--r--www/p5-POE-Component-Server-SimpleHTTP/files/patch-Makefile.PL23
3 files changed, 20 insertions, 23 deletions
diff --git a/www/p5-POE-Component-Server-SimpleHTTP/Makefile b/www/p5-POE-Component-Server-SimpleHTTP/Makefile
index d9c7dd28e9e6..98ddfbd070dd 100644
--- a/www/p5-POE-Component-Server-SimpleHTTP/Makefile
+++ b/www/p5-POE-Component-Server-SimpleHTTP/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= POE-Component-Server-SimpleHTTP
-PORTVERSION= 1.13
+PORTVERSION= 1.15
CATEGORIES= www perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -14,10 +14,10 @@ PKGNAMEPREFIX= p5-
MAINTAINER= lth@FreeBSD.org
COMMENT= Perl extension to serve HTTP requests in POE
-BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Storable.pm:${PORTSDIR}/devel/p5-Storable \
- ${SITE_PERL}/HTTP/Date.pm:${PORTSDIR}/www/p5-libwww \
- ${SITE_PERL}/POE.pm:${PORTSDIR}/devel/p5-POE
-RUN_DEPENDS= ${BUILD_DEPENDS}
+RUN_DEPENDS= p5-Storable>0:${PORTSDIR}/devel/p5-Storable \
+ p5-libwww>0:${PORTSDIR}/www/p5-libwww \
+ p5-POE>=0.38:${PORTSDIR}/devel/p5-POE
+BUILD_DEPENDS= ${RUN_DEPENDS}
PERL_CONFIGURE= yes
@@ -32,11 +32,11 @@ OPTIONS= SSL "SSL support (POE::Component::SSLify)" on \
.include <bsd.port.pre.mk>
.ifdef(WITH_SSL)
-BUILD_DEPENDS+= ${SITE_PERL}/POE/Component/SSLify.pm:${PORTSDIR}/security/p5-POE-Component-SSLify
+BUILD_DEPENDS+= p5-POE-Component-SSLify>=0.04:${PORTSDIR}/security/p5-POE-Component-SSLify
.endif
.ifdef(WITH_PREFORK)
-BUILD_DEPENDS+= ${SITE_PERL}/IPC/Shareable.pm:${PORTSDIR}/devel/p5-IPC-Shareable
+BUILD_DEPENDS+= p5-IPC-Shareable>0:${PORTSDIR}/devel/p5-IPC-Shareable
.endif
.if ${PERL_LEVEL} < 500600 # inherited from www/p5-libwww
diff --git a/www/p5-POE-Component-Server-SimpleHTTP/distinfo b/www/p5-POE-Component-Server-SimpleHTTP/distinfo
index 2c3aeecb19d9..8af3b1d3350c 100644
--- a/www/p5-POE-Component-Server-SimpleHTTP/distinfo
+++ b/www/p5-POE-Component-Server-SimpleHTTP/distinfo
@@ -1,3 +1,3 @@
-MD5 (POE-Component-Server-SimpleHTTP-1.13.tar.gz) = 67fc5cc0ac0dc7bfdfb226953df0c31d
-SHA256 (POE-Component-Server-SimpleHTTP-1.13.tar.gz) = a7f5cdbd8465d06d7379ecac53eb0d0675c038e25ad2a57903e068cf2d429129
-SIZE (POE-Component-Server-SimpleHTTP-1.13.tar.gz) = 22769
+MD5 (POE-Component-Server-SimpleHTTP-1.15.tar.gz) = d79fa9b0b608d17a80a2bbee99122bd1
+SHA256 (POE-Component-Server-SimpleHTTP-1.15.tar.gz) = 2355960a2d925500e66f45ec09486086fb4500f334e06d14c68837659fd3e5ec
+SIZE (POE-Component-Server-SimpleHTTP-1.15.tar.gz) = 31638
diff --git a/www/p5-POE-Component-Server-SimpleHTTP/files/patch-Makefile.PL b/www/p5-POE-Component-Server-SimpleHTTP/files/patch-Makefile.PL
index 1df0b70c092d..9493c57546d9 100644
--- a/www/p5-POE-Component-Server-SimpleHTTP/files/patch-Makefile.PL
+++ b/www/p5-POE-Component-Server-SimpleHTTP/files/patch-Makefile.PL
@@ -1,25 +1,22 @@
---- Makefile.PL.orig Wed Oct 12 11:21:00 2005
-+++ Makefile.PL Wed Oct 12 11:21:16 2005
-@@ -16,22 +16,6 @@
- 'HTTP::Response' => 0,
- };
+--- ./Makefile.PL.orig Sun Jan 7 11:18:22 2007
++++ ./Makefile.PL Wed Jan 10 20:07:51 2007
+@@ -17,19 +17,4 @@
+ requires 'HTTP::Request' => 0;
+ requires 'HTTP::Response' => 0;
-# Ask users if they want SSL support
--my $value = prompt( 'Do you want SSL support ( requires POE::Component::SSLify ) [Y/n]?', 'Y' );
+-my $value = prompt( 'Do you want SSL support ( requires POE::Component::SSLify ) [Y/n]?', 'N' );
-
-# Add to the prereqs PoCo::SSLify?
-if ( $value =~ /^Y$/i ) {
-- $prereqs->{ 'POE::Component::SSLify' } = '0.04';
+- requires 'POE::Component::SSLify' => '0.04';
-}
-
-# Ask users if they want PreFork support
--$value = prompt( 'Do you want PreFork support ( requires IPC::Shareable ) [Y/n]?', 'Y' );
+-$value = prompt( 'Do you want PreFork support ( requires IPC::Shareable ) [Y/n]?', 'N' );
-
-# Add to the prereqs IPC::Shareable?
-if ( $value =~ /^Y$/i ) {
-- $prereqs->{ 'IPC::Shareable' } = '0';
+- requires 'IPC::Shareable' => '0';
-}
--
- # See lib/ExtUtils/MakeMaker.pm for details of how to influence
- # the contents of the Makefile that is written.
- WriteMakefile(
+ WriteAll();