aboutsummaryrefslogtreecommitdiffstats
path: root/www/p5-RT-Extension-SLA/Makefile
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2008-12-15 04:09:57 +0800
committermiwi <miwi@FreeBSD.org>2008-12-15 04:09:57 +0800
commit74ade284116e1b7afb8af49559b8ba0edd1954c1 (patch)
tree15b7d23163de0e488887cd6280bfac72122e2528 /www/p5-RT-Extension-SLA/Makefile
parentfaed2396c0d836bd226cf1eafa648a87e1657c8d (diff)
downloadfreebsd-ports-gnome-74ade284116e1b7afb8af49559b8ba0edd1954c1.tar.gz
freebsd-ports-gnome-74ade284116e1b7afb8af49559b8ba0edd1954c1.tar.zst
freebsd-ports-gnome-74ade284116e1b7afb8af49559b8ba0edd1954c1.zip
RT's extension that allows you to automate due dates using service levels.
WWW: http://search.cpan.org/perldoc?RT::Extension::SLA PR: ports/126779 Submitted by: Matthew Seaman <m.seaman at infracaninophile.co.uk>
Diffstat (limited to 'www/p5-RT-Extension-SLA/Makefile')
-rw-r--r--www/p5-RT-Extension-SLA/Makefile39
1 files changed, 39 insertions, 0 deletions
diff --git a/www/p5-RT-Extension-SLA/Makefile b/www/p5-RT-Extension-SLA/Makefile
new file mode 100644
index 000000000000..56ad92866698
--- /dev/null
+++ b/www/p5-RT-Extension-SLA/Makefile
@@ -0,0 +1,39 @@
+# New ports collection Makefile for: RT-Extension-SLA
+# Date created: 23 August 2008
+# Whom: Matthew Seaman <m.seaman@infracaninophile.co.uk>
+#
+# $FreeBSD$
+#
+
+PORTNAME= RT-Extension-SLA
+PORTVERSION= 0.02
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= m.seaman@infracaninophile.co.uk
+COMMENT= RT extension to automate due dates using service levels
+
+BUILD_DEPENDS= ${LOCALBASE}/${RTHOME}/bin/rt:${PORTSDIR}/www/rt36 \
+ ${SITE_PERL}/Business/Hours.pm:${PORTSDIR}/misc/p5-Business-Hours
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+RTHOME?= rt3
+PLIST_SUB+= RTHOME=${RTHOME}
+
+PERL_CONFIGURE= yes
+CONFIGURE_ENV+= RTHOME=${PREFIX}/${RTHOME}
+
+MAN3PREFIX?= ${PREFIX}/${RTHOME}/local
+MAN3= RT::Action::SLA_SetDefault.3 \
+ RT::Condition::SLA_RequireDueSet.3 RT::Condition::SLA.3 \
+ RT::Condition::SLA_RequireDefault.3 RT::Extension::SLA.3 \
+ RT::Condition::SLA_RequireStartsSet.3 RT::Queue_SLA.3 \
+ RT::Action::SLA_SetStarts.3 RT::Action::SLA.3
+
+# Don't use normal CONFIGURE_ARGS
+do-configure:
+ @cd ${CONFIGURE_WRKSRC} && \
+ ${SETENV} ${CONFIGURE_ENV} ${PERL5} ./${CONFIGURE_SCRIPT}
+
+.include <bsd.port.mk>