aboutsummaryrefslogtreecommitdiffstats
path: root/www/p5-RT-Extension-SLA/Makefile
diff options
context:
space:
mode:
authorbeech <beech@FreeBSD.org>2009-01-25 14:21:14 +0800
committerbeech <beech@FreeBSD.org>2009-01-25 14:21:14 +0800
commitd9ada38f69c30b5e82ffd61d20911fdf2465d08c (patch)
tree484936b8628523eea6c2b0bdbdbe5b2b9509d127 /www/p5-RT-Extension-SLA/Makefile
parentc0b1c031451fbdb9f9949bc8f499f07ceb0ae434 (diff)
downloadfreebsd-ports-gnome-d9ada38f69c30b5e82ffd61d20911fdf2465d08c.tar.gz
freebsd-ports-gnome-d9ada38f69c30b5e82ffd61d20911fdf2465d08c.tar.zst
freebsd-ports-gnome-d9ada38f69c30b5e82ffd61d20911fdf2465d08c.zip
- Add OPTION to switch between dependency on www/rt36 or www/rt38
(www/rt38 is now the default) - Rename pkg-plist to pkg-plist.rt36 - Add new pkg-plist.rt38 PR: ports/130083 Submitted by: Matthew Seaman <m.seaman@infracaninophile.co.uk> (maintainer)
Diffstat (limited to 'www/p5-RT-Extension-SLA/Makefile')
-rw-r--r--www/p5-RT-Extension-SLA/Makefile38
1 files changed, 28 insertions, 10 deletions
diff --git a/www/p5-RT-Extension-SLA/Makefile b/www/p5-RT-Extension-SLA/Makefile
index 2dd9bc73b88a..d6864db17943 100644
--- a/www/p5-RT-Extension-SLA/Makefile
+++ b/www/p5-RT-Extension-SLA/Makefile
@@ -14,30 +14,48 @@ PKGNAMEPREFIX= p5-
MAINTAINER= m.seaman@infracaninophile.co.uk
COMMENT= RT extension to automate due dates using service levels
-BUILD_DEPENDS= ${LOCALBASE}/${RTHOME}/bin/rt:${PORTSDIR}/www/rt36 \
- ${SITE_PERL}/Business/Hours.pm:${PORTSDIR}/misc/p5-Business-Hours
+BUILD_DEPENDS= ${SITE_PERL}/Business/Hours.pm:${PORTSDIR}/misc/p5-Business-Hours
RUN_DEPENDS= ${BUILD_DEPENDS}
-RTHOME?= rt3
-PLIST_SUB+= RTHOME=${RTHOME}
+OPTIONS= RT36 "Install for rt-3.6.x (default rt-3.8.x)" off
PERL_CONFIGURE= yes
-CONFIGURE_ENV+= RTHOME=${PREFIX}/${RTHOME}
-MAN3PREFIX?= ${PREFIX}/${RTHOME}/local
MAN3= RT::Action::SLA_SetDefault.3 \
RT::Condition::SLA_RequireDueSet.3 RT::Condition::SLA.3 \
RT::Condition::SLA_RequireDefault.3 RT::Extension::SLA.3 \
RT::Condition::SLA_RequireStartsSet.3 RT::Queue_SLA.3 \
- RT::Action::SLA_SetStarts.3 RT::Action::SLA.3
+ RT::Action::SLA_SetStarts.3 RT::Action::SLA.3 \
+ RT::Action::SLA_SetDue.3
+
+PLIST_SUB+= RTHOME=${RTHOME}
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_RT36)
+
+RTHOME?= rt3
+RT_PM_DIR= ${LOCALBASE}/${RTHOME}/lib
+BUILD_DEPENDS+= ${RT_PM_DIR}/RT.pm:${PORTSDIR}/www/rt36
+PLIST= ${PKGDIR}/pkg-plist.rt36
+MAN3PREFIX= ${PREFIX}/${RTHOME}/local
+
+.else
+
+RTHOME?= share/rt38
+RT_PM_DIR= ${SITE_PERL}
+BUILD_DEPENDS+= ${RT_PM_DIR}/RT.pm:${PORTSDIR}/www/rt38
+PLIST= ${PKGDIR}/pkg-plist.rt38
+MAN3PREFIX= ${PREFIX}
+
+.endif
# Don't use normal CONFIGURE_ARGS. Disable doc_?????_indstall targets to
# suppress installing perllocal.pod. This duplicates code from bsd.perl.mk
# rather undesirably.
do-configure:
@cd ${CONFIGURE_WRKSRC} && \
- ${SETENV} ${CONFIGURE_ENV} ${PERL5} ./${CONFIGURE_SCRIPT} && \
+ ${SETENV} ${CONFIGURE_ENV} ${PERL5} -I${RT_PM_DIR} ./${CONFIGURE_SCRIPT} && \
${PERL5} -pi -e 's/ doc_(perl|site|\$$\(INSTALLDIRS\))_install$$//' Makefile
-
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>