aboutsummaryrefslogtreecommitdiffstats
path: root/www/p5-Reddit
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2012-04-19 04:00:30 +0800
committerehaupt <ehaupt@FreeBSD.org>2012-04-19 04:00:30 +0800
commita7cbc2c61557240b4796797af53d06e42c6391e5 (patch)
tree222f0810f9d70245b61b07ff73900378f6658811 /www/p5-Reddit
parentb97049a1d69868bf7a44d2b0e868b254a6282248 (diff)
downloadfreebsd-ports-gnome-a7cbc2c61557240b4796797af53d06e42c6391e5.tar.gz
freebsd-ports-gnome-a7cbc2c61557240b4796797af53d06e42c6391e5.tar.zst
freebsd-ports-gnome-a7cbc2c61557240b4796797af53d06e42c6391e5.zip
Add p5-Reddit, a perl module for interacting with Reddit.
Diffstat (limited to 'www/p5-Reddit')
-rw-r--r--www/p5-Reddit/Makefile31
-rw-r--r--www/p5-Reddit/distinfo2
-rw-r--r--www/p5-Reddit/pkg-descr3
-rw-r--r--www/p5-Reddit/pkg-plist7
4 files changed, 43 insertions, 0 deletions
diff --git a/www/p5-Reddit/Makefile b/www/p5-Reddit/Makefile
new file mode 100644
index 000000000000..45b264f5a0ca
--- /dev/null
+++ b/www/p5-Reddit/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: p5-Reddit
+# Date created: 18 Apr 2012
+# Whom: Emanuel Haupt <ehaupt@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Reddit
+PORTVERSION= 0.3.02.20120418
+CATEGORIES= www perl5
+MASTER_SITES= CRITICAL
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= ehaupt@FreeBSD.org
+COMMENT= Module for interacting with Reddit
+
+BUILD_DEPENDS= ${SITE_PERL}/Module/Install.pm:${PORTSDIR}/devel/p5-Module-Install \
+ p5-Moose>=0:${PORTSDIR}/devel/p5-Moose \
+ p5-ExtUtils-MakeMaker>=6.42:${PORTSDIR}/devel/p5-ExtUtils-MakeMaker \
+ p5-common-sense>=3.2:${PORTSDIR}/devel/p5-common-sense
+RUN_DEPENDS= p5-Moose>=0:${PORTSDIR}/devel/p5-Moose \
+ p5-common-sense>=3.2:${PORTSDIR}/devel/p5-common-sense \
+ p5-JSON>=2:${PORTSDIR}/converters/p5-JSON \
+ p5-HTTP-Cookies>=6:${PORTSDIR}/www/p5-HTTP-Cookies \
+ p5-libwww>=5.829:${PORTSDIR}/www/p5-libwww
+
+PERL_CONFIGURE= yes
+
+MAN3= Reddit.3
+
+.include <bsd.port.mk>
diff --git a/www/p5-Reddit/distinfo b/www/p5-Reddit/distinfo
new file mode 100644
index 000000000000..5a9d0cea41df
--- /dev/null
+++ b/www/p5-Reddit/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Reddit-0.3.02.20120418.tar.gz) = a48ad8df25f197a60c94be21c0f3671ec390f92ae43c670738822b178e49f93f
+SIZE (Reddit-0.3.02.20120418.tar.gz) = 5735
diff --git a/www/p5-Reddit/pkg-descr b/www/p5-Reddit/pkg-descr
new file mode 100644
index 000000000000..f4533cdd69fa
--- /dev/null
+++ b/www/p5-Reddit/pkg-descr
@@ -0,0 +1,3 @@
+Perl module for interacting with Reddit.
+
+WWW: https://github.com/three18ti/Reddit.pm
diff --git a/www/p5-Reddit/pkg-plist b/www/p5-Reddit/pkg-plist
new file mode 100644
index 000000000000..c09659916106
--- /dev/null
+++ b/www/p5-Reddit/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/Reddit.pm
+%%SITE_PERL%%/Reddit/Type/User.pm
+%%SITE_PERL%%/Reddit/Type/Subreddit.pm
+%%SITE_PERL%%/mach/auto/Reddit/.packlist
+@dirrm %%SITE_PERL%%/mach/auto/Reddit
+@dirrm %%SITE_PERL%%/Reddit/Type
+@dirrm %%SITE_PERL%%/Reddit