aboutsummaryrefslogtreecommitdiffstats
path: root/www/p5-STF-Dispatcher-PSGI
diff options
context:
space:
mode:
authorkuriyama <kuriyama@FreeBSD.org>2011-12-31 17:31:00 +0800
committerkuriyama <kuriyama@FreeBSD.org>2011-12-31 17:31:00 +0800
commitd22ba58eabebfe9fad993430fbf01e1009fc42a3 (patch)
treeb10da77e681658d500d8aebb6d97b51ab0431ce4 /www/p5-STF-Dispatcher-PSGI
parent105fa49a40d7d20bcf15b18bfa78aaf2696f7457 (diff)
downloadfreebsd-ports-gnome-d22ba58eabebfe9fad993430fbf01e1009fc42a3.tar.gz
freebsd-ports-gnome-d22ba58eabebfe9fad993430fbf01e1009fc42a3.tar.zst
freebsd-ports-gnome-d22ba58eabebfe9fad993430fbf01e1009fc42a3.zip
STF::Dispatcher::PSGI implements the basic STF Protocol
(http://stf-storage.github.com) dispatcher component. It does not know how to actually store or retrieve data, so you must implement that portion yourself. The reason this exists is mainly to allow you to testing systems that interact with STF servers. For example, setting up the main STF implementation is quite a pain if all you want to do is to test your application, but with this module, you can easily create a dummy STF dispatcher. WWW: http://search.cpan.org/dist/STF-Dispatcher-PSGI/
Diffstat (limited to 'www/p5-STF-Dispatcher-PSGI')
-rw-r--r--www/p5-STF-Dispatcher-PSGI/Makefile33
-rw-r--r--www/p5-STF-Dispatcher-PSGI/distinfo2
-rw-r--r--www/p5-STF-Dispatcher-PSGI/pkg-descr12
-rw-r--r--www/p5-STF-Dispatcher-PSGI/pkg-plist13
4 files changed, 60 insertions, 0 deletions
diff --git a/www/p5-STF-Dispatcher-PSGI/Makefile b/www/p5-STF-Dispatcher-PSGI/Makefile
new file mode 100644
index 000000000000..d1992fe26697
--- /dev/null
+++ b/www/p5-STF-Dispatcher-PSGI/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: STF::Dispatcher::PSGI
+# Date created: 31 Dec 2011
+# Whom: Jun Kuriyama <kuriyama@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= STF-Dispatcher-PSGI
+PORTVERSION= 1.07
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= ../../authors/id/D/DM/DMAKI
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= kuriyama@FreeBSD.org
+COMMENT= Perl extension for pluggable STF dispatcher interface
+
+RUN_DEPENDS= \
+ p5-Class-Accessor-Lite>0:${PORTSDIR}/devel/p5-Class-Accessor-Lite \
+ p5-HTTP-Date>0:${PORTSDIR}/www/p5-HTTP-Date \
+ p5-Plack>0:${PORTSDIR}/www/p5-Plack \
+ p5-Plack-Middleware-Header>0:${PORTSDIR}/www/p5-Plack-Middleware-Header
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= STF::Dispatcher::Impl::File.3 \
+ STF::Dispatcher::Impl::Hash.3 \
+ STF::Dispatcher::PSGI.3 \
+ STF::Dispatcher::PSGI::HTTPException.3 \
+ STF::Dispatcher::Test.3
+
+.include <bsd.port.mk>
diff --git a/www/p5-STF-Dispatcher-PSGI/distinfo b/www/p5-STF-Dispatcher-PSGI/distinfo
new file mode 100644
index 000000000000..8b03c20d0c2d
--- /dev/null
+++ b/www/p5-STF-Dispatcher-PSGI/distinfo
@@ -0,0 +1,2 @@
+SHA256 (STF-Dispatcher-PSGI-1.07.tar.gz) = e22ec2896ac3deadeca0b60ede815c100c0faca4af9cdf274686d2aa28865717
+SIZE (STF-Dispatcher-PSGI-1.07.tar.gz) = 25350
diff --git a/www/p5-STF-Dispatcher-PSGI/pkg-descr b/www/p5-STF-Dispatcher-PSGI/pkg-descr
new file mode 100644
index 000000000000..f8edfd610801
--- /dev/null
+++ b/www/p5-STF-Dispatcher-PSGI/pkg-descr
@@ -0,0 +1,12 @@
+STF::Dispatcher::PSGI implements the basic STF Protocol
+(http://stf-storage.github.com) dispatcher component. It does not know
+how to actually store or retrieve data, so you must implement that
+portion yourself.
+
+The reason this exists is mainly to allow you to testing systems that
+interact with STF servers. For example, setting up the main STF
+implementation is quite a pain if all you want to do is to test your
+application, but with this module, you can easily create a dummy STF
+dispatcher.
+
+WWW: http://search.cpan.org/dist/STF-Dispatcher-PSGI/
diff --git a/www/p5-STF-Dispatcher-PSGI/pkg-plist b/www/p5-STF-Dispatcher-PSGI/pkg-plist
new file mode 100644
index 000000000000..fa7a950cfd92
--- /dev/null
+++ b/www/p5-STF-Dispatcher-PSGI/pkg-plist
@@ -0,0 +1,13 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/STF/Dispatcher/PSGI/.packlist
+%%SITE_PERL%%/STF/Dispatcher/Impl/File.pm
+%%SITE_PERL%%/STF/Dispatcher/Impl/Hash.pm
+%%SITE_PERL%%/STF/Dispatcher/PSGI.pm
+%%SITE_PERL%%/STF/Dispatcher/PSGI/HTTPException.pm
+%%SITE_PERL%%/STF/Dispatcher/Test.pm
+@dirrm %%SITE_PERL%%/STF/Dispatcher/PSGI
+@dirrm %%SITE_PERL%%/STF/Dispatcher/Impl
+@dirrm %%SITE_PERL%%/STF/Dispatcher
+@dirrm %%SITE_PERL%%/STF
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/STF/Dispatcher/PSGI
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/STF/Dispatcher
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/STF