aboutsummaryrefslogtreecommitdiffstats
path: root/www/p5-Squatting
diff options
context:
space:
mode:
authortobez <tobez@FreeBSD.org>2008-07-07 20:46:25 +0800
committertobez <tobez@FreeBSD.org>2008-07-07 20:46:25 +0800
commit52c6f4e9d415b6d6ecdd51cadb4ff9b3688ecbef (patch)
tree448b14f0c6aad23c11f0ca228f037929c2c763ce /www/p5-Squatting
parentcbb19d7113b6ef8d053fc79d9e98bb186737005e (diff)
downloadfreebsd-ports-gnome-52c6f4e9d415b6d6ecdd51cadb4ff9b3688ecbef.tar.gz
freebsd-ports-gnome-52c6f4e9d415b6d6ecdd51cadb4ff9b3688ecbef.tar.zst
freebsd-ports-gnome-52c6f4e9d415b6d6ecdd51cadb4ff9b3688ecbef.zip
Add www/p5-Squatting:
Squatting is a web microframework written in Perl that is based on Ruby's Camping. It originally used Continuity as its foundation, but it has since been generalized such that it can squat on top of any Perl-based web framework (in theory). WWW: http://search.cpan.org/dist/Squatting/
Diffstat (limited to 'www/p5-Squatting')
-rw-r--r--www/p5-Squatting/Makefile37
-rw-r--r--www/p5-Squatting/distinfo3
-rw-r--r--www/p5-Squatting/pkg-descr6
-rw-r--r--www/p5-Squatting/pkg-plist13
4 files changed, 59 insertions, 0 deletions
diff --git a/www/p5-Squatting/Makefile b/www/p5-Squatting/Makefile
new file mode 100644
index 000000000000..6295defd5c08
--- /dev/null
+++ b/www/p5-Squatting/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: www/p5-Squatting
+# Date created: 07 July 2008
+# Whom: Anton Berezin <tobez@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Squatting
+PORTVERSION= 0.40
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= ../by-authors/id/B/BE/BEPPU
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= tobez@FreeBSD.org
+COMMENT= A Camping-inspired Web Microframework for Perl
+
+BUILD_DEPENDS= p5-Continuity>=0.991:${PORTSDIR}/www/p5-Continuity \
+ p5-Class-C3-Componentised>0:${PORTSDIR}/devel/p5-Class-C3-Componentised \
+ p5-Data-Dump>0:${PORTSDIR}/devel/p5-Data-Dump \
+ p5-Shell-Perl>0:${PORTSDIR}/shells/p5-Shell-Perl \
+ p5-JSON-XS>0:${PORTSDIR}/converters/p5-JSON-XS \
+ p5-libwww>0:${PORTSDIR}/www/p5-libwww
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= 5.8.0+
+
+MAN1= squatting.1
+MAN3= Squatting.3 \
+ Squatting::Controller.3 \
+ Squatting::Cookbook.3 \
+ Squatting::Mapper.3 \
+ Squatting::On::Catalyst.3 \
+ Squatting::On::Continuity.3 \
+ Squatting::View.3
+
+.include <bsd.port.mk>
diff --git a/www/p5-Squatting/distinfo b/www/p5-Squatting/distinfo
new file mode 100644
index 000000000000..1be17d3a1807
--- /dev/null
+++ b/www/p5-Squatting/distinfo
@@ -0,0 +1,3 @@
+MD5 (Squatting-0.40.tar.gz) = d0c0cbe2a868b377d50bad9c142be203
+SHA256 (Squatting-0.40.tar.gz) = 049109162860dfb203fbee9e042477c9fffd82e8ae6e4013c04eb83e23fd89db
+SIZE (Squatting-0.40.tar.gz) = 61161
diff --git a/www/p5-Squatting/pkg-descr b/www/p5-Squatting/pkg-descr
new file mode 100644
index 000000000000..8a08d9e186a7
--- /dev/null
+++ b/www/p5-Squatting/pkg-descr
@@ -0,0 +1,6 @@
+Squatting is a web microframework written in Perl that is based on
+Ruby's Camping. It originally used Continuity as its foundation, but it
+has since been generalized such that it can squat on top of any
+Perl-based web framework (in theory).
+
+WWW: http://search.cpan.org/dist/Squatting/
diff --git a/www/p5-Squatting/pkg-plist b/www/p5-Squatting/pkg-plist
new file mode 100644
index 000000000000..02f09c12c7c4
--- /dev/null
+++ b/www/p5-Squatting/pkg-plist
@@ -0,0 +1,13 @@
+bin/squatting
+bin/vw
+%%SITE_PERL%%/Squatting.pm
+%%SITE_PERL%%/Squatting/Controller.pm
+%%SITE_PERL%%/Squatting/Cookbook.pod
+%%SITE_PERL%%/Squatting/Mapper.pm
+%%SITE_PERL%%/Squatting/On/Catalyst.pm
+%%SITE_PERL%%/Squatting/On/Continuity.pm
+%%SITE_PERL%%/Squatting/View.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Squatting/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Squatting
+@dirrmtry %%SITE_PERL%%/Squatting/On
+@dirrmtry %%SITE_PERL%%/Squatting